Установить старую версию порта

Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.

Ответить


Этот вопрос предназначен для предотвращения автоматической отправки форм спам-ботами.
Смайлики
:smile: :( ;-) :roll: :pardon: 8) :x :oops: :shock: :cz2: :-D :ROFL: :Yahoo!: :cry: :Search: :Bravo: :good: :bad: :sorry: :no: :unknown: :evil: :crazy: :"": :fool: :-o :drinks: :st: :bn:
Ещё смайлики…

BBCode ВКЛЮЧЁН
[img] ВКЛЮЧЁН
[flash] ОТКЛЮЧЕН
[url] ВКЛЮЧЁН
Смайлики ВКЛЮЧЕНЫ

Обзор темы
   

Если вы не хотите добавлять вложения, оставьте поля пустыми.

Развернуть Обзор темы: Установить старую версию порта

Установить старую версию порта

Сообщение basov » 2016-02-05 11:59:32

basov писал(а):что можно сделать без обновления системы?
не хотелось бы вносить лишние изменения в рабочую систему, однако нужно кое-что доустановить...

Всё, уже сам разобрался.
Посмотрел какая версия была в оригинальной версии после установки.
Скачал и установил.

Установить старую версию порта

Сообщение basov » 2016-02-04 13:19:46

Может кто знает, как поставить старую версию portdowngrade? потому что у меня при попытке его установки вылетает ошибка:

Код: Выделить всё

Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
"/usr/ports/Mk/bsd.sites.mk", line 991: Malformed conditional (!empty(_PERL_CPAN_ID) && ${_PERL_CPAN_FLAG:tl} == "cpan")
Unknown modifier 't'
Unknown modifier 't'
"/usr/ports/Mk/bsd.port.mk", line 3042: warning: Missing closing parenthesis for defined()
Unknown modifier 't'
"/usr/ports/Mk/bsd.port.mk", line 3042: Malformed conditional (((!defined(OPTIONS_DEFINE) && !defined(OPTIONS_SINGLE) && !defined(OPTIONS_MULTI))  && !defined(OPTIONS_GROUP) && !defined(OPTIONS_RADIO)  || defined(CONFIG_DONE_${UNIQUENAME:tu}) ||  defined(PACKAGE_BUILDING) || defined(BATCH)))
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
Unknown modifier 't'
5 open conditionals:
              at line 6028 (skipped)
             at line 6028 (evaluated to false)
            at line 6028 (evaluated to true)
           at line 6028 (evaluated to true)
          at line 6028 (evaluated to true)
make: fatal errors encountered -- cannot continue

что можно сделать без обновления системы?
не хотелось бы вносить лишние изменения в рабочую систему, однако нужно кое-что доустановить...

Re: Установить старую версию порта

Сообщение Dog » 2010-07-20 15:30:00

Что именно откатываешь, какой конкретно порт? Что в Makefile после portdowngrade?

Re: Установить старую версию порта

Сообщение dagor » 2010-07-20 15:23:26

dagor писал(а):Попробовал откатить QT4,portdowngrade,порт выглядит нормально,но почемуто хочет все равно ставить 4.6.3 вместо прописанного 4.6.2 :(

Так мне никто ничего и не ответил,а я так и не могу откатить порт,в самой директории все хорошо,но при попытке собрать,оно все равно пытается поставить свежак. ;(

Re: Установить старую версию порта

Сообщение dagor » 2010-06-24 18:31:00

Попробовал откатить QT4,portdowngrade,порт выглядит нормально,но почемуто хочет все равно ставить 4.6.3 вместо прописанного 4.6.2 :(

Re: Установить старую версию порта

Сообщение Shuba » 2010-06-18 11:16:27

Почитай здесь

Установить старую версию порта

Сообщение dagor » 2010-06-18 1:25:22

Поставил тут новую версию qbittorrent(2.2.9),а она зараза вместе с rblibtorrent не хочет нормально раздавать,2.2.8 с 14.10 rblibtorrent раздавала хорошо если включить ограничение,без ограничения раздавала плохо,тут обновил,раздает хреново,а как вернутся не понятно,подскажите плиз.

Вернуться к началу