не могу не один порт обновить

Проблемы с установкой, настройкой и работой системных и сетевых программ.

Модераторы: GRooVE, alexco

Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
bagas
лейтенант
Сообщения: 913
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

не могу не один порт обновить

Непрочитанное сообщение bagas » 2017-11-18 17:38:47

Добрый вечер.
Не могу не один порт обновить, помогите пожалуйста.

Код: Выделить всё

root@1a:/usr/ports/www/nginx # make reinstall clean
===>  Installing for nginx-1.12.2_1,2
===>   nginx-1.12.2_1,2 depends on shared library: libpcre.so - found (/usr/local/lib/libpcre.so)
===>   Registering installation for nginx-1.12.2_1,2
pkg-static: Warning: @exec is deprecated, please use @[pre|post][un]exec
*** Error code 70

Stop.
make[2]: stopped in /usr/ports/www/nginx
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/www/nginx
*** Error code 1

Stop.
make: stopped in /usr/ports/www/nginx
root@1a:/usr/ports/www/nginx #

Код: Выделить всё

root@1a:/usr/ports/editors/nano # make reinstall clean
===>  Installing for nano-2.8.7
===>   nano-2.8.7 depends on executable: indexinfo - found
===>   nano-2.8.7 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   Registering installation for nano-2.8.7
*** Error code 70

Stop.
make[2]: stopped in /usr/ports/editors/nano
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/editors/nano
*** Error code 1

Stop.
make: stopped in /usr/ports/editors/nano
root@1a:/usr/ports/editors/nano #

через

Код: Выделить всё

# portupgrade -arR
# portupgrade -fr nginx

так работает, подскажите что я упускаю из виду.
Порты обновлены.
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

Аватара пользователя
Amaka
ефрейтор
Сообщения: 62
Зарегистрирован: 2016-02-03 12:05:11
Откуда: Москва

не могу не один порт обновить

Непрочитанное сообщение Amaka » 2017-11-20 17:18:10

А какая версия ОС?
Всем удачи!

Аватара пользователя
bagas
лейтенант
Сообщения: 913
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

не могу не один порт обновить

Непрочитанное сообщение bagas » 2017-11-20 18:10:47

Amaka писал(а):А какая версия ОС?

Что вам даст версия ОС?

Код: Выделить всё

# uname -rm
11.0-RELEASE-p15 amd64
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

Аватара пользователя
Amaka
ефрейтор
Сообщения: 62
Зарегистрирован: 2016-02-03 12:05:11
Откуда: Москва

не могу не один порт обновить

Непрочитанное сообщение Amaka » 2017-11-20 18:21:15

Какая версия pkg? Сделай (portsnap fetch update).Какие ошибки показывает команда (pkg check -Bda):

Код: Выделить всё

pkg -v
portsnap fetch update
pkg check -Bda
Всем удачи!

Аватара пользователя
bagas
лейтенант
Сообщения: 913
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

не могу не один порт обновить

Непрочитанное сообщение bagas » 2017-11-20 19:52:00

Amaka писал(а):Какая версия pkg? Сделай (portsnap fetch update).Какие ошибки показывает команда (pkg check -Bda):

Код: Выделить всё

pkg -v
portsnap fetch update
pkg check -Bda

Код: Выделить всё

# pkg -v
1.10.2
# pkg check -Bda
Checking all packages: 100%
#

Везде код ошибки одинаков Error code 70

Код: Выделить всё

install  -m 0644 /usr/ports/editors/nano/work/nano-2.8.7/doc/sample.nanorc /usr/ports/editors/nano/work/stage/usr/local/share/examples/nano
====> Compressing man pages (compress-man)
===>  Installing for nano-2.8.7
===>   Registering installation for nano-2.8.7
*** Error code 70

Stop.
make[2]: stopped in /usr/ports/editors/nano
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/editors/nano
*** Error code 1

Stop.
make: stopped in /usr/ports/editors/nano

Код: Выделить всё

root@1a:/usr/ports/www/nginx # make reinstall clean
===>  Installing for nginx-1.12.2_1,2
===>   nginx-1.12.2_1,2 depends on shared library: libpcre.so - found (/usr/local/lib/libpcre.so)
===>   Registering installation for nginx-1.12.2_1,2
pkg-static: Warning: @exec is deprecated, please use @[pre|post][un]exec
*** Error code 70

Stop.
make[2]: stopped in /usr/ports/www/nginx
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/www/nginx
*** Error code 1

Stop.
make: stopped in /usr/ports/www/nginx
root@1a:/usr/ports/www/nginx #
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

Аватара пользователя
Amaka
ефрейтор
Сообщения: 62
Зарегистрирован: 2016-02-03 12:05:11
Откуда: Москва

не могу не один порт обновить

Непрочитанное сообщение Amaka » 2017-11-21 10:21:26

Что-то было у меня подобное.
Если правильно помню, если порты зависят от каких-то библиотек, также нуждающихся в обновлении.
Например твои nginx и nano зависят от: pcre, indexinfo, gettext.
Всем удачи!

Аватара пользователя
bagas
лейтенант
Сообщения: 913
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

не могу не один порт обновить

Непрочитанное сообщение bagas » 2017-11-21 11:56:28

Amaka писал(а):Что-то было у меня подобное.
Если правильно помню, если порты зависят от каких-то библиотек, также нуждающихся в обновлении.
Например твои nginx и nano зависят от: pcre, indexinfo, gettext.

Не думаю, так как весь софт на сервере пересобирал.
portupgrade -arRf
Мне кажется что то с базой установленного софта.
Свежий софт ставится из портов нормально make install clean
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

Аватара пользователя
Amaka
ефрейтор
Сообщения: 62
Зарегистрирован: 2016-02-03 12:05:11
Откуда: Москва

не могу не один порт обновить

Непрочитанное сообщение Amaka » 2017-11-21 12:21:43

Тогда попробуй так:

Код: Выделить всё

cd  /usr/ports/editors/nano
make deinstall
make install clean
Всем удачи!

Аватара пользователя
bagas
лейтенант
Сообщения: 913
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

не могу не один порт обновить

Непрочитанное сообщение bagas » 2017-11-21 12:46:01

Amaka писал(а):Тогда попробуй так:

Код: Выделить всё

cd  /usr/ports/editors/nano
make deinstall
make install clean

Это не дело.
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

Аватара пользователя
Amaka
ефрейтор
Сообщения: 62
Зарегистрирован: 2016-02-03 12:05:11
Откуда: Москва

не могу не один порт обновить

Непрочитанное сообщение Amaka » 2017-11-21 12:50:09

А что смущает?
Если не поможет, то всегда можно сделать: pkg install nano.
Всем удачи!

Аватара пользователя
bagas
лейтенант
Сообщения: 913
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

не могу не один порт обновить

Непрочитанное сообщение bagas » 2017-11-21 13:18:29

Amaka писал(а):А что смущает?
Если не поможет, то всегда можно сделать: pkg install nano.

Меня не смущает, а напрягает такой вариант ), это мне каждый софт что ле удалять, пересобирать, это не дело.
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

Аватара пользователя
Amaka
ефрейтор
Сообщения: 62
Зарегистрирован: 2016-02-03 12:05:11
Откуда: Москва

не могу не один порт обновить

Непрочитанное сообщение Amaka » 2017-11-21 15:16:24

А как по другому?
Во FreeBSD эта проблема появилась года 2-3. Раньше проблем с обновлением было по-меньше. Никуда от этого не деться. У меня во многих случаях пришлось сначала удалять порт ( pkg delete 'portname' ), потом ставить заново... :-(
Всем удачи!

Аватара пользователя
xM
ст. лейтенант
Сообщения: 1210
Зарегистрирован: 2009-01-15 23:57:41
Откуда: Königsberg
Контактная информация:

не могу не один порт обновить

Непрочитанное сообщение xM » 2017-11-21 15:30:12

У вас, похоже, что-то в самом дереве портов в районе *.mk файлов покривилось.
pkg-static: Warning: @exec is deprecated, please use @[pre|post][un]exec

Попробуйте снести порты rm -rf /usr/ports и вновь скачать его portsnap fetch && portsnap extract
IT voodoo blog https://kostikov.co

Аватара пользователя
bagas
лейтенант
Сообщения: 913
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

не могу не один порт обновить

Непрочитанное сообщение bagas » 2017-11-21 16:00:30

Amaka писал(а):А как по другому?
Во FreeBSD эта проблема появилась года 2-3. Раньше проблем с обновлением было по-меньше. Никуда от этого не деться. У меня во многих случаях пришлось сначала удалять порт ( pkg delete 'portname' ), потом ставить заново... :-(

Я лет 6-8 использую фряху, не было таких проблем раньше.

Отправлено спустя 34 секунды:
xM писал(а):У вас, похоже, что-то в самом дереве портов в районе *.mk файлов покривилось.
pkg-static: Warning: @exec is deprecated, please use @[pre|post][un]exec

Попробуйте снести порты rm -rf /usr/ports и вновь скачать его portsnap fetch && portsnap extract

Хмм, возможно, попробую.
Спасибо всем.
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

Аватара пользователя
Amaka
ефрейтор
Сообщения: 62
Зарегистрирован: 2016-02-03 12:05:11
Откуда: Москва

не могу не один порт обновить

Непрочитанное сообщение Amaka » 2017-12-01 11:50:10

xM писал(а):У вас, похоже, что-то в самом дереве портов в районе *.mk файлов покривилось.
...
Попробуйте снести порты rm -rf /usr/ports и вновь скачать его portsnap fetch && portsnap extract

Добрый день!
Попробовал ваши рекомендации:

Код: Выделить всё

rm -rf /usr/ports
portsnap fetch && portsnap extract

Все получилось.
При make reinstall, порблема "Error code 70" решена.
Всем удачи!

Аватара пользователя
Amaka
ефрейтор
Сообщения: 62
Зарегистрирован: 2016-02-03 12:05:11
Откуда: Москва

не могу не один порт обновить

Непрочитанное сообщение Amaka » 2017-12-25 13:14:19

Снова проблема с обновлением. Только уже на другом сервере:

Код: Выделить всё

root@rim:/usr/ports # uname -a
FreeBSD rim.alfastrah.ru 11.1-RELEASE-p4 FreeBSD 11.1-RELEASE-p4 #0: Tue Nov 14 06:12:40 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
root@rim:/usr/ports # cd /usr/ports/ports-mgmt/pkg


root@rim:/usr/ports/ports-mgmt/pkg # make clean
===>  Cleaning for pkg-1.10.3_1


root@rim:/usr/ports/ports-mgmt/pkg # make
/!\ ERROR: /!\

Ports Collection support for your FreeBSD version has ended, and no ports are
guaranteed to build on this system. Please upgrade to a supported release.

No support will be provided if you silence this message by defining
ALLOW_UNSUPPORTED_SYSTEM.

*** Error code 1

Stop.
make: stopped in /usr/ports/ports-mgmt/pkg


root@rim:/usr/ports # make clean reinstall -D ALLOW_UNSUPPORTED_SYSTEM

/usr/bin/make  install-data-hook
ln -s -f pkg-delete.8  /usr/ports/ports-mgmt/pkg/work/stage/usr/local/man/man8/pkg-remove.8
ln -s -f pkg-lock.8  /usr/ports/ports-mgmt/pkg/work/stage/usr/local/man/man8/pkg-unlock.8
ln -s -f pkg.8  /usr/ports/ports-mgmt/pkg/work/stage/usr/local/man/man8/pkg-static.8
 /bin/mkdir -p '/usr/ports/ports-mgmt/pkg/work/stage/usr/local/libdata/pkgconfig'
 install  -m 0644 libpkg/pkg.pc '/usr/ports/ports-mgmt/pkg/work/stage/usr/local/libdata/pkgconfig'
install  -m 0644 /usr/ports/ports-mgmt/pkg/work/pkg-1.10.3/NEWS /usr/ports/ports-mgmt/pkg/work/stage/usr/local/share/doc/pkg/NEWS
====> Compressing man pages (compress-man)
===>  Installing for pkg-1.10.3_1
===>   Registering installation for pkg-1.10.3_1
*** Error code 70

Stop.
make[2]: stopped in /usr/ports/ports-mgmt/pkg
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/ports-mgmt/pkg
*** Error code 1

Stop.



ЧТО ДЕЛАТЬ??????

Отправлено спустя 57 минут 19 секунд:
Посмотрел на форум: https://forums.freebsd.org/.
Там рекомендуют посмотреть содержимое файла: /usr/include/sys/param.h
Смотрю у себя. Вижу там:

Код: Выделить всё

#undef __FreeBSD_version
#define __FreeBSD_version 1100122       /* Master, propagated to newvers */

моя система:

Код: Выделить всё

# uname -a
FreeBSD rim 11.1-RELEASE-p4 FreeBSD 11.1-RELEASE-p4 #0: Tue Nov 14 06:12:40 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64

Думаю, а что должно быть?
Смотрю на другой свой сервер:

Код: Выделить всё

root@relay7:/home/amakarenko # uname -a
FreeBSD roma 11.1-RELEASE-p1 FreeBSD 11.1-RELEASE-p1 #0: Wed Aug  9 11:55:48 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64

# less /usr/include/sys/param.h

#undef __FreeBSD_version
#define __FreeBSD_version 1101001       /* Master, propagated to newvers */


Неужели мне нужно поменять значение версии 1100122 на реальное? 1100122 -> 1101004 ?
Сделал и все заработало.
Обновления стали устанавливаться...
Как и почему во FREEBSD выпущено неотлаженное обновление???? Это теперь всегда так будет??? Лет 6-8 назад такого не было. Куда катится мир?...
Всем удачи!


Вернуться в «Софт»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 7 гостей