py27-josepy-1.0.1 conflicts with py27-acme-0.20.0,1

Проблемы с установкой, настройкой и работой системных и сетевых программ.

Модераторы: GRooVE, alexco

Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
bagas
лейтенант
Сообщения: 913
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

py27-josepy-1.0.1 conflicts with py27-acme-0.20.0,1

Непрочитанное сообщение bagas » 2018-01-29 13:45:00

Добрый день, возникла ошибка при обновлении софта.
Помогите пожалуйста решить ее.

Код: Выделить всё

byte-compiling /usr/ports/security/py-josepy/work-py27/stage/usr/local/lib/python2.7/site-packages/josepy/jwk_test.py to jwk_test.pyc
writing byte-compilation script '/tmp/tmpEhVmyD.py'
/usr/local/bin/python2.7 -O /tmp/tmpEhVmyD.py
removing /tmp/tmpEhVmyD.py
running install_egg_info
Copying src/josepy.egg-info to /usr/ports/security/py-josepy/work-py27/stage/usr/local/lib/python2.7/site-packages/josepy-1.0.1-py2.7.egg-info
running install_scripts
Installing jws script to /usr/ports/security/py-josepy/work-py27/stage/usr/local/bin
writing list of installed files to '/usr/ports/security/py-josepy/work-py27/.PLIST.pymodtmp'
====> Compressing man pages (compress-man)
===>  Installing for py27-josepy-1.0.1
===>  Checking if py27-josepy already installed
===>   Registering installation for py27-josepy-1.0.1 as automatic
[far_ru] Installing py27-josepy-1.0.1...
pkg-static: py27-josepy-1.0.1 conflicts with py27-acme-0.20.0,1 (installs files into the same place).  Problematic file: /usr/local/bin/jws
*** Error code 70

Stop.
make[1]: stopped in /usr/ports/security/py-josepy
*** Error code 1

Stop.
make: stopped in /usr/ports/security/py-acme
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20180129-86159-l0kgli env UPGRADE_TOOL=portupgrade UPGRADE_PORT=py27-acme-0.20.0,1 UPGRADE_PORT_VER=0.20.0,1 make
** Fix the problem and try again.
--->  Skipping 'security/py-certbot' (py27-certbot-0.20.0,1) because a requisite package 'py27-acme-0.20.0,1' (security/py-acme) failed (specify -k to force)
** Listing the failed packages (-:ignored / *:skipped / !:failed)
   ! security/py-acme (py27-acme-0.20.0,1)   (unknown build error)
   * security/py-certbot (py27-certbot-0.20.0,1)
root@far_ru:/ #

Как быть в таком случае?
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

Аватара пользователя
xM
ст. лейтенант
Сообщения: 1210
Зарегистрирован: 2009-01-15 23:57:41
Откуда: Königsberg
Контактная информация:

py27-josepy-1.0.1 conflicts with py27-acme-0.20.0,1

Непрочитанное сообщение xM » 2018-01-29 19:20:02

# portsnap auto
# portmaster security/py-certbot
IT voodoo blog https://kostikov.co

Аватара пользователя
bagas
лейтенант
Сообщения: 913
Зарегистрирован: 2010-08-18 19:49:01
Откуда: Воронеж
Контактная информация:

py27-josepy-1.0.1 conflicts with py27-acme-0.20.0,1

Непрочитанное сообщение bagas » 2018-01-30 8:04:04

решил проблему, удалил py-acme и после пересобрал py-certbot, все нормально.
Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.


Вернуться в «Софт»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 13 гостей