Внимание обновление pkg 1.3.7

Обсуждение всяких разных новостей.
Аватара пользователя
f_andrey
майор
Сообщения: 2629
Зарегистрирован: 2007-12-26 1:22:58
Откуда: СПб
Контактная информация:

Внимание обновление pkg 1.3.7

Непрочитанное сообщение f_andrey » 2014-08-27 9:20:01

Выпущен pkg 1.3.7, в нём переработана система определения зависимостей, в связи с этим необходимо соблюдать некоторые меры при обновлении.

Для тех кто строит пакеты, например используя Poudriere или иные способы, рекомендуется удалить все ранее собранные пакеты и после обновления до pkg 1.3.7 построить все пакеты заново.

Рекомендуемая схема обновления, для тех кто использует установку с помощью pkg:

  • обновить pkg до версии 1.3.7, только pkg никакие пакеты более;
  • с правами пользователя root запустить

    Код: Выделить всё

    pkg check -Ba
    это приведёт к анализу и исправлению зависимостей и библиотек установленного программного обеспечения. Данная процедура, может занять 1-15 минут.
  • продолжить обновление, по стандартной процедуре.

Так же можно воспользоваться следующим скриптом:

Код: Выделить всё

pkg update
pkg_local_ver=`pkg query %v ports-mgmt/pkg`
pkg_remote_ver=`pkg rquery -U %v ports-mgmt/pkg`
# Special handling needed for upgrading <=1.3.6 to 1.3.7+
if [ "`pkg version -t ${pkg_local_ver} 1.3.7)`" = "<" ]; then
  pkg install -Uy ports-mgmt/pkg
  pkg check -Ba
fi


# Normal upgrade can proceed...

Код: Выделить всё

pkg upgrade -Uy


Если вы используете только сборку из портов, то каких либо действий не требуется. Однако после обновления до pkg 1.3.7, рекомендуется всё же выполнить

Код: Выделить всё

pkg check -Ba


Более подробно о причинах и процедуре, можно прочесть в официальном анонсе.

За перевод, спасибо мне, в лице BSDniR :)
Если ваша тема перенесена, то смотри viewtopic.php?f=1&t=32308

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 34889
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Внимание обновление pkg 1.3.7

Непрочитанное сообщение Alex Keda » 2014-08-27 10:35:05

угу... со странностями он.
я вот сервер одному клиенту обновлял, после обновления mysql стал версии 5.5 вместо 5.1 а php и apache просто удлились...
не считая ещё половину софта.
как-то корявенько короче =))
Убей их всех! Бог потом рассортирует...

Аватара пользователя
f_andrey
майор
Сообщения: 2629
Зарегистрирован: 2007-12-26 1:22:58
Откуда: СПб
Контактная информация:

Re: Внимание обновление pkg 1.3.7

Непрочитанное сообщение f_andrey » 2014-08-27 10:41:51

Это в смысле при помощи pkg обновлялся? Там же вроде видно что он собирается делать.
Ну а вообще чего удивляться, конечно не смена двигателя на ходу автомобиля, но весьма близко, так что крепимся и терпим :)
Если ваша тема перенесена, то смотри viewtopic.php?f=1&t=32308

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 34889
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Внимание обновление pkg 1.3.7

Непрочитанное сообщение Alex Keda » 2014-08-28 9:47:43

видно. и обещал он обновление пыха, кстати... а не удаление...
Убей их всех! Бог потом рассортирует...

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 34889
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Внимание обновление pkg 1.3.7

Непрочитанное сообщение Alex Keda » 2014-08-30 18:25:42

во, аццкий отжиг:

Код: Выделить всё

dns0# pkg install -y net-snmp-5.7.2_16
Updating HostFood repository catalogue...
HostFood repository is up-to-date.
All repositories are up-to-date.
The following 2 packages will be affected (of 0 checked):

New packages to be INSTALLED:
        net-snmp: 5.7.2_16
        perl5: 5.16.3_11

The process will require 58 MB more space.
14 MB to be downloaded.
Fetching net-snmp-5.7.2_16.txz: 100%    2 MB   2.2M/s    00:01   
Fetching perl5-5.16.3_11.txz: 100%   12 MB  13.4M/s    00:01   
Checking integrity... done (1 conflicting)
Checking integrity... done (0 conflicting)
Conflicts with the existing packages have been found.
One more solver iteration is needed to resolve them.
The following 7 packages will be affected (of 0 checked):

Installed packages to be REMOVED:
        colorize-0.3.4_1
        p5-Term-ANSIColor-3.02
        vim-7.4.398
        apache22-itk-mpm-2.2.27_6
        perl5.14-5.14.4_7

New packages to be INSTALLED:
        perl5: 5.16.3_11
        net-snmp: 5.7.2_16

The operation will free 30 MB.
[1/7] Deleting perl5.14-5.14.4_7: 100%
[2/7] Deleting colorize-0.3.4_1: 100%
[3/7] Deleting p5-Term-ANSIColor-3.02: 100%
[4/7] Deleting vim-7.4.398: 100%
pkg: rmdir(/usr/local/share/vim/): Directory not empty
/usr/local/etc/apache22/httpd.conf /usr/local/share/examples/apache22/httpd.conf differ: char 826, line 16
[5/7] Deleting apache22-itk-mpm-2.2.27_6: 100%
[6/7] Installing perl5-5.16.3_11: 100%
[7/7] Installing net-snmp-5.7.2_16: 100%
dns0#
Убей их всех! Бог потом рассортирует...

Аватара пользователя
dekloper
ст. лейтенант
Сообщения: 1280
Зарегистрирован: 2008-02-24 15:43:19
Откуда: давно здесь сидим..
Контактная информация:

Re: Внимание обновление pkg 1.3.7

Непрочитанное сообщение dekloper » 2014-09-01 13:57:30

Alex Keda писал(а):во, аццкий отжиг:

круто
интересно, чем помешал, в целях экономии места видимо :pardon:
надеюсь никто и не заметил.. болансер то есь пади какой..
ТОВАгИЩИ! БгАТЬЯ И СЕСТгЫ! ДОЛОЙ гАВНОДУШИЕ!

Аватара пользователя
dekloper
ст. лейтенант
Сообщения: 1280
Зарегистрирован: 2008-02-24 15:43:19
Откуда: давно здесь сидим..
Контактная информация:

Re: Внимание обновление pkg 1.3.7

Непрочитанное сообщение dekloper » 2014-09-02 9:59:38

Код: Выделить всё

D    /usr/ports/ports-mgmt/bxpkg
D    /usr/ports/ports-mgmt/pkgfe
D    /usr/ports/ports-mgmt/prhistory
U    /usr/ports/ports-mgmt/Makefile
Checked out revision 366974.

root@titan:~ # date
вторник,  2 сентября 2014 г. 13:53:26

# pkg version
dialog4ports-0.1.5_2               =
gettext-0.18.3.1_1                 =
glib-2.36.3_4                      >
gmake-3.82_1                       =
icu-53.1                           =
indexinfo-0.2                      =
libffi-3.0.13_2                    >
libiconv-1.14_4                    >
libssh2-1.4.3_4,2                  >
mc-4.8.12_2                        =
pcre-8.35                          >
perl5-5.16.3_11                    =
pkg-1.3.7                          >
pkgconf-0.9.6_1                    >
python27-2.7.8_4                   >

офегедь :shock:
а чо стрелочке не туды гледять?? :bn:
ТОВАгИЩИ! БгАТЬЯ И СЕСТгЫ! ДОЛОЙ гАВНОДУШИЕ!

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 34889
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Внимание обновление pkg 1.3.7

Непрочитанное сообщение Alex Keda » 2014-09-02 21:44:57

dekloper писал(а):
Alex Keda писал(а):во, аццкий отжиг:

круто
интересно, чем помешал, в целях экономии места видимо :pardon:
надеюсь никто и не заметил.. болансер то есь пади какой..

это DNS сервер
а bind, раньше и к счастью, был системный =)
Убей их всех! Бог потом рассортирует...

Аватара пользователя
iMoJo
ефрейтор
Сообщения: 63
Зарегистрирован: 2010-03-23 7:24:48
Откуда: KZ

Re: Внимание обновление pkg 1.3.7

Непрочитанное сообщение iMoJo » 2014-09-04 6:27:18

Alex Keda писал(а):во, аццкий отжиг:

Была такая же х...я, ничего не понял, пакеты потом переустанавливал ...

Аватара пользователя
f_andrey
майор
Сообщения: 2629
Зарегистрирован: 2007-12-26 1:22:58
Откуда: СПб
Контактная информация:

Re: Внимание обновление pkg 1.3.7

Непрочитанное сообщение f_andrey » 2014-09-04 6:33:17

iMoJo писал(а):
Alex Keda писал(а):во, аццкий отжиг:

Была такая же х...я, ничего не понял, пакеты потом переустанавливал ...

Да чего там понимать, хреновенький "ресолвер" зависимостей, в том году на ruBSD паренёк про теорию этого дела рассказывал, там ещё конь не валялся, работы не початый край :evil:
Если ваша тема перенесена, то смотри viewtopic.php?f=1&t=32308

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 34889
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Внимание обновление pkg 1.3.7

Непрочитанное сообщение Alex Keda » 2014-09-30 22:19:54

Хлопцы, а кто знает какая опция в 1.3.8 отвечает за удаление старых пакетов?
Поставил для 10.1 из release_0, сменил на latest, а там КДЕ кусками... Поделие снесло всё чего не было - итог - не работающий кде.
Хотел откатить, а оказалось оно из кэша старые пакеты снесло...

А я блин на даче... 3G мать его... И трафик кончился... Попадос :(
Убей их всех! Бог потом рассортирует...


Вернуться в «Новости»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя