EdgeOS Маршрутизация после VPN

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
neekonoff
рядовой
Сообщения: 11
Зарегистрирован: 2017-04-06 15:51:54

EdgeOS Маршрутизация после VPN

Непрочитанное сообщение neekonoff » 2017-09-27 14:40:03

Приветствую!

Помогите пжлста разобарться.

Есть следующий сценарий:
medium.jpg
medium.jpg (18.38 КБ) 10047 просмотров
Свитч (ES-48-LITE) является маршрутизатором для VLAN-подсетей.
Маршрутизатор (ERPro-8) - гейтвей, DNS-форвардер, VPN-сервер.
Маршрутизация настроена и на свиче и на гейтвее. Все работает.

Вопрос в том, как указать VPN-клиентам путь до VLAN-подсетей?
При инициализации VPN-соединения с VPN-клиента пинг ходит только до 10.1.1.2. Дальше не хочет..

show vpn

Код: Выделить всё

vpn {
    ipsec {
        ipsec-interfaces {
            interface eth2.547
        }
    }
    l2tp {
        remote-access {
            authentication {
                local-users {
                    username user1 {
                        password ****************
                    }
                }
                mode local
            }
            client-ip-pool {
                start 10.1.1.111
                stop 10.1.1.199
            }
            dns-servers {
                server-1 10.1.1.1
            }
            ipsec-settings {
                authentication {
                    mode pre-shared-secret
                    pre-shared-secret ****************
                }
            }
            outside-address x.x.x.x
        }
    }
}
На всякий пожарный ниже полный конфиг маршрутизатора и упрощенный - свича:
ERPro-8
show configuration

Код: Выделить всё

firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    modify SOURCE_ROUTE {
        rule 1 {
            action modify
            description "Traffic from VLAN11 to Westcall 42569"
            modify {
                table 3
            }
            source {
                address 192.168.1.0/24
            }
        }
        rule 10 {
            action modify
            description "Traffic from VLAN10 to Westcall 42569"
            modify {
                table 3
            }
            source {
                address 192.168.10.0/24
            }
        }
        rule 20 {
            action modify
            description "Traffic from VLAN20 to Westcall 42568"
            modify {
                table 2
            }
            source {
                address 192.168.20.0/24
            }
        }
        rule 30 {
            action modify
            description "Traffic form VLAN30 to Westcall 42567"
            modify {
                table 1
            }
            source {
                address 192.168.30.0/24
            }
        }
    }
    name WAN_150 {
        default-action drop
        description ""
    }
    name WAN_235 {
        default-action drop
        description ""
    }
    name WAN_IN {
        default-action drop
        description "WAN to internal"
        rule 10 {
            action accept
            log disable
            protocol all
            state {
                established enable
                invalid disable
                new disable
                related enable
            }
        }
        rule 30 {
            action drop
            log disable
            protocol all
            state {
                established disable
                invalid enable
                new disable
                related disable
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        rule 10 {
            action accept
            description Estableshed
            log disable
            protocol all
            state {
                established enable
                invalid disable
                new disable
                related enable
            }
        }
        rule 20 {
            action accept
            description SSH
            destination {
                port 2345
            }
            log disable
            protocol tcp
        }
        rule 30 {
            action accept
            description IKE
            destination {
                port 500
            }
            log disable
            protocol udp
        }
        rule 40 {
            action accept
            description L2TP
            destination {
                port 1701
            }
            log disable
            protocol udp
        }
        rule 50 {
            action accept
            description ESP
            log disable
            protocol esp
        }
        rule 60 {
            action accept
            description NAT-T
            destination {
                port 4500
            }
            log disable
            protocol udp
        }
        rule 70 {
            action accept
            description ICMP
            protocol icmp
        }
        rule 80 {
            action drop
            description Invalid
            destination {
            }
            log disable
            protocol all
            state {
                established disable
                invalid enable
                new disable
                related disable
            }
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        address 10.1.1.1/24
        duplex auto
        firewall {
            in {
                modify SOURCE_ROUTE
            }
        }
        speed auto
    }
    ethernet eth1 {
        duplex auto
        speed auto
    }
    ethernet eth2 {
        duplex auto
        speed auto
        vif 150 {
            address z.z.z.z/30
            description "Westcall 42567"
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_150
                }
            }
        }
        vif 235 {
            address y.y.y.y/30
            description "Westcall 42568"
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_235
                }
            }
        }
        vif 547 {
            address x.x.x.x/30
            description "Westcall 42569"
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_LOCAL
                }
            }
        }
    }
    ethernet eth3 {
        duplex auto
        speed auto
    }
    ethernet eth4 {
        duplex auto
        speed auto
    }
    ethernet eth5 {
        duplex auto
        speed auto
    }
    ethernet eth6 {
        duplex auto
        speed auto
    }
    ethernet eth7 {
        duplex auto
        speed auto
    }
    loopback lo {
    }
}
protocols {
    static {
        route 192.168.10.0/24 {
            next-hop 10.1.1.2 {
                description "Route to VLAN10"
            }
        }
        route 192.168.20.0/24 {
            next-hop 10.1.1.2 {
                description "Route to VLAN20"
            }
        }
        route 192.168.30.0/24 {
            next-hop 10.1.1.2 {
                description "Route to VLAN30"
            }
        }
        table 1 {
            description "Westcall 42567"
            route 0.0.0.0/0 {
                next-hop z.z.z.z-1 {
                }
            }
        }
        table 2 {
            description "Westcall 42568"
            route 0.0.0.0/0 {
                next-hop y.y.y.y-1 {
                }
            }
        }
        table 3 {
            description "Westcall 42569"
            route 0.0.0.0/0 {
                next-hop x.x.x.x-1 {
                }
            }
        }
    }
}
service {
    dns {
        forwarding {
            cache-size 150
            listen-on eth0
            name-server 8.8.8.8
        }
    }
    gui {
        http-port 80
        https-port 443
        older-ciphers enable
    }
    nat {
        rule 5000 {
            log disable
            outbound-interface eth2.547
            protocol all
            source {
                address 192.168.1.0/24
            }
            type masquerade
        }
        rule 5001 {
            log disable
            outbound-interface eth2.547
            protocol all
            source {
                address 192.168.10.0/24
            }
            type masquerade
        }
        rule 5002 {
            log disable
            outbound-interface eth2.235
            protocol all
            source {
                address 192.168.20.0/24
            }
            type masquerade
        }
        rule 5003 {
            log disable
            outbound-interface eth2.150
            protocol all
            source {
                address 192.168.30.0/24
            }
            type masquerade
        }
    }
    ssh {
        port 2345
        protocol-version v2
    }
    unms {
        disable
    }
}
system {
    gateway-address x.x.x.x-1
    host-name ubnt
    login {
        user admin {
            authentication {
                encrypted-password ****************
                plaintext-password ****************
            }
            level admin
        }
    }
    name-server 8.8.8.8
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone UTC
}
vpn {
    ipsec {
        ipsec-interfaces {
            interface eth2.547
        }
    }
    l2tp {
        remote-access {
            authentication {
                local-users {
                    username user1 {
                        password ****************
                    }
                }
                mode local
            }
            client-ip-pool {
                start 10.1.1.111
                stop 10.1.1.199
            }
            dns-servers {
                server-1 10.1.1.1
            }
            ipsec-settings {
                authentication {
                    mode pre-shared-secret
                    pre-shared-secret ****************
                }
            }
            outside-address x.x.x.x
        }
    }
}
show running-config

Код: Выделить всё

network protocol none
network parms 192.168.0.2 255.255.255.0
vlan database
vlan 10,20,30
vlan routing 10 1
vlan routing 20 2
vlan routing 30 3
exit

configure
no ip domain lookup
ip routing
username "admin" password ********
no username "ubnt"
line console
exit

line telnet
exit

line ssh
exit

interface 0/17
vlan participation exclude 1,3,10-11,20,30,40
routing
ip address 10.1.1.2 255.255.255.0
exit

interface vlan 10
bandwidth 10000
routing
ip address 192.168.10.2 255.255.255.0
no ip proxy-arp
ip mtu 1500
no ip unreachables
no ip redirects
exit



interface vlan 20
bandwidth 10000
routing
ip address 192.168.20.2 255.255.255.0
no ip proxy-arp
ip mtu 1500
no ip unreachables
no ip redirects
exit



interface vlan 30
bandwidth 10000
routing
ip address 192.168.30.2 255.255.255.0
no ip proxy-arp
ip mtu 1500
no ip unreachables
no ip redirects
exit


service dhcp
ip dhcp excluded-address 192.168.10.0 192.168.10.110
ip dhcp excluded-address 192.168.10.200 192.168.10.255
ip dhcp excluded-address 192.168.1.0 192.168.1.110
ip dhcp excluded-address 192.168.1.200 192.168.1.255
ip dhcp excluded-address 192.168.20.0 192.168.20.110
ip dhcp excluded-address 192.168.20.200 192.168.20.255
ip dhcp excluded-address 192.168.30.0 192.168.30.110
ip dhcp excluded-address 192.168.30.200 192.168.30.255
ip dhcp pool "VLAN0010"
lease infinite
dns-server 10.1.1.1
default-router 192.168.10.2
network 192.168.10.0 255.255.255.0
exit

ip dhcp pool "VLAN0020"
lease infinite
dns-server 10.1.1.1
default-router 192.168.20.2
network 192.168.20.0 255.255.255.0
exit

ip dhcp pool "VLAN0030"
lease infinite
dns-server 10.1.1.1
default-router 192.168.30.2
network 192.168.30.0 255.255.255.0
exit

ip default-gateway 10.1.1.1
exit

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35454
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

EdgeOS Маршрутизация после VPN

Непрочитанное сообщение Alex Keda » 2018-03-18 21:00:20

а чего это - EdgeOS ?
на джунипер похож конфиг...
Убей их всех! Бог потом рассортирует...