Solaris 10 1/13. Как заставить работать Realtek 8168D/8111D?

SunOS, Solaris, OpenSolaris, SmartOS

Модератор: weec

Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
lemonacid
проходил мимо
Сообщения: 2
Зарегистрирован: 2014-09-18 13:28:31

Solaris 10 1/13. Как заставить работать Realtek 8168D/8111D?

Непрочитанное сообщение lemonacid » 2014-09-18 13:42:03

Здравствуйте.
Поставил на рабочий комп Solaris 10 1/13.
Он не видит сетевую плату. Интегрированная, Windows говорит что якобы Realtek 8168D/8111Dю
Где-то нагуглил, что она поддерживается штатным драйвером rge. У рилтека ничего для Solaris нет.
prtconf -v выдаёт следующее:

Код: Выделить всё

            pci1462,7529 (driver not attached)
                Hardware properties:
                    name='assigned-addresses' type=int items=15
                        value=81020010.00000000.0000e800.00000000.00000100.c3020018.00000000.fdfff000.00000000.00001000.c3020020.00000000.fdff8000.00000000.00004000
                    name='reg' type=int items=20
                        value=00020000.00000000.00000000.00000000.00000000.01020010.00000000.00000000.00000000.00000100.43020018.00000000.00000000.00000000.00001000.43020020.00000000.00000000.00000000.00004000
                    name='compatible' type=string items=13
                        value='pciex10ec,8168.1462.7529.3' + 'pciex10ec,8168.1462.7529' + 'pciex10ec,8168.3' + 'pciex10ec,8168' + 'pciexclass,020000' + 'pciexclass,0200' + 'pci10ec,8168.1462.7529.3' + 'pci10ec,8168.1462.7529' + 'pci1462,7529' + 'pci10ec,8168.3' + 'pci10ec,8168' + 'pciclass,020000' + 'pciclass,0200'
                    name='model' type=string items=1
                        value='Ethernet controller'
                    name='power-consumption' type=int items=2
                        value=00000001.00000001
                    name='devsel-speed' type=int items=1
                        value=00000000
                    name='interrupts' type=int items=1
                        value=00000001
                    name='subsystem-vendor-id' type=int items=1
                        value=00001462
                    name='subsystem-id' type=int items=1
                        value=00007529
                    name='unit-address' type=string items=1
                        value='0'
                    name='class-code' type=int items=1
                        value=00020000
                    name='revision-id' type=int items=1
                        value=00000003
                    name='vendor-id' type=int items=1
                        value=000010ec
                    name='device-id' type=int items=1
                        value=00008168
                    name='pci-msix-capid-pointer' type=int items=1
                        value=000000ac
                    name='pci-msi-capid-pointer' type=int items=1
                        value=00000050

согласно вот этой инструкции добавил в /etc/driver_aliases строчку

Код: Выделить всё

rge "pci1462,7529"

выполнил

Код: Выделить всё

update_drv rge
devfsadm -i rge

на обе команды система отругалась "cannot attach driver" или что-то около того. И теперь система в циклической перезагрузке.
Я что-то не так сделал или всё-таки rge неправильный драйвер для этой железяки?
ps. как систему вернуть к жизни - знаю. а вот как сеть дать - не понимаю пока.

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 34896
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Solaris 10 1/13. Как заставить работать Realtek 8168D/81

Непрочитанное сообщение Alex Keda » 2014-09-28 20:18:53

выбросить в пропасть?
нормальной сетевухи нет чтоле?
Убей их всех! Бог потом рассортирует...

lemonacid
проходил мимо
Сообщения: 2
Зарегистрирован: 2014-09-18 13:28:31

Re: Solaris 10 1/13. Как заставить работать Realtek 8168D/81

Непрочитанное сообщение lemonacid » 2014-09-29 9:09:23

Вот прикинь, нету! Есть несколько сетевух разных производителей, все на этих чипах! В итоге взял по одному по одному представителю каждого вида, напихал в комп, одна завелась но не видит линка, вторая нормально заработала. D-Link DFE какая-то...
вопрос снят...

snorlov
подполковник
Сообщения: 3559
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

Re: Solaris 10 1/13. Как заставить работать Realtek 8168D/81

Непрочитанное сообщение snorlov » 2014-09-29 10:36:25

lemonacid писал(а):Вот прикинь, нету! Есть несколько сетевух разных производителей, все на этих чипах! В итоге взял по одному по одному представителю каждого вида, напихал в комп, одна завелась но не видит линка, вторая нормально заработала. D-Link DFE какая-то...
вопрос снят...

У D-link'а сетевухи с очень похожим названием могут быть сделаны на разных чипах даже не одного производителя...

Аватара пользователя
skeletor
майор
Сообщения: 2370
Зарегистрирован: 2007-11-16 18:22:04
Откуда: Kiev
Контактная информация:

Re: Solaris 10 1/13. Как заставить работать Realtek 8168D/81

Непрочитанное сообщение skeletor » 2014-10-03 14:44:06

Просто не подоходит драйвер. На 11 версии оно просто бы его не подгрузило, а на 10-ке уходит в ребут. Удалите этот драйвер из /etc/driver_aliases
"Винда съела дрова и резет здесь не фурычит."
"Все говорят, что у меня /dev/hands криво и я всё делаю через /dev/ass. А у меня этих фалов вообще нет!"

Mikl
мл. сержант
Сообщения: 131
Зарегистрирован: 2010-08-06 6:52:24
Откуда: замкадыш

Re: Solaris 10 1/13. Как заставить работать Realtek 8168D/81

Непрочитанное сообщение Mikl » 2014-10-03 19:48:52

интел про и будет щастье.


Вернуться в «SunOS»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость