FreeBSD 10.3 и монтировка флешки

Решение проблем связванных с работой железа. Проблемы программно-аппаратной совместимости.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
spear
проходил мимо
Сообщения: 4
Зарегистрирован: 2016-05-29 15:34:48

FreeBSD 10.3 и монтировка флешки

Непрочитанное сообщение spear » 2016-05-29 15:50:21

Что-то совсем у меня сломалась монтировка флешек. Люди помогите!
Раньше хоть как-то через раз работало, теперь совсем поломалось... :(

Все рекомендованные опции, типа vfs.usermount и т.д., у меня с давних времен прописаны и работали

Симптомы: вставляю флэшку (любую), устройство da0 появляется. Видно его и в usbconfig и в camcontrol devlist

dmesg:
da0 at umass-sim0 bus 0 scbus8 target 0 lun 0
da0: <Kingston DataTraveler 2.0 1.00> Removable Direct Access SCSI-2 device
da0: Serial Number 0000000646
da0: 40.000MB/s transfers
da0: 953MB (1952256 512 byte sectors)
da0: quirks=0x3<NO_SYNC_CACHE,NO_6_BYTE>

Но раздел da0s1 не появляется, и соответственно смонтировать его нельзя. Раньше помогало в таких случаях true > /dev/da0 , но сейчас тоже не помогает.

KDE-шный Дельфин пишет: mount_msdosfs: msdosfs_iconv: File exists

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 34910
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

FreeBSD 10.3 и монтировка флешки

Непрочитанное сообщение Alex Keda » 2016-05-30 8:08:59

в другой порт втыкали?
другую флэшку?
Убей их всех! Бог потом рассортирует...

guest
проходил мимо

FreeBSD 10.3 и монтировка флешки

Непрочитанное сообщение guest » 2016-05-30 9:27:52

spear писал(а):Что-то совсем у меня сломалась монтировка флешек. Люди помогите!
Раньше хоть как-то через раз работало, теперь совсем поломалось... :(

Все рекомендованные опции, типа vfs.usermount и т.д., у меня с давних времен прописаны и работали

Симптомы: вставляю флэшку (любую), устройство da0 появляется. Видно его и в usbconfig и в camcontrol devlist

dmesg:
da0 at umass-sim0 bus 0 scbus8 target 0 lun 0
da0: <Kingston DataTraveler 2.0 1.00> Removable Direct Access SCSI-2 device
da0: Serial Number 0000000646
da0: 40.000MB/s transfers
da0: 953MB (1952256 512 byte sectors)
da0: quirks=0x3<NO_SYNC_CACHE,NO_6_BYTE>

Но раздел da0s1 не появляется, и соответственно смонтировать его нельзя. Раньше помогало в таких случаях true > /dev/da0 , но сейчас тоже не помогает.

KDE-шный Дельфин пишет: mount_msdosfs: msdosfs_iconv: File exists


# gpart show da0

что покажет?

snorlov
подполковник
Сообщения: 3561
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

FreeBSD 10.3 и монтировка флешки

Непрочитанное сообщение snorlov » 2016-05-30 10:26:17

spear,
Посмотрите в /dev, может надо монтировать da0s1a...

spear
проходил мимо
Сообщения: 4
Зарегистрирован: 2016-05-29 15:34:48

FreeBSD 10.3 и монтировка флешки

Непрочитанное сообщение spear » 2016-05-30 12:44:11

Спасибо все откликнувшимся.
В общем, я флэшками не пользуюсь. Но периодически мне что-то дают, и говорят - "скачай". Как правило, в виндах работает без пробле.

По очереди

undefined писал(а):Источник цитаты # gpart show da0
что покажет?


=> 63 7864257 da0 MBR (3.8G)
63 7864257 1 fat32 [active] (3.7G)

или другая флэшка

=> 63 30489345 da0 MBR (15G)
63 1985 - free - (993K)
2048 30486528 1 !12 (15G)
30488576 832 - free - (416K)

обе в виндах видятся замечательно

snorlov писал(а):Источник цитаты Посмотрите в /dev, может надо монтировать da0s1a...

Alex Keda писал(а):Источник цитаты в другой порт втыкали?
другую флэшку?

Да, на некоторых флэшках появляется da0s1. И монтирование вручную в командное строке срабатывает. Тогда немного переформулирую вопрос, разбивая на две части:
1. Как сделать, чтобы проходило монтирование в KDE? Значок флэшки в дельфине появляется, но содержимое не отображается, при попытке доступа вываливется сообщение об ошибке?
2. Что делать, если не появляется раздел da0s1, а только da0? Флэшка в винде открывается нормально.

guest
проходил мимо

FreeBSD 10.3 и монтировка флешки

Непрочитанное сообщение guest » 2016-05-30 21:29:17

spear писал(а):Спасибо все откликнувшимся.
В общем, я флэшками не пользуюсь. Но периодически мне что-то дают, и говорят - "скачай". Как правило, в виндах работает без пробле.

По очереди

undefined писал(а):Источник цитаты # gpart show da0
что покажет?


=> 63 7864257 da0 MBR (3.8G)
63 7864257 1 fat32 [active] (3.7G)


разметка MBR, da0s1 -> fat32, не вижу проблем

или другая флэшка

=> 63 30489345 da0 MBR (15G)
63 1985 - free - (993K)
2048 30486528 1 !12 (15G)
30488576 832 - free - (416K)

обе в виндах видятся замечательно


тоже fat32 в LBA, тоже da0s1

snorlov писал(а):Источник цитаты Посмотрите в /dev, может надо монтировать da0s1a...

Alex Keda писал(а):Источник цитаты в другой порт втыкали?
другую флэшку?

Да, на некоторых флэшках появляется da0s1. И монтирование вручную в командное строке срабатывает. Тогда немного переформулирую вопрос, разбивая на две части:
1. Как сделать, чтобы проходило монтирование в KDE? Значок флэшки в дельфине появляется, но содержимое не отображается, при попытке доступа вываливется сообщение об ошибке?
2. Что делать, если не появляется раздел da0s1, а только da0? Флэшка в винде открывается нормально.


все что FAT12/16/32/exFAT - монтируется без проблем, а вот для NTFS - нужно ставить sysutils/fusefs-ntfs

spear
проходил мимо
Сообщения: 4
Зарегистрирован: 2016-05-29 15:34:48

FreeBSD 10.3 и монтировка флешки

Непрочитанное сообщение spear » 2017-01-22 19:24:47

РЕШЕНО.
Оказалось, в опциях ядра зачем-то стояло

options MSDOSFS_ICONV

КДЕ же пыталось, судя по всему этот модуль отдельно подгрузить - и обламывалось...
Короче, мои кривые руки :-)


Вернуться в «Железо»

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и 3 гостя