vboxdrv сбивает с толку geom

VirtualBox, QEMU, ESX/ESXi и прочия
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
oklas
рядовой
Сообщения: 13
Зарегистрирован: 2014-05-29 21:32:56

vboxdrv сбивает с толку geom

Непрочитанное сообщение oklas » 2015-02-27 11:31:40

При установке и включении vboxdrv (от VirtualBox)
становятся мало доступны два диска и аппаратный райд из них.
Мало доступны - т.е. в /dev присутствуют но не видно
разделов и bsdlabel не видит ничего, fdisk - видит что bsd.
Вследствие этого не грузится ос. Был ещё один диск с фряхой
там-же, но не соединенный ни с чем в райд он виден, на нем
снят dmesg привожу оба для сравнения. Ядро явлется копией
generic 9.3 плюс встроенный ipfw и две таблицы маршрутизации.
Суть вопроса в том баг ли это vboxdrv или ещё что проверить?
файлы приаттачены в конце сообщения или тут в двух окошках:
рабочая загрузка без драйвера vboxdrv:

Код: Выделить всё

Copyright (c) 1992-2014 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
   The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 9.3-RELEASE #0 r279048: Fri Feb 20 17:16:15 MSK 2015
    user@ns2.local:/usr/obj/home/src93/sys/BSDKERNEL amd64
gcc version 4.2.1 20070831 patched [FreeBSD]
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ (2009.31-MHz K8-class CPU)
  Origin = "AuthenticAMD"  Id = 0x40fb2  Family = 0xf  Model = 0x4b  Stepping = 2
  Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
  Features2=0x2001<SSE3,CX16>
  AMD Features=0xea500800<SYSCALL,NX,MMX+,FFXSR,RDTSCP,LM,3DNow!+,3DNow!>
  AMD Features2=0x1f<LAHF,CMP,SVM,ExtAPIC,CR8>
real memory  = 2147483648 (2048 MB)
avail memory = 1911738368 (1823 MB)
Event timer "LAPIC" quality 400
ACPI APIC Table: <A_M_I_ OEMAPIC >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
FreeBSD/SMP: 1 package(s) x 2 core(s)
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
ioapic0 <Version 1.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
acpi0: <A_M_I_ OEMXSDT> on motherboard
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 77f00000 (3) failed
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
attimer0: <AT timer> port 0x40-0x43 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
attimer0: Can't map interrupt.
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed00fff on acpi0
Timecounter "HPET" frequency 25000000 Hz quality 950
Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x508-0x50b on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <memory, RAM> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> port 0x900-0x9ff at device 1.0 on pci0
isa0: <ISA bus> on isab0
pci0: <memory, RAM> at device 1.2 (no driver attached)
ohci0: <nVidia nForce MCP61 USB Controller> mem 0xdfeff000-0xdfefffff irq 21 at device 2.0 on pci0
usbus0 on ohci0
ehci0: <NVIDIA nForce MCP61 USB 2.0 controller> mem 0xdfefec00-0xdfefecff irq 22 at device 2.1 on pci0
usbus1: EHCI version 1.0
usbus1 on ehci0
pcib1: <ACPI PCI-PCI bridge> at device 4.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vr0: <VIA VT6105 Rhine III 10/100BaseTX> port 0xe800-0xe8ff mem 0xdffffc00-0xdffffcff irq 16 at device 7.0 on pci1
vr0: Quirks: 0x0
vr0: Revision: 0x8b
miibus0: <MII bus> on vr0
ukphy0: <Generic IEEE 802.3u media interface> PHY 1 on miibus0
ukphy0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto, auto-flow
vr0: Ethernet address: de:b9:de:b9:de:b9
hdac0: <NVIDIA MCP61 HDA Controller> mem 0xdfef8000-0xdfefbfff irq 23 at device 5.0 on pci0
nfe0: <NVIDIA nForce MCP61 Networking Adapter> port 0xd480-0xd487 mem 0xdfefd000-0xdfefdfff irq 20 at device 7.0 on pci0
miibus1: <MII bus> on nfe0
atphy0: <Atheros F1 10/100/1000 PHY> PHY 1 on miibus1
atphy0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT-FDX, 1000baseT-FDX-master, auto, auto-flow
nfe0: Ethernet address: fe:ee:fe:ee:fe:ee
atapci0: <nVidia nForce MCP61 SATA300 controller> port 0xd400-0xd407,0xd080-0xd083,0xd000-0xd007,0xcc00-0xcc03,0xc880-0xc88f mem 0xdfefc000-0xdfefcfff irq 21 at device 8.0 on pci0
ata2: <ATA channel> at channel 0 on atapci0
ata3: <ATA channel> at channel 1 on atapci0
atapci1: <nVidia nForce MCP61 SATA300 controller> port 0xc800-0xc807,0xc480-0xc483,0xc400-0xc407,0xc080-0xc083,0xc000-0xc00f mem 0xdfeef000-0xdfeeffff irq 22 at device 8.1 on pci0
ata4: <ATA channel> at channel 0 on atapci1
ata5: <ATA channel> at channel 1 on atapci1
pcib2: <ACPI PCI-PCI bridge> at device 9.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 11.0 on pci0
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 12.0 on pci0
pci4: <ACPI PCI bus> on pcib4
vgapci0: <VGA-compatible display> mem 0xde000000-0xdeffffff,0xc0000000-0xcfffffff,0xdd000000-0xddffffff irq 23 at device 13.0 on pci0
vgapci0: Boot video device
acpi_button0: <Power Button> on acpi0
fdc0: <floppy drive controller (FDE)> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
orm0: <ISA Option ROM> at iomem 0xc0000-0xcefff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ppc0: cannot reserve I/O port range
powernow0: <PowerNow! K8> on cpu0
powernow1: <PowerNow! K8> on cpu1
Timecounters tick every 1.000 msec
ipfw2 (+ipv6) initialized, divert enabled, nat enabled, default to deny, logging disabled
hdacc0: <Analog Devices AD1986A HDA CODEC> at cad 0 on hdac0
hdaa0: <Analog Devices AD1986A Audio Function Group> at nid 1 on hdacc0
hdaa0: WARNING: nid=18 has zero cnid entnum=4 j=2 index=0 entries=8 found=2 res=0x21002211
pcm0: <Analog Devices AD1986A (Analog 6ch/2.0)> at nid 27,28,29 and 31 on hdaa0
pcm1: <Analog Devices AD1986A (Rear Digital)> at nid 37 on hdaa0
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 480Mbps High Speed USB v2.0
ugen0.1: <nVidia> at usbus0
uhub0: <nVidia OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen1.1: <nVidia> at usbus1
uhub1: <nVidia EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus1
uhub0: 10 ports with 10 removable, self powered
ada0 at ata2 bus 0 scbus0 target 0 lun 0
ada0: <WDC WD7501AALS-00J7B0 05.00K05> ATA-8 SATA 2.x device
ada0: Serial Number WD-WMATW0040163
ada0: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)
ada0: 715404MB (1465149168 512 byte sectors: 16H 63S/T 16383C)
ada0: Previously was known as ad4
ada1 at ata3 bus 0 scbus1 target 0 lun 0
ada1: <WDC WD3200AAKS-00L9A0 01.03E01> ATA-8 SATA 2.x device
ada1: Serial Number WD-WMAV27361650
ada1: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)
ada1: 305245MB (625142448 512 byte sectors: 16H 63S/T 16383C)
ada1: Previously was known as ad6
ada2 at ata5 bus 0 scbus3 target 0 lun 0
ada2: <WDC WD3200AAKS-00L9A0 01.03E01> ATA-8 SATA 2.x device
ada2: Serial Number WD-WMAV27753872
ada2: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)
ada2: 305245MB (625142448 512 byte sectors: 16H 63S/T 16383C)
ada2: Previously was known as ad10
SMP: AP CPU #1 Launched!
GEOM_RAID: NVIDIA-1: Array NVIDIA-1 created.
GEOM_RAID: NVIDIA-1: Disk ada1 state changed from NONE to ACTIVE.
GEOM_RAID: NVIDIA-1: Subdisk MIRROR   298.09G:0-ada1 state changed from NONE to ACTIVE.
GEOM_RAID: NVIDIA-1: Disk ada2 state changed from NONE to ACTIVE.
GEOM_RAID: NVIDIA-1: Subdisk MIRROR   298.09G:1-ada2 state changed from NONE to ACTIVE.
GEOM_RAID: NVIDIA-1: Array started.
GEOM_RAID: NVIDIA-1: Volume MIRROR   298.09G state changed from STARTING to OPTIMAL.
GEOM_RAID: NVIDIA-1: Provider raid/r0 for volume MIRROR   298.09G created.
Root mount waiting for: usbus1
Root mount waiting for: usbus1
uhub1: 10 ports with 10 removable, self powered
Root mount waiting for: usbus1
Trying to mount root from ufs:/dev/ar0s1a [rw]...
ugen0.2: <American Power Conversion> at usbus0
uhid0: <American Power Conversion Smart-UPS 1500 FWUPS 09.1  ID18, class 0/0, rev 2.00/1.06, addr 2> on usbus0
ugen0.3: <vendor 0x04d9> at usbus0
ums0: <vendor 0x04d9 product 0x0499, class 0/0, rev 1.10/2.90, addr 3> on usbus0
ums0: 3 buttons and [XYZ] coordinates ID=0
bridge0: Ethernet address: 02:ef:da:ee:44:00
tap0: Ethernet address: 00:bd:77:23:00:00
tap1: Ethernet address: 00:bd:7a:23:00:01
tap2: Ethernet address: 00:bd:7d:23:00:02
tap3: Ethernet address: 00:bd:80:23:00:03
vboxdrv: fAsync=1 offMin=0x667d6 offMax=0x667d6
supdrvGipCreate: omni timer not supported, falling back to synchronous mode
tap0: link state changed to UP
tap2: link state changed to UP
tap1: link state changed to UP

отказ при загрузке с драйвером vboxdrv:

Код: Выделить всё

Copyright (c) 1992-2014 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
   The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 9.3-RELEASE #0 r279048: Fri Feb 20 17:16:15 MSK 2015
    user@ns2.local:/usr/obj/home/src93/sys/BSDKERNEL amd64
gcc version 4.2.1 20070831 patched [FreeBSD]
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ (2009.31-MHz K8-class CPU)
  Origin = "AuthenticAMD"  Id = 0x40fb2  Family = 0xf  Model = 0x4b  Stepping = 2
  Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
  Features2=0x2001<SSE3,CX16>
  AMD Features=0xea500800<SYSCALL,NX,MMX+,FFXSR,RDTSCP,LM,3DNow!+,3DNow!>
  AMD Features2=0x1f<LAHF,CMP,SVM,ExtAPIC,CR8>
real memory  = 2147483648 (2048 MB)
avail memory = 1911738368 (1823 MB)
Event timer "LAPIC" quality 400
ACPI APIC Table: <A_M_I_ OEMAPIC >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
FreeBSD/SMP: 1 package(s) x 2 core(s)
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
ioapic0 <Version 1.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
acpi0: <A_M_I_ OEMXSDT> on motherboard
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 77f00000 (3) failed
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
attimer0: <AT timer> port 0x40-0x43 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
attimer0: Can't map interrupt.
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed00fff on acpi0
Timecounter "HPET" frequency 25000000 Hz quality 950
Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x508-0x50b on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <memory, RAM> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> port 0x900-0x9ff at device 1.0 on pci0
isa0: <ISA bus> on isab0
pci0: <memory, RAM> at device 1.2 (no driver attached)
ohci0: <nVidia nForce MCP61 USB Controller> mem 0xdfeff000-0xdfefffff irq 21 at device 2.0 on pci0
usbus0 on ohci0
ehci0: <NVIDIA nForce MCP61 USB 2.0 controller> mem 0xdfefec00-0xdfefecff irq 22 at device 2.1 on pci0
usbus1: EHCI version 1.0
usbus1 on ehci0
pcib1: <ACPI PCI-PCI bridge> at device 4.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vr0: <VIA VT6105 Rhine III 10/100BaseTX> port 0xe800-0xe8ff mem 0xdffffc00-0xdffffcff irq 16 at device 7.0 on pci1
vr0: Quirks: 0x0
vr0: Revision: 0x8b
miibus0: <MII bus> on vr0
ukphy0: <Generic IEEE 802.3u media interface> PHY 1 on miibus0
ukphy0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto, auto-flow
vr0: Ethernet address: de:b9:de:b9:de:b9
hdac0: <NVIDIA MCP61 HDA Controller> mem 0xdfef8000-0xdfefbfff irq 23 at device 5.0 on pci0
nfe0: <NVIDIA nForce MCP61 Networking Adapter> port 0xd480-0xd487 mem 0xdfefd000-0xdfefdfff irq 20 at device 7.0 on pci0
miibus1: <MII bus> on nfe0
atphy0: <Atheros F1 10/100/1000 PHY> PHY 1 on miibus1
atphy0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT-FDX, 1000baseT-FDX-master, auto, auto-flow
nfe0: Ethernet address: fe:ee:fe:ee:fe:ee
atapci0: <nVidia nForce MCP61 SATA300 controller> port 0xd400-0xd407,0xd080-0xd083,0xd000-0xd007,0xcc00-0xcc03,0xc880-0xc88f mem 0xdfefc000-0xdfefcfff irq 21 at device 8.0 on pci0
ata2: <ATA channel> at channel 0 on atapci0
ata3: <ATA channel> at channel 1 on atapci0
atapci1: <nVidia nForce MCP61 SATA300 controller> port 0xc800-0xc807,0xc480-0xc483,0xc400-0xc407,0xc080-0xc083,0xc000-0xc00f mem 0xdfeef000-0xdfeeffff irq 22 at device 8.1 on pci0
ata4: <ATA channel> at channel 0 on atapci1
ata5: <ATA channel> at channel 1 on atapci1
pcib2: <ACPI PCI-PCI bridge> at device 9.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 11.0 on pci0
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 12.0 on pci0
pci4: <ACPI PCI bus> on pcib4
vgapci0: <VGA-compatible display> mem 0xde000000-0xdeffffff,0xc0000000-0xcfffffff,0xdd000000-0xddffffff irq 23 at device 13.0 on pci0
vgapci0: Boot video device
acpi_button0: <Power Button> on acpi0
fdc0: <floppy drive controller (FDE)> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
orm0: <ISA Option ROM> at iomem 0xc0000-0xcefff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ppc0: cannot reserve I/O port range
powernow0: <PowerNow! K8> on cpu0
powernow1: <PowerNow! K8> on cpu1
Timecounters tick every 1.000 msec
vboxdrv: fAsync=0 offMin=0x116 offMax=0x471
supdrvGipCreate: omni timer not supported, falling back to synchronous mode
ipfw2 (+ipv6) initialized, divert enabled, nat enabled, default to deny, logging disabled
hdacc0: <Analog Devices AD1986A HDA CODEC> at cad 0 on hdac0
hdaa0: <Analog Devices AD1986A Audio Function Group> at nid 1 on hdacc0
hdaa0: WARNING: nid=18 has zero cnid entnum=4 j=2 index=0 entries=8 found=2 res=0x21002211
pcm0: <Analog Devices AD1986A (Analog 6ch/2.0)> at nid 27,28,29 and 31 on hdaa0
pcm1: <Analog Devices AD1986A (Rear Digital)> at nid 37 on hdaa0
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 480Mbps High Speed USB v2.0
ugen0.1: <nVidia> at usbus0
uhub0: <nVidia OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen1.1: <nVidia> at usbus1
uhub1: <nVidia EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus1
uhub0: 10 ports with 10 removable, self powered
ada0 at ata2 bus 0 scbus0 target 0 lun 0
ada0: <WDC WD7501AALS-00J7B0 05.00K05> ATA-8 SATA 2.x device
ada0: Serial Number WD-WMATW0040163
ada0: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)
ada0: 715404MB (1465149168 512 byte sectors: 16H 63S/T 16383C)
ada0: Previously was known as ad4
ada1 at ata3 bus 0 scbus1 target 0 lun 0
ada1: <WDC WD3200AAKS-00L9A0 01.03E01> ATA-8 SATA 2.x device
ada1: Serial Number WD-WMAV27361650
ada1: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)
ada1: 305245MB (625142448 512 byte sectors: 16H 63S/T 16383C)
ada1: Previously was known as ad6
ada2 at ata5 bus 0 scbus3 target 0 lun 0
ada2: <WDC WD3200AAKS-00L9A0 01.03E01> ATA-8 SATA 2.x device
ada2: Serial Number WD-WMAV27753872
ada2: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)
ada2: 305245MB (625142448 512 byte sectors: 16H 63S/T 16383C)
ada2: Previously was known as ad10
SMP: AP CPU #1 Launched!
GEOM_RAID: Promise: Array Promise created.
Root mount waiting for: GRAID usbus1
Root mount waiting for: GRAID usbus1
Root mount waiting for: GRAID usbus1
uhub1: 10 ports with 10 removable, self powered
Root mount waiting for: GRAID usbus1
ugen0.2: <American Power Conversion> at usbus0
uhid0: <American Power Conversion Smart-UPS 1500 FWUPS 09.1  ID18, class 0/0, rev 2.00/1.06, addr 2> on usbus0
Root mount waiting for: GRAID
ugen0.3: <vendor 0x04d9> at usbus0
ums0: <vendor 0x04d9 product 0x0499, class 0/0, rev 1.10/2.90, addr 3> on usbus0
ums0: 3 buttons and [XYZ] coordinates ID=0
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
Root mount waiting for: GRAID
GEOM_RAID: Promise: Force volume start due to timeout.
GEOM_RAID: Promise: Disk ada1 state changed from NONE to ACTIVE.
GEOM_RAID: Promise: Subdisk RAID 0   LD  1:1-ada1 state changed from NONE to STALE.
GEOM_RAID: Promise: Disk ada2 state changed from NONE to ACTIVE.
GEOM_RAID: Promise: Subdisk RAID 0   LD  1:1-ada2 state changed from STALE to ACTIVE.
GEOM_RAID: Promise: Volume started.
GEOM_RAID: Promise: Volume RAID 0   LD  1 state changed from STARTING to BROKEN.
Trying to mount root from ufs:/dev/ar0s1a [rw]...
mountroot: waiting for device /dev/ar0s1a ...
Mounting from ufs:/dev/ar0s1a failed with error 19.

Loader variables:
  vfs.root.mountfrom=ufs:/dev/ar0s1a
  vfs.root.mountfrom.options=rw

Manual root filesystem specification:
  <fstype>:<device> [options]
      Mount <device> using filesystem <fstype>
      and with the specified (optional) option list.

    eg. ufs:/dev/da0s1a
        zfs:tank
        cd9660:/dev/acd0 ro
          (which is equivalent to: mount -t cd9660 -o ro /dev/acd0 /)

  ?               List valid disk boot devices
  .               Yield 1 second (for background tasks)
  <empty line>    Abort manual input

mountroot>
List of GEOM managed disk devices:
  ufsid/4f5b4342bde0bd93 ufsid/4d107490ea7bcc7e ufsid/4d107490fb9848ad ufsid/4d1074901c620224 ufsid/4d107490952ce7fd ada0s2a ada0s1f ada0s1e ada0s1d ada0s1b ada0s1a ada2 ada1 ada0s2 ada0s1 ada0

mountroot>
 Trying to mount root from ufs:/dev/ada0s1a []...
tap0: Ethernet address: 00:bd:be:34:06:00
vr0: link state changed to UP
nfe0: link state changed to UP
tap0: link state changed to UP
tap2: link state changed to UP
tap1: link state changed to UP

тожесамое в виде файлов для скачаивания:
dmesg.ok.txt
рабочая загрузка без драйвера vboxdrv
(7.95 КБ) 27 скачиваний
dmesg.fail.txt
отказ при загрузке с драйвером vboxdrv
(9.54 КБ) 30 скачиваний


Отправлено спустя 27 минут 57 секунд:
Да, забыл добавить что если драйвер загрузить через
kldload на уже загруженной системе, то всё ok, драйвер
грузится, диски продолжают работать, VirtualBox тоже
работает нормально. Проблема только при старте системы.

Отправлено спустя 2 часа 7 минут 4 секунды:
Превые две отличающиеся строки dmesg,
в рабочем:
GEOM_RAID: NVIDIA-1: Array NVIDIA-1 created.

в сломаном:
GEOM_RAID: Promise: Array Promise created.

snorlov
подполковник
Сообщения: 3561
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

vboxdrv сбивает с толку geom

Непрочитанное сообщение snorlov » 2015-02-27 14:24:10

У вас vboxdrv грузится в обоих случаях, только во втором откуда-то всплывает волшебное слово Promise.. Вы в биосе ничего не накрутили...

oklas
рядовой
Сообщения: 13
Зарегистрирован: 2014-05-29 21:32:56

vboxdrv сбивает с толку geom

Непрочитанное сообщение oklas » 2015-02-27 14:30:18

да грузится, после чего срывает крышу geom, а если отключить и не грузить то всё ок.

Отправлено спустя 1 минуту 46 секунд:
на счёт биоса - какой мне смысл вносить помехи. разница только в загрузке vboxdrv. Версия кстати которого irtualbox-ose-kmod-4.3.22

snorlov
подполковник
Сообщения: 3561
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

vboxdrv сбивает с толку geom

Непрочитанное сообщение snorlov » 2015-02-27 14:40:57

Платы то одинаковы или нет, про биос, у меня в одной плате стояло возможность горячего отключения, в результате диски виделись как подключенные через usb и действительно их можно было отключать/подключать на горячую, как только убрал эту возможность, они стали простыми sata...
P.S. Не люблю я последние 5-ть лет юзать аппаратные и псевдоаппаратные контроллеры RAID...

oklas
рядовой
Сообщения: 13
Зарегистрирован: 2014-05-29 21:32:56

vboxdrv сбивает с толку geom

Непрочитанное сообщение oklas » 2015-02-27 16:22:01

Да плата физически одна и таже, и ядро грузиться с того-же райда.

Сейчас посмотрел ещё раз выяснил что vboxdrv грузится в рабочем
случае тоже, но уже на другой стадии, после того, как geom сделает
свое дело, и файловая система смонтируется. Видимо в момент
прочтения /boot/loader.conf. Это достигается путем указания в
начальном загрузчике не грузить драйвер vboxdrv.

А в сбойном случае vboxdrv грузится из папки с драйверами скопом
ещё до работы geom.

snorlov
подполковник
Сообщения: 3561
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

vboxdrv сбивает с толку geom

Непрочитанное сообщение snorlov » 2015-02-27 16:37:02

oklas писал(а):Да плата физически одна и таже, и ядро грузиться с того-же райда.

Вот это все дело и усложняет, поскольку в одном случае все стартует с дисками подключенными как SATA, а в другим случае c дисками подключенными по USB... Крутите биос, можно просто заглянуть в комп, вдруг там чего интересное найдете...

oklas
рядовой
Сообщения: 13
Зарегистрирован: 2014-05-29 21:32:56

vboxdrv сбивает с толку geom

Непрочитанное сообщение oklas » 2015-02-27 18:50:38

snorlov писал(а):Источник цитатыпоскольку в одном случае все стартует с дисками подключенными как SATA, а в другим случае c дисками подключенными по USB

имеется один и тот-же случай, никакого другого, всё на одной плате. И один единственный биос, ясно дело не к чему трогать, так как на компе всё отлично, и плохо только когда грузим vboxdrv.

Отправлено спустя 49 минут 6 секунд:
может вы хотите сказать, что FreeBSD не видит что биос поддерживает
горячую замену, а после загрузки vboxdrv вдруг начинает видеть?
Или наоборот. Тем не менее такое поведение тоже не правильное.

Или если vboxdrv перхватывает устройство (т.е. раид) на себя и далее представляет его системе иначе - то он должен это делать правильно,
а здесь мы наблюдаем что он всё ломает - следовательно это баг.

Neus
капитан
Сообщения: 1712
Зарегистрирован: 2008-09-08 21:59:56

vboxdrv сбивает с толку geom

Непрочитанное сообщение Neus » 2015-02-27 22:16:55

Пишите багрепорт.
loader.conf читается загрузчиком, после чего начинается инициализация ядра и модулей там указанных.

oklas
рядовой
Сообщения: 13
Зарегистрирован: 2014-05-29 21:32:56

vboxdrv сбивает с толку geom

Непрочитанное сообщение oklas » 2015-02-27 22:29:48

Neus писал(а):Пишите багрепорт.

написал в порты FreeBSD, мож ещё куда?
Neus писал(а):loader.conf читается загрузчиком, после чего начинается инициализация ядра и модулей там указанных.

вот по этому поводу странно, что его повторно загружает, см лог
успешной загрузки, там в загрузчике говорю disbable-module,
и он не грузится но после, опять таки загружается перед
tap интерфейсами.

snorlov
подполковник
Сообщения: 3561
Зарегистрирован: 2008-09-04 11:51:25
Откуда: Санкт-Петербург

vboxdrv сбивает с толку geom

Непрочитанное сообщение snorlov » 2015-02-27 23:04:06

Приведите /boot/loader.conf и /etc/rc.conf, на всякий случай, вы больше ничего не меняли, я имею в виду в default и кстати приведите загрузку на проблемном сервере без загрузки vboxdrv


Вернуться в «Виртуализация»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя