Cisco ACE 20 MRTG

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
vj
рядовой
Сообщения: 12
Зарегистрирован: 2013-01-30 13:36:41

Cisco ACE 20 MRTG

Непрочитанное сообщение vj » 2014-03-11 10:57:19

Добрый день, уважаемые форумчане. Столкнулся с проблемой вывода MRTG для модуля Cisco ACE 20 для Cisco 6509.
Сам модуль будет использоваться у меня в качестве NAT.
Проблем с настройкой NAT не возникло,а вот MRTG вывести не выходит.
Ниже приложу конфиги самого модуля и нужные куски из самого супервизора.


Вот контекст Admin:

Код: Выделить всё

Cisco-ACE-20/Admin# sh run
Generating configuration....


logging enable
logging standby
logging console 5
logging timestamp
logging trap 5
logging buffered 5
logging persistent 5
logging monitor 7
logging queue 2048
logging device-id string ACE1-CTX-PwC
logging message 251010 level 6


peer hostname Cisco-ACE-20

login timeout 60
hostname Cisco-ACE-20
boot system image:c6ace-t1k9-mz.A2_2_3.bin
boot system image:c6ace-t1k9-mz.A2_1_6a.bin

ssh maxsessions 5

resource-class Gold
  limit-resource all minimum 0.00 maximum unlimited
aaa group server tacacs+ Administration

aaa authentication login default group Administration local 
aaa authentication login error-enable



class-map type management match-any MGNT
  2 match protocol http any
  3 match protocol icmp any
  4 match protocol https any
  5 match protocol ssh any
class-map match-any test

policy-map type management first-match MGNT
  class MGNT
    permit

service-policy input MGNT

context NAT
  allocate-interface vlan 10-11
  member Gold

snmp-server contact "root@tim.ua"
snmp-server location "TIM"
snmp-server community rodocsisstat group Network-Monitor
Вот контекст NAT:

Код: Выделить всё

Cisco-ACE-20/NAT# sh run
Generating configuration....


logging enable
logging monitor 7



access-list ALL line 10 extended permit ip any any 
access-list ALL line 15 extended permit icmp any any echo 
access-list ALL line 20 extended permit icmp any any echo-reply 
access-list PAT-AccessList line 10 extended permit ip 10.10.66.0 255.255.255.0 any 



class-map type management match-any MGNT
  2 match protocol http any
  3 match protocol icmp any
  4 match protocol https any
  5 match protocol ssh any
class-map match-any PAT-ClassMap
  2 match access-list PAT-AccessList
class-map type management match-all SNMP-ALLOW_CLASS
  2 match protocol snmp source-address 192.168.1.240 255.255.255.255
class-map match-any test

policy-map type management first-match MGNT
  class MGNT
    permit
policy-map type management first-match SNMP_POLICY
  class SNMP-ALLOW_CLASS
    permit

policy-map multi-match PAT-PolicyMap
  class PAT-ClassMap
    nat dynamic 1 vlan 11

service-policy input MGNT

interface vlan 10
  description PAT_IN
  ip address 10.100.10.2 255.255.255.248
  access-group input ALL
  access-group output ALL
  service-policy input PAT-PolicyMap
  no shutdown
interface vlan 11
  description PAT_OUT
  ip address 10.100.11.2 255.255.255.248
  access-group input ALL
  access-group output ALL
  nat-pool 1 194.242.103.184 194.242.103.184 netmask 255.255.255.255 pat
  no shutdown

ip route 0.0.0.0 0.0.0.0 10.100.11.1
ip route 10.10.66.0 255.255.255.0 10.100.10.1

snmp-server contact "root@tim.ua"
snmp-server location "TIM"
snmp-server community rodocsisstat group Network-Monitor

Как видно, политика для SNMP настроена, но при таком конфиге не видно SNMP source, т.е. 192.168.1.240.
При попытке опросить по SNMP модуль ACE с машины 192.168.1.240 отзывается сам супервизор, а не модуль.
Не пойму что я делаю неправильно, может кто-то сталкивался с проблемой вывода MRTG на данный модуль, либо на подобные, буду благодарен за любую помощь.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35066
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Cisco ACE 20 MRTG

Непрочитанное сообщение Alex Keda » 2014-03-15 23:51:10

покажите кусочек snmpwalk
Убей их всех! Бог потом рассортирует...