Нужен libcups.so.2 линуксовый

Проблемы установки, настройки и работы Правильной Операционной Системы

Модератор: terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35092
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение Alex Keda » 2008-02-08 10:54:12

de-signer писал(а):

Код: Выделить всё

$ truss rastertosamsungspl
truss: cannot open /proc/curproc/mem: No such file or directory
truss: cannot open1 /proc/34369/mem: No such file or directory
$ ls /proc
$
Кхм.... Куда это он меня послал?
это?
Убей их всех! Бог потом рассортирует...

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

de-signer
сержант
Сообщения: 220
Зарегистрирован: 2007-05-11 14:39:01
Откуда: Отсюда :)

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение de-signer » 2008-02-08 10:56:43

Да нет! :) truss пошёл. Тремя-четыремя постами выше я ж его вывод привёл.
То же самое у rastertosamsungspl, а именно undefined symbol: __mb_cur_max
---
"Если я рассуждаю логично, то это значит только то, что я не сумашедший, но вовсе не доказывает, что я прав" (с)И.П.Павлов

de-signer
сержант
Сообщения: 220
Зарегистрирован: 2007-05-11 14:39:01
Откуда: Отсюда :)

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение de-signer » 2008-02-08 11:17:02

2zingel
Откуда берётся /lib стало ясно. Но в /usr/compat/lib/ нету libiconv*.
Попробовал прописать первой строкой /usr/compat/lib -- не помогло.
---
"Если я рассуждаю логично, то это значит только то, что я не сумашедший, но вовсе не доказывает, что я прав" (с)И.П.Павлов

de-signer
сержант
Сообщения: 220
Зарегистрирован: 2007-05-11 14:39:01
Откуда: Отсюда :)

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение de-signer » 2008-02-09 17:54:32

2zingel
Не покидай нас =(
---
"Если я рассуждаю логично, то это значит только то, что я не сумашедший, но вовсе не доказывает, что я прав" (с)И.П.Павлов

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение zingel » 2008-02-09 21:38:55

нутк надо поставить compat5 &&
/usr/ports/devel/linuxthreads и обновить converters/libiconv
Z301171463546 - можно пожертвовать мне денег

Аватара пользователя
iZEN
ст. лейтенант
Сообщения: 1087
Зарегистрирован: 2007-09-15 16:45:26
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение iZEN » 2008-02-10 19:52:24

de-signer писал(а):df я в первую очередь запустил :)

Код: Выделить всё

Filesystem     Size    Used   Avail Capacity  Mounted on
/dev/ad0s1a    496M    261M    195M    57%    /
devfs          1.0K    1.0K      0B   100%    /dev
/dev/ad0s1e    496M    4.3M    452M     1%    /tmp
/dev/ad0s1f     25G    7.9G     15G    34%    /usr
/dev/ad0s1d    1.2G    135M    993M    12%    /var
чё-та не видать :)
Добавь следующую строчку в /etc/fstab:

Код: Выделить всё

linprocfs      /compat/linux/proc         linprocfs              rw          0        0
GNU/Linux — это не Unix и даже никогда им не был, и, что самое смешное, никогда им не станет — GNU's Not Unix

Аватара пользователя
iZEN
ст. лейтенант
Сообщения: 1087
Зарегистрирован: 2007-09-15 16:45:26
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение iZEN » 2008-02-10 19:53:54

xxx
Последний раз редактировалось iZEN 2008-02-10 19:59:24, всего редактировалось 1 раз.
GNU/Linux — это не Unix и даже никогда им не был, и, что самое смешное, никогда им не станет — GNU's Not Unix

Аватара пользователя
iZEN
ст. лейтенант
Сообщения: 1087
Зарегистрирован: 2007-09-15 16:45:26
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение iZEN » 2008-02-10 19:54:44

iZEN писал(а):
zingel писал(а):нутк надо поставить compat5 <...>
Что даст установка compat5, если compat5 -- библиотеки совместимости с предыдущими версиями FreeBSD?
Последний раз редактировалось iZEN 2008-02-10 19:58:33, всего редактировалось 1 раз.
GNU/Linux — это не Unix и даже никогда им не был, и, что самое смешное, никогда им не станет — GNU's Not Unix

Аватара пользователя
iZEN
ст. лейтенант
Сообщения: 1087
Зарегистрирован: 2007-09-15 16:45:26
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение iZEN » 2008-02-10 19:58:11

Вообще же, предлагаю поставить нативный ghostscript-gpl (порт: ports/print/ghostscript-gpl/). В нём выбрать драйвера для Samsung. Затем установить CUPS.
GNU/Linux — это не Unix и даже никогда им не был, и, что самое смешное, никогда им не станет — GNU's Not Unix

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение zingel » 2008-02-10 20:42:01

Что даст установка compat5, если compat5 -- библиотеки совместимости с предыдущими версиями FreeBSD?
Возможность поддержки old DEFAULT_LIB_INSTALL_PATH && старых environment variables через setenv для iconv.h
ghostscript-gpl.
Не факт, что заработает.
Z301171463546 - можно пожертвовать мне денег

Аватара пользователя
iZEN
ст. лейтенант
Сообщения: 1087
Зарегистрирован: 2007-09-15 16:45:26
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение iZEN » 2008-02-11 1:10:47

zingel писал(а):
ghostscript-gpl.
Не факт, что заработает.
Попробовать стоит на "чистой" машине, так как ghostscript-gpl всё же активно обновляется.
GNU/Linux — это не Unix и даже никогда им не был, и, что самое смешное, никогда им не станет — GNU's Not Unix

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение zingel » 2008-02-12 2:35:10

de-signer что-то не отвечает, видать принтер на него обиделся и убежал к бухам....
Z301171463546 - можно пожертвовать мне денег

de-signer
сержант
Сообщения: 220
Зарегистрирован: 2007-05-11 14:39:01
Откуда: Отсюда :)

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение de-signer » 2008-02-12 11:06:57

Я жиииив !! Кому из смертных нужна моя помощь? (с) Мушу м/ф "Мулан" =)
---
Про /usr/ports/devel/linuxthreads - просит поставить сырцы в /usr/src. Странно. Все сырцы установлены. Что ему надобно?
Про linuxfs - уже стоит.
ghostscript? Попробую.
---
"Если я рассуждаю логично, то это значит только то, что я не сумашедший, но вовсе не доказывает, что я прав" (с)И.П.Павлов

de-signer
сержант
Сообщения: 220
Зарегистрирован: 2007-05-11 14:39:01
Откуда: Отсюда :)

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение de-signer » 2008-02-12 12:05:45

ghostscript-gpl зачем-то начинает собирать xorg-libraries. На кой чёрт они ему сдались?
Не собираются - куча ошибок. Иксы - 6-ые. Трафика тянуть новьё - нет.

*Что за жизнь? =( Пойду стучаться головой об стену =)*
---
"Если я рассуждаю логично, то это значит только то, что я не сумашедший, но вовсе не доказывает, что я прав" (с)И.П.Павлов

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение zingel » 2008-02-12 13:35:11

есть спицификация на устройсвто? =)
если есть, давай.....
Z301171463546 - можно пожертвовать мне денег

de-signer
сержант
Сообщения: 220
Зарегистрирован: 2007-05-11 14:39:01
Откуда: Отсюда :)

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение de-signer » 2008-02-12 13:58:28

Он поставляется:
- собственно МФУ: Samsung SCX-4100;
- Quick install guide (формата A2 сложенный дважды до формата A4);
- набор гарантийных карточек;
- анкета аля конверт для "Службы работы с потребителями компании Samsung";
- USB шнур;
- CD-ROM с дровами (для винды и линуха) и ПО SmartЧего-тотам.
-----
Итого: 6 наименований + пакетики для всего этого.
---
"Если я рассуждаю логично, то это значит только то, что я не сумашедший, но вовсе не доказывает, что я прав" (с)И.П.Павлов

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение zingel » 2008-02-12 14:10:56

поближе к асму, так сказать, можно ли ? =)
Z301171463546 - можно пожертвовать мне денег

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35092
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение Alex Keda » 2008-02-12 14:23:35

de-signer писал(а): - анкета аля конверт для "Службы работы с потребителями компании Samsung";
вот это и надо сделать.
Убей их всех! Бог потом рассортирует...

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение zingel » 2008-02-12 14:29:35

Одним словом, если есть желание нужна спецификация или исходный код (если есть под тех, кто никогда не взлетит {linux} то можно и его адаптировать) но это не стоит того...увольте свой отдел снабжения....
Z301171463546 - можно пожертвовать мне денег

Аватара пользователя
iZEN
ст. лейтенант
Сообщения: 1087
Зарегистрирован: 2007-09-15 16:45:26
Контактная информация:

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение iZEN » 2008-02-12 15:39:49

de-signer писал(а):ghostscript-gpl зачем-то начинает собирать xorg-libraries. На кой чёрт они ему сдались?
Не собираются - куча ошибок. Иксы - 6-ые. Трафика тянуть новьё - нет.
Без Xorg: ports/print/ghostscript-gpl-nox11/

Ответьте мне, почему трудно провести обновление системы до 6.3-RELEASE и обновить локальное дерево портов, чтобы нормально поставить CUPS и ghostscript-gpl (как правило, они новее, чем в любом дистрибутиве Linux)? Выхода в Интернет нету?

Тогда зачем заниматься извращениями по прикручиванию драйверов Linux'а к FreeBSD, может проще поставить Linux?
Последний раз редактировалось iZEN 2008-02-12 15:42:46, всего редактировалось 1 раз.
GNU/Linux — это не Unix и даже никогда им не был, и, что самое смешное, никогда им не станет — GNU's Not Unix

de-signer
сержант
Сообщения: 220
Зарегистрирован: 2007-05-11 14:39:01
Откуда: Отсюда :)

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение de-signer » 2008-02-12 16:17:22

Ответьте мне, почему трудно провести обновление системы до 6.3-RELEASE и обновить локальное дерево портов, чтобы нормально поставить CUPS и ghostscript-gpl (как правило, они новее, чем в любом дистрибутиве Linux)? Выхода в Интернет нету?
Тише, тише! Чего возмущаться-то? Есть инет, но не анлим. Дерево от 6.3. Потихоньку стягиваю distfiles. Скоро, думаю, ghostscript-gpl встанет.
---
libGL было закричал, что у кого-то configure.in нет, зашёл туда. Посмотрел. Есть configure.bak %( Впервые такой вижу. По содержимому, вроде оно. Скопировал. Встало. Сейчас компилится ghostscript-gpl.

P.S.: пока пост ваял -- скомпилился. Сейчас ставлю и пробую.
---
"Если я рассуждаю логично, то это значит только то, что я не сумашедший, но вовсе не доказывает, что я прав" (с)И.П.Павлов

de-signer
сержант
Сообщения: 220
Зарегистрирован: 2007-05-11 14:39:01
Откуда: Отсюда :)

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение de-signer » 2008-02-12 16:50:15

ghostscript-gpl и cups успешно обновились и встали. Настроил cups на usb: /dev/ulpt0. Под юзером запищал: access denied. Подправил рутом: chmod 777 /dev/ulpt0. Теперь cups ругается: USB port busy, retry in 30 seconds. Чем он busy х.з. Никто, кроме самого cups, порт не юзает.
Где лопата?

P.S.: и как юзать ghostscript? Встать-то он встал, а где и как его юзать?
---
"Если я рассуждаю логично, то это значит только то, что я не сумашедший, но вовсе не доказывает, что я прав" (с)И.П.Павлов

de-signer
сержант
Сообщения: 220
Зарегистрирован: 2007-05-11 14:39:01
Откуда: Отсюда :)

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение de-signer » 2008-02-12 17:02:40

CUPS выдал на "Set printer options":
Error:

Код: Выделить всё

successful-ok
Чё-та винду напомнило с её диалогом: заголовок -- Фатальная ошибка. Текст диалога -- нет ошибки =)
---
"Если я рассуждаю логично, то это значит только то, что я не сумашедший, но вовсе не доказывает, что я прав" (с)И.П.Павлов

Nick
проходил мимо

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение Nick » 2008-02-12 17:33:35

Мучаюсь с той же дрянью. Только принтер другой - Xerox WC3119. Умиляет то, что под Линуксами дрова от Самсунга (Ксерокса) работают без проблем. И библиотека libcups.so.2 стоит в линуксе (проверял на Ubuntu 7.04) Тож сижу думаю как сие чудо заставить печатать :cry:

de-signer
сержант
Сообщения: 220
Зарегистрирован: 2007-05-11 14:39:01
Откуда: Отсюда :)

Re: Нужен libcups.so.2 линуксовый

Непрочитанное сообщение de-signer » 2008-02-12 17:41:59

Замочил cupsd (кстати, как его по человечески остановить/запустить не юзая ps и kill?) Выключил/включил принтер. Поставил пермишены на устройство. Запустил cupsd. Полёт нормальный. Посылаю тестовую страницу. Тишина. Ни реакции принтера, ни ошибок. Командую CUPSу - Stop/Start printer получаю: USB device busy.
Под рутом тут же:

Код: Выделить всё

%echo labuda > /dev/ulpt0
/dev/ulpt0: Device busy
%
Стопаю КУПС. Дисконнект/коннект принтера. Под рутом:

Код: Выделить всё

%echo labuda > /dev/ulpt0
%
И принтер показывает на своём ЖДК: "Идет печать..." Но ничего не печатает, НО хоть реагирует.
Чем его так CUPS занимает? Может настроил чего не так?
---
"Если я рассуждаю логично, то это значит только то, что я не сумашедший, но вовсе не доказывает, что я прав" (с)И.П.Павлов