Модуль mod_php5

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
Reken
лейтенант
Сообщения: 605
Зарегистрирован: 2014-06-30 11:23:24
Откуда: Республика Карелия

Модуль mod_php5

Непрочитанное сообщение Reken » 2015-10-07 14:46:33

Доброго времени суток
Помогите мне пожалуйста разобраться в проблеме:
Я установил FreeBSD 9.3 , далее поставил из портов APACHE22-2.2.31 а так же php5-5.20.3_8

Суть проблемы в том, что в файле конфигурации /usr/local/etc/apache22/httpd.conf прописан пункт: LoadModule php5_module libexec/apache22/libphp5.so
И при запуске APACHE22, происходит ошибка:

Код: Выделить всё

Performing sanity check on apache22 configuration:
httpd: Syntax error on line 108 of /usr/local/etc/apache22/httpd.conf: Cannot load /usr/local/libexec/apache22/libphp5.so into server: Cannot open "/usr/local/libexec/apache22/libphp5.so
Starting apache22"
httpd: Syntax error on line 108 of /usr/local/etc/apache22/httpd.conf: Cannot load /usr/local/libexec/apache22/libphp5.so into server: Cannot open "/usr/local/libexec/apache22/libphp5.so
А в файле /usr/ports/UPDATING я нашел следующее:

Код: Выделить всё

20140327
AFFECTS: users of lang/php5 and lang/php55 with Apache module
AUTHOR: ale@FreeBSD.org

The apache php module has been separated from the main php port
If you had apache option selected, you have to perform the following steps
1) update your lang/php8 options i.e. make
2) rebuild lang/php port
install www/mod_php

It is *mandatory* to build both ports with the same DEBUG and ZTS options, so if you have a threaded apche (i.e. worker or event MPM) you have to select the ZTS option in lang/php* port
Я так понял из этого, что модуль mod_php5 нужно установить отдельно...
Попробовал его установить, но получил ошибку:

Код: Выделить всё

/usr/ports/www/mod_php5 # make install clean
mod_php5-5.4.45,1 is marked as broken: : Error from bsd.apache.mk. apache22 is installed (or APACHE_PORT is defined) and port requires apache
Помогите пожалуйста разобраться...

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Гость
проходил мимо

Модуль mod_php5

Непрочитанное сообщение Гость » 2015-10-07 15:01:38

а если

Код: Выделить всё

pkg install mod_php5
?

guest
проходил мимо

Модуль mod_php5

Непрочитанное сообщение guest » 2015-10-07 16:59:56

чистая установка 9.3-R?
затем на чистую систему:
- apache22
- php55

так?
если так, покажите:

# cat /etc/make.conf

guest
проходил мимо

Модуль mod_php5

Непрочитанное сообщение guest » 2015-10-07 17:28:42

если ставили /usr/ports/lang/php55, ставьте модуль: /usr/ports/www/mod_php55

ну а в /etc/make.conf можно или нужно:

DEFAULT_VERSIONS+=php=5.5 apache=2.2

Аватара пользователя
Reken
лейтенант
Сообщения: 605
Зарегистрирован: 2014-06-30 11:23:24
Откуда: Республика Карелия

Модуль mod_php5

Непрочитанное сообщение Reken » 2015-10-08 9:24:16

Да, чистая установка FreeBSD 9.3 (с диска...)

Далее чистую FreeBSD настроил на работу под "прокси сервером", сделал это следующими действиями:

Код: Выделить всё

# vi /etc/rc.conf
gateway_enable="YES"
ifconfig_sis0="inet 192.168.99.37 netmask 255.255.255.0" # внешняя сетевая карта
ifconfig_rl0="inet 192.168.0.17 netmask 255.255.255.0"   # внутрення сетевая карта
defaultrouter="192.168.99.4"                             # шлюз
sshd_enable="YES"
ntpd_enable="YES"
named_enable="YES"

# vi /etc/resolv.conf
nameserver 192.168.99.5   # Мой DNS 
nameserver 127.0.0.1      # Стандартный DNS
nameserver 8.8.8.8        # DNS от google

# vi /etc/namedb/named.conf
listen-on { 127.0.0.1; 192.168.0.17; };
forwarders {
127.0.0.1; 192.168.99.5; 8.8.8.8;
};
Перезагрузка FreeBSD

# vi /.cshrc
Добавил туда следующее:
setenv HTTP_PROXY http://192.168.99.4:3128
setenv http_proxy http://192.168.99.4:3128
setenv FTP_PROXY http://192.168.99.4:3128
setenv ftp_proxy http://192.168.99.4:3128
setenv FETCH_CMD "/usr/bin/fetch -ARrvp -T 10"

# vi /etc/make.conf
Добавил туда следующее:
FETCH_ENV=HTTP_PROXY=http://192.168.99.4:3128
FETCH_ENV=http_proxy=http://192.168.99.4:3128
FETCH_ENV=FTP_PROXY=http://192.168.99.4:3128
FETCH_ENV=ftp_proxy=http://192.168.99.4:3128
FETCH_CMD=/usr/bin/fetch -ARrvp -T 10

Перезагрузка FreeBSD
После этих действий обновил порты:
portsnap fetch extract

Далее установка из портов:
fetchmail
APACHE22
mysql56-serve
php5
postfixadmin

Это я расписал подробные мои действия...
__________________________________________

После того, как я добавил в файл конфигурации APACHE22 строчку LoadModule php5_module libexec/apache22/libphp5.so, то APACHE начал на неё ругаться...

Отправлено спустя 10 минут 54 секунды:
/etc/make.conf содержит только:

Код: Выделить всё

FETCH_ENV=HTTP_PROXY=http://192.168.99.4:3128
FETCH_ENV=http_proxy=http://192.168.99.4:3128
FETCH_ENV=FTP_PROXY=http://192.168.99.4:3128
FETCH_ENV=ftp_proxy=http://192.168.99.4:3128
FETCH_CMD=/usr/bin/fetch -ARrvp -T 10

guest
проходил мимо

Модуль mod_php5

Непрочитанное сообщение guest » 2015-10-08 9:54:34

Sorry, но Вы учиться не хотите и внимательности ноль:

есть порты (на момент моего последнего обновления, посему могут быть небольшие изменения):

Код: Выделить всё

[joker]~ > ls -la /usr/ports/lang/ | grep php5
drwxr-xr-x    3 root  wheel   512 11 сен 10:48 php5
drwxr-xr-x    2 root  wheel   512 28 ноя  2014 php5-extensions
drwxr-xr-x    3 root  wheel   512 11 сен 10:48 php55
drwxr-xr-x    2 root  wheel   512 28 ноя  2014 php55-extensions
drwxr-xr-x    3 root  wheel   512 11 сен 10:48 php56
drwxr-xr-x    2 root  wheel   512 28 ноя  2014 php56-extensions
[joker]~ >
разницу ниже видите:

lang/php5 -> php 5.4.ab
lang/php55 -> php 5.5.cd
lang/php56 -> php 5.6.ef
?

default'ы на данный момент: apache22, mysql56, php56

есть порты:

Код: Выделить всё

[joker]~ > ls -la /usr/ports/www/ | grep mod_php
drwxr-xr-x     2 root  wheel    512 12 апр  2014 mod_php5
drwxr-xr-x     2 root  wheel    512 12 апр  2014 mod_php55
drwxr-xr-x     2 root  wheel    512 28 ноя  2014 mod_php56
[joker]~ >
нужно объяснять что в случае установки lang/php5 -> модуль нужен mod_php5,
в случае lang/php55 -> mod_php55 и by default будет lang/php56 с mod_php56.

Разница понятна? видна?

Если Вы хотите изменить текущие default'ы в портах, добавляете в /etc/make.conf
DEFAULT_VERSIONS+=php=5.5 apache=2.2

после чего собираете порты.

Все это есть в документации: handbook, man ports, less /usr/ports/UPDATING

Аватара пользователя
Reken
лейтенант
Сообщения: 605
Зарегистрирован: 2014-06-30 11:23:24
Откуда: Республика Карелия

Модуль mod_php5

Непрочитанное сообщение Reken » 2015-10-08 14:10:21

guest писал(а):Sorry, но Вы учиться не хотите и внимательности ноль:
Стараюсь исправиться :pardon:
Quest я наверное всё равно не правильно понимаю Ваши слова...
guest писал(а): разницу ниже видите:
lang/php5 -> php 5.4.ab
Из порта php5 установится версия 5.4.ab, правильно? Или я не правильно понял?
guest писал(а): lang/php5 -> модуль нужен mod_php5
Это понятно, для каждого php5 своя версия модуля
guest писал(а): default'ы на данный момент: apache22, mysql56, php56
Это из usr/ports/UPDATING видно?
guest писал(а): Если Вы хотите изменить текущие default'ы в портах, добавляете в /etc/make.conf
DEFAULT_VERSIONS+=php=5.5 apache=2.2
Почему php=5.5? У меня же в системе установлен php5 значит:
guest писал(а): lang/php5 -> php 5.4.ab
Получается нужно добавить php=5.4 ? Или я не правильно понял?

guest
проходил мимо

Модуль mod_php5

Непрочитанное сообщение guest » 2015-10-08 14:23:18

Reken писал(а):
guest писал(а):Sorry, но Вы учиться не хотите и внимательности ноль:
Стараюсь исправиться :pardon:
Quest я наверное всё равно не правильно понимаю Ваши слова...
guest писал(а): разницу ниже видите:
lang/php5 -> php 5.4.ab
Из порта php5 установится версия 5.4.ab, правильно? Или я не правильно понял?
guest писал(а): lang/php5 -> модуль нужен mod_php5
Это понятно, для каждого php5 своя версия модуля
guest писал(а): default'ы на данный момент: apache22, mysql56, php56
Это из usr/ports/UPDATING видно?
guest писал(а): Если Вы хотите изменить текущие default'ы в портах, добавляете в /etc/make.conf
DEFAULT_VERSIONS+=php=5.5 apache=2.2
Почему php=5.5? У меня же в системе установлен php5 значит:
guest писал(а): lang/php5 -> php 5.4.ab
Получается нужно добавить php=5.4 ? Или я не правильно понял?
мне вообще непонятно что у Вас установлено, ибо Вы написали php5-5.20.3_8

Все остальное я расписал, осознаете что и как делать - сделаете, заставляйте
серое вещество напрягаться и работать.

Удачи

Аватара пользователя
Reken
лейтенант
Сообщения: 605
Зарегистрирован: 2014-06-30 11:23:24
Откуда: Республика Карелия

Модуль mod_php5

Непрочитанное сообщение Reken » 2015-10-08 15:47:10

Всё получилось
mod_php5-5.4.45,1 установился...

guest
проходил мимо

Модуль mod_php5

Непрочитанное сообщение guest » 2015-10-08 17:52:58

Reken писал(а):Всё получилось
mod_php5-5.4.45,1 установился...
ну вот и результат