не получается запустить ftpd

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
anachrom
рядовой
Сообщения: 30
Зарегистрирован: 2009-11-25 12:32:21

не получается запустить ftpd

Непрочитанное сообщение anachrom » 2011-01-24 12:59:28

FreeBSD 8.0 ядро стандартное. только поставил, никаких настроек ещё не делал. пытаюсь включить ftpd не выходит. По шагам (как написано в статье http://www.lissyara.su/articles/freebsd ... st_tuning/)
т.к. ничего не ставил inetd.conf открывал через ee

Код: Выделить всё

ee /etc/inetd.conf
раскоментировал строчку:

Код: Выделить всё

ftp   stream  tcp   nowait  root  /usr/libexec/ftpd  ftpd -l
далее набираю:

Код: Выделить всё

killall -1 inetd
и в ответ получаю

Код: Выделить всё

no matching  processes were found
ну и соответственно 21 порта нет

Что не так?
Последний раз редактировалось f_andrey 2011-01-24 23:28:55, всего редактировалось 1 раз.
Причина: Автору, выбирайте пожалуйста раздел соответствуюший тематике вашего сообщения. оформляйте сообщен е по человечески, приводите полную диагностику, больше логов больше вероятности ответа, а не флуда

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: не получается запустить ftpd

Непрочитанное сообщение hizel » 2011-01-24 13:15:27

что значит 21-ого порта нет?
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

anachrom
рядовой
Сообщения: 30
Зарегистрирован: 2009-11-25 12:32:21

Re: не получается запустить ftpd

Непрочитанное сообщение anachrom » 2011-01-24 13:58:25

hizel писал(а):что значит 21-ого порта нет?
это значит, что inetd на 21 порту не весит (root inetd 125 4 tcp4 *:21)
и вообще ни где не весит

Аватара пользователя
unix-admin
ст. сержант
Сообщения: 324
Зарегистрирован: 2010-11-26 12:43:04
Откуда: Cornucopia

Re: не получается запустить ftpd

Непрочитанное сообщение unix-admin » 2011-01-24 15:11:12

Код: Выделить всё

/etc/rc.d/inetd rcvar

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: не получается запустить ftpd

Непрочитанное сообщение hizel » 2011-01-24 16:16:01

К.О.

Код: Выделить всё

echo 'inetd_enable="YES"' >> /etc/rc.conf
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

Аватара пользователя
unix-admin
ст. сержант
Сообщения: 324
Зарегистрирован: 2010-11-26 12:43:04
Откуда: Cornucopia

Re: не получается запустить ftpd

Непрочитанное сообщение unix-admin » 2011-01-24 17:30:40

hizel писал(а):К.О.

Код: Выделить всё

echo 'inetd_enable="YES"' >> /etc/rc.conf
если его там нет...

Аватара пользователя
ADRE
майор
Сообщения: 2641
Зарегистрирован: 2007-07-26 8:53:49
Контактная информация:

Re: не получается запустить ftpd

Непрочитанное сообщение ADRE » 2011-01-24 19:42:02

а после этого:

Код: Выделить всё

/etc/rc.d/inetd start
далее скопируйте в данное окно вывод:

Код: Выделить всё

sockstat -4
и

Код: Выделить всё

ipfw list
//del

Charlz_Klug_
проходил мимо

Re: не получается запустить ftpd

Непрочитанное сообщение Charlz_Klug_ » 2011-01-25 6:24:01

А Я настраивал так:
Добавил следующие строки в /etc/rc.conf:

Код: Выделить всё

ftpd_enable="YES"
ftpd_flags="-D -d -r"
Файл /etc/rc.conf выглядит так:

Код: Выделить всё

Yasmina# cat /etc/rc.conf

# -- sysinstall generated deltas -- # Fri Oct  1 02:12:47 2010
# Created: Fri Oct  1 02:12:47 2010
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
keymap="us.iso"
sshd_enable="YES"
# -- sysinstall generated deltas -- # Fri Oct  1 07:02:45 2010
ifconfig_vr0="inet 192.168.20.140  netmask 255.255.255.0"
hostname="Yasmina.local"
ifconfig_ed0="inet 192.168.21.1 netmask 255.255.255.0"
bozohttpd_enable="YES"
bozohttpd_flags="-b -c /usr/home/Charlz_Klug/ManSubWeb/cgi-bin -U nobody /usr/home/Charlz_Klug/ManSubWeb"
ftpd_enable="YES"
ftpd_flags="-D -d -r"

Yasmina#
Добавил нового пользователя:

Код: Выделить всё

Yasmina# adduser
Username: ats2
Full name: Ftp user
Uid (Leave empty for default):
Login group [ats2]:
Login group is ats2. Invite ats2 into other groups? []: n
Group n does not exist!
Login group is ats2. Invite ats2 into other groups? []:
Login class [default]:
Shell (sh csh tcsh nologin) [sh]: nologin
Home directory [/home/ats2]:
Home directory permissions (Leave empty for default):
Use password-based authentication? [yes]:
Use an empty password? (yes/no) [no]:
Use a random password? (yes/no) [no]:
Enter password:
Enter password again:
Lock out the account after creation? [no]:
Username   : ats2
Password   : *****
Full Name  : Ftp user
Uid        : 1003
Class      :
Groups     : ats2
Home       : /home/ats2
Home Mode  :
Shell      : /usr/sbin/nologin
Locked     : no
OK? (yes/no): yes
adduser: INFO: Successfully added (ats2) to the user database.
Add another user? (yes/no): no
Goodbye!
Yasmina#
Перезагрузил Yasmina. Как оказалось впоследствии, родной ftpd поставляемый вместе с FreeBSD не пускает пользователей с шеллом nologin ("Shell : /usr/sbin/nologin"). Поэтому пришлось удалить пользователя ats2 и создать пользователя ats2 со следующими свойствами:

Код: Выделить всё

Charlz_Klug@Yasmina$ finger ats2
Login: ats2                             Name: ftp user
Directory: /home/ats2                   Shell: /bin/sh
Last login Thu Dec 16 11:09 (UZT) on pts/0 from 192.168.20.28
No Mail.
No Plan.
Charlz_Klug@Yasmina$ groups ats2
ats2
ats2 с шеллом /bin/sh, домашней директорией /home/ats2, и группой ats2. Но, возникла следующая проблема: этот пользователь может входить в систему со свзкой логин-пароль:"ats2"-"****". Чтобы отключить такое поведение добавил строку "DenyGroups ats2", теперь файл /etc/ssh/sshd_config выглядит так:

Код: Выделить всё

Charlz_Klug@Yasmina$ cat /etc/ssh/sshd_config|grep -vE '^#'|sed '/^$/d'
Protocol 2
UseDNS no
Subsystem       sftp    /usr/libexec/sftp-server
DenyGroups ats2
Charlz_Klug@Yasmina$
Перезагрузил компьютер и теперь пользователи в группе "ats2" не могут войти в систему через ssh. В /etc/inetd.conf всё закомментировано.

anachrom
рядовой
Сообщения: 30
Зарегистрирован: 2009-11-25 12:32:21

Re: не получается запустить ftpd

Непрочитанное сообщение anachrom » 2011-01-25 10:20:21

Всем большое спасибо. За помощь и за ресурс по фряшке.
Что-то я даже и не подумал про то что нужно inetd стартовать. Теперь красуется в rc.conf и стартует с системой.