Ошибка при установке 9.1

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
icb
лейтенант
Сообщения: 739
Зарегистрирован: 2008-07-15 16:11:11

Ошибка при установке 9.1

Непрочитанное сообщение icb » 2013-04-02 12:29:53

Загружаюсь с установочного CD. Все идет вроде нормально, но прерывается такой ошибкой:

Код: Выделить всё

Mounting from cd9660:/dev/iso9660/FREEBSD_INSTALL failed with error 19
....
mountroot>
Дальше я монтирую cd9660:/dev/cd0 и все нормально продолжается.
Но ведь это не совсем нормальное поведение. В чем может быть проблема?

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
skeletor
майор
Сообщения: 2486
Зарегистрирован: 2007-11-16 18:22:04
Откуда: Kiev
Контактная информация:

Re: Ошибка при установке 9.1

Непрочитанное сообщение skeletor » 2013-04-02 13:56:40

что-то либо с диском, либо с приводом, либо со шлефом, либо с iso-шником, который качался, либо ...
"Винда съела дрова и резет здесь не фурычит."
"Все говорят, что у меня /dev/hands криво и я всё делаю через /dev/ass. А у меня этих фалов вообще нет!"

icb
лейтенант
Сообщения: 739
Зарегистрирован: 2008-07-15 16:11:11

Re: Ошибка при установке 9.1

Непрочитанное сообщение icb » 2013-04-02 14:13:35

Почему монтируется cd9660:/dev/iso9660/FREEBSD_INSTALL, а не cd9660:/dev/cd0?
Ошибка в образе?

Аватара пользователя
tom.cat
старшина
Сообщения: 441
Зарегистрирован: 2007-11-24 20:23:49
Откуда: Мытищи
Контактная информация:

Re: Ошибка при установке 9.1

Непрочитанное сообщение tom.cat » 2013-04-03 12:52:22

However, as is not unusual in the case of these seemingly intractable problems, the solution is readily available and very, very easy.
Here's where I found it and all that is need is to open the loader prompt during the CD/DVD/USB boot (by pressing 2 or ESC) and adding the following line:
set debug.acpi.disabled ="hostres"
and then booting with
boot
Как бе подробнее
When you see pigs fly it means Windows has become open source

Аватара пользователя
tom.cat
старшина
Сообщения: 441
Зарегистрирован: 2007-11-24 20:23:49
Откуда: Мытищи
Контактная информация:

Re: Ошибка при установке 9.1

Непрочитанное сообщение tom.cat » 2013-04-03 12:57:29

Open Issues
[amd64, i386] FreeBSD 9.0-RELEASE includes several changes to improve resource management of PCI devices. Some x86 machines may not boot or may have devices that no longer attach when using ACPI as a result of these changes. This can be worked around by setting a loader(8) tunable debug.acpi.disabled to hostres. To do this, enter the following lines at the loader prompt:

Код: Выделить всё

set debug.acpi.disabled="hostres"
boot
Or, put the following line into /boot/loader.conf:

Код: Выделить всё

debug.acpi.disabled="hostres"
When you see pigs fly it means Windows has become open source

bRUtality
рядовой
Сообщения: 27
Зарегистрирован: 2013-04-04 16:19:32

Re: Ошибка при установке 9.1

Непрочитанное сообщение bRUtality » 2013-04-04 16:49:09

Всем доброго времени!

Бьюсь с той же траблой. Сначала пробовал применить решение из 1-го поста, не получается:

Код: Выделить всё

mountroot> cd9660:/dev/cd0
Trying to mount root from cd9660:/dev/cd0 []...
g_vfs_done():cd0[READ(offset=32768, length=2048)]error = 6
Mounting from cd9660:/dev/cd0 failed with error 6.
Потом попробовал с конфигом загрузки. Жму ESC, когда появляется рожица дьяволенка, печатаю

Код: Выделить всё

set debug.acpi.disabled ="hostres"
boot
начинается загрузка, опять та же самая 19-ая ошибка, но в конце еще такой аут:

Код: Выделить всё

mountroot> (probe:umass-sim0:0:0:0): INQUIRY. CDB: 12 0 0 1 0 0
(probe:umass-sim0:0:0:0): CAM status: CCB request completed with an error
(probe:umass-sim0:0:0:0): Retrying command
Установку произвожу с iLO, образ записан на диск. В принципе, могу попробовать непосредственно на серваке (имеется USB-привод), но думаю, ничего не измениться, т.к. через физический привод ставил версию 9.0 - ошибки были все те же (тогда я забил и поставил 8.3).
Есть предположение, что у фряхи, начиная с версий 9.0, непростые отношения с рейдами (на этом серваке RAID1 4 штуки), но как с этим жить - инфы не нарыл.

Что можно сделать?
Заранее спасибо за помощь.

bRUtality
рядовой
Сообщения: 27
Зарегистрирован: 2013-04-04 16:19:32

Re: Ошибка при установке 9.1

Непрочитанное сообщение bRUtality » 2013-04-05 11:55:38

C USB привода инсталировалось без проблем :Yahoo!:

sudo
мл. сержант
Сообщения: 132
Зарегистрирован: 2011-02-05 10:54:11

Re: Ошибка при установке 9.1

Непрочитанное сообщение sudo » 2013-04-11 15:04:27

Код: Выделить всё

mountroot> cd9660:/dev/iso9660/FREEBSD_INSTALL  ro

Dmitriy_3206
проходил мимо

Re: Ошибка при установке 9.1

Непрочитанное сообщение Dmitriy_3206 » 2013-04-11 19:12:06

Альтернатива - инсталятор PCBsd - там есть возможность установить "голую" Free

ArtemZ
проходил мимо
Сообщения: 4
Зарегистрирован: 2008-02-12 13:52:16

Re: Ошибка при установке 9.1

Непрочитанное сообщение ArtemZ » 2013-06-04 11:10:32

Dmitriy_3206 писал(а):Альтернатива - инсталятор PCBsd - там есть возможность установить "голую" Free
Никакая это не альтернатива, точно такая же ошибка при загрузке PCBSD из HP iLO

AmoN
проходил мимо

Re: Ошибка при установке 9.1

Непрочитанное сообщение AmoN » 2014-03-15 20:56:41

У меня тож сервак HP не хотел инталиться с usb привода, у меня на USB DVDROMе два конца, так помогло только когда я их оба переткнул в порты на usb порты сзади корпуса, те что отдельно от всех остальных портов и все без ошибок установилось :pardon:

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35182
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Ошибка при установке 9.1

Непрочитанное сообщение Alex Keda » 2014-03-15 23:42:40

AmoN писал(а):У меня тож сервак HP не хотел инталиться с usb привода, у меня на USB DVDROMе два конца, так помогло только когда я их оба переткнул в порты на usb порты сзади корпуса, те что отдельно от всех остальных портов и все без ошибок установилось :pardon:
питания не хватало
--
вообще не понимаю прикола инсталлить с сидюков - ручками, с флэшки, всё делается проще и быстрей
Убей их всех! Бог потом рассортирует...

Dmitriy_3206
рядовой
Сообщения: 44
Зарегистрирован: 2014-10-13 15:51:34

Ошибка при установке 9.1

Непрочитанное сообщение Dmitriy_3206 » 2016-09-18 1:16:01

вот и я получил такую же ошибку
Оказалось HDD давно стоял в Raid. Потом долго лежал на полке, я и забыть успел.
Помогло set kern.geom.raid.enable=0