После переноса сайт не стартует

Простые/общие вопросы по UNIX системам. Спросите здесь, если вы новичок

Модераторы: vadim64, terminus

Правила форума
Убедительная просьба юзать теги [cоde] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
mr. brightside
сержант
Сообщения: 260
Зарегистрирован: 2010-04-17 17:32:39
Откуда: Saint-Petersburg

После переноса сайт не стартует

Непрочитанное сообщение mr. brightside » 2010-11-25 19:25:56

Добрый день, уважаемые!

Старый сервак:

# uname -a
7.0-RELEASE FreeBSD 7.0-RELEASE i386

Версия апача:
Apache Version Apache/1.3.41 (Unix) PHP/5.2.5 mod_ssl/2.8.31 OpenSSL/0.9.8g

PHP версия:
PHP Version 5.2.5

Версия мускула:
MySQL 4.1.22

Новый сервак:

# uname -a
7.2-RELEASE FreeBSD 7.2-RELEASE i386


Версия апача:
# pkg_version -v | grep apache
apache+mod_ssl-1.3.41+2.8.31_2

PHP версия:
PHP Version 5.2.14

Версия мускула:
5.1.52

---------------

Итак, через mysqldump свернул,-перенес,-развернул мускульные базы, которые юзаются для сайта, выставил владельца, дал полные привилегии, поставил тот же пароль, что и на старом серве.

Базы развернулись, таблички все на месте - в общем тут все гуд.

Сам сайт сначала затарил. Потом скопировал себе на тачку (затарил, чтобы chmod не умер), потом залил на новый сервак. Там распаковал в DocumentRoot директории и поставил права на владельца www (Апач стартует от него, работает от него).

Апач настроил, , <directory>...</directory> тоже.

Пытаюсь открыть сайт через бразуер - пустая страница. Только иконка favicon подгружается.

Вопрос, - где выпрямлять руки?

Проблема в мускульных базах? Через пма их видно, но есть ошибки.
Проблема в битриксе? Может есть спец скрипт переноса, как для мускула - mysqldump?

Или, проблема в пхп? в error-log апача при рестарте оного получаю следующие ворнинги:

Код: Выделить всё

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/curl.so' - Cannot open "/usr/local/lib/php/20060613/curl.so"
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/exif.so' - Cannot open "/usr/local/lib/php/20060613/exif.so"
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/fribidi.so' - Cannot open "/usr/local/lib/php/20060613/fribidi.so&
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/imap.so' - Cannot open "/usr/local/lib/php/20060613/imap.so"
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/sqlite.so' - /usr/local/lib/php/20060613/sqlite.so: Undefined symbol &q
PHP Warning:  Module 'ctype' already loaded in Unknown on line 0
PHP Warning:  Module 'SimpleXML' already loaded in Unknown on line 0
PHP Warning:  Module 'dom' already loaded in Unknown on line 0
PHP Warning:  Module 'filter' already loaded in Unknown on line 0
PHP Warning:  Module 'ftp' already loaded in Unknown on line 0
PHP Warning:  Module 'gd' already loaded in Unknown on line 0
PHP Warning:  Module 'gettext' already loaded in Unknown on line 0
PHP Warning:  Module 'hash' already loaded in Unknown on line 0
PHP Warning:  Module 'iconv' already loaded in Unknown on line 0
PHP Warning:  Module 'json' already loaded in Unknown on line 0
PHP Warning:  Module 'ldap' already loaded in Unknown on line 0
PHP Warning:  Module 'mysql' already loaded in Unknown on line 0
PHP Warning:  Module 'openssl' already loaded in Unknown on line 0
PHP Warning:  Module 'PDO' already loaded in Unknown on line 0
PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0
PHP Warning:  Module 'posix' already loaded in Unknown on line 0
PHP Warning:  Module 'session' already loaded in Unknown on line 0
PHP Warning:  Module 'tokenizer' already loaded in Unknown on line 0
PHP Warning:  Module 'xml' already loaded in Unknown on line 0
PHP Warning:  Module 'xmlreader' already loaded in Unknown on line 0
PHP Warning:  Module 'xmlwriter' already loaded in Unknown on line 0
PHP Warning:  Module 'zlib' already loaded in Unknown on line 0
PHP Warning:  Module 'zip' already loaded in Unknown on line 0
Кроме того, у меня есть расширения php5.3, но не сам php5.3. Причем, эти расширения не установлены, если верить этому:

Код: Выделить всё

[root@mail /usr/ports/lang/php5-extensions]# make deinstall clean
===>  Deinstalling for lang/php5-extensions
===>   php5-extensions not installed, skipping
===>  Cleaning for php5-extensions-1.4
Короче, что то не так =) Помогите разобраться, пожалуйста... :st:
Только FreeBSD, только хардкор

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
server801
ст. лейтенант
Сообщения: 1386
Зарегистрирован: 2008-09-27 21:15:16
Откуда: Саратов
Контактная информация:

Re: После переноса сайт не стартует

Непрочитанное сообщение server801 » 2010-11-26 0:42:28

сноси весь php

Код: Выделить всё

pkg_info | grep php | awk '{print $1}' | xargs -o pkg_delete -f
ставь далее php52,все вопросы исчезнут само собой

Аватара пользователя
mr. brightside
сержант
Сообщения: 260
Зарегистрирован: 2010-04-17 17:32:39
Откуда: Saint-Petersburg

Re: После переноса сайт не стартует

Непрочитанное сообщение mr. brightside » 2010-11-26 21:11:31

сноси весь php

Код: Выделить всё • Развернуть

pkg_info | grep php | awk '{print $1}' | xargs -o pkg_delete -f


ставь далее php52,все вопросы исчезнут само собой
Спасибо большое! теперь с деревом все ок, пхп5.3 в дереве нет, даже pkgdb -F запускать не пришлось :crazy:

Тем не менее сайт все равно не стартует...

прикрепляю скрины пма, вдруг наведет на мысль...

P.S. пишу скриптик запроса к базе данных, кидаю в докьюментрут, чтобы проверить идет ли из самого каталога сайта коннект к базе - идет, запросы обрабатываются...

теперь, надо чтобы и битрикс умел также =)

эх... видимо все таки пути =(
Вложения
2.JPG
1.JPG
Только FreeBSD, только хардкор

Аватара пользователя
server801
ст. лейтенант
Сообщения: 1386
Зарегистрирован: 2008-09-27 21:15:16
Откуда: Саратов
Контактная информация:

Re: После переноса сайт не стартует

Непрочитанное сообщение server801 » 2010-11-26 21:54:07

ничего страшного и не вижу.апач то сам настроен для работы с пхп?

Аватара пользователя
mr. brightside
сержант
Сообщения: 260
Зарегистрирован: 2010-04-17 17:32:39
Откуда: Saint-Petersburg

Re: После переноса сайт не стартует

Непрочитанное сообщение mr. brightside » 2010-11-26 22:40:04

апач то сам настроен для работы с пхп?
ну конечно =)

у меня roundcube и phpMyAdmin то работают, запросы в базу тоже отрабатывают из самописного скрипта...

Дело все в том, что у предыдущего админа сайт лежал в каталоге /usr/local/apache/htdocs. Ставил он все из пакетов, пути установки менял, даже сам конфиг апача лежит на старом серве в этой же папке /usr/local/apache/htdocs (!)

Я все поставил из портов и, соответственно сайт пихаю в /usr/local/www/site/

В старом апаче:

Код: Выделить всё

DocumentRoot=/usr/local/apache/htdocs
в новом, моем:

Код: Выделить всё

DocumentRoot=/usr/local/www/site/
вот и думай тут =(
Только FreeBSD, только хардкор

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: После переноса сайт не стартует

Непрочитанное сообщение manefesto » 2010-11-29 15:10:21

виртуалхосты тебе знакомы ?
я такой яростный шо аж пиздеЦ
Изображение

Аватара пользователя
mr. brightside
сержант
Сообщения: 260
Зарегистрирован: 2010-04-17 17:32:39
Откуда: Saint-Petersburg

Re: После переноса сайт не стартует

Непрочитанное сообщение mr. brightside » 2010-11-29 18:44:35

виртуалхосты тебе знакомы ?
знакомы :crazy:

Но они мне не помогли =(
Только FreeBSD, только хардкор

boriskaaaa
рядовой
Сообщения: 17
Зарегистрирован: 2010-11-26 11:11:46

Re: После переноса сайт не стартует

Непрочитанное сообщение boriskaaaa » 2010-11-30 11:53:05

Так, а если сделать всё так же, как и было?

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: После переноса сайт не стартует

Непрочитанное сообщение manefesto » 2010-11-30 12:18:31

читай логи, кури маны
я такой яростный шо аж пиздеЦ
Изображение

Аватара пользователя
mr. brightside
сержант
Сообщения: 260
Зарегистрирован: 2010-04-17 17:32:39
Откуда: Saint-Petersburg

Re: После переноса сайт не стартует

Непрочитанное сообщение mr. brightside » 2010-11-30 21:26:01

читай логи, кури маны
даа, а что еще остается? :smile:
Так, а если сделать всё так же, как и было?
Сделал на новом сервер такие же пути, как и на старом - не пашет. Только иконку цепляет при старте и все... :unknown:

А идейки то кончаются...
Только FreeBSD, только хардкор

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: После переноса сайт не стартует

Непрочитанное сообщение manefesto » 2010-12-01 9:44:41

замани кого нибудь конфеткой, тебе помогут.
а то ни конфигов, ни логов
я такой яростный шо аж пиздеЦ
Изображение

boriskaaaa
рядовой
Сообщения: 17
Зарегистрирован: 2010-11-26 11:11:46

Re: После переноса сайт не стартует

Непрочитанное сообщение boriskaaaa » 2010-12-01 10:18:10

...если допустим сделать установку заново (через install), потом базу залить..ну и дизайн уже сделать, какой был...

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: После переноса сайт не стартует

Непрочитанное сообщение manefesto » 2010-12-01 10:27:09

дерзай
я такой яростный шо аж пиздеЦ
Изображение

Аватара пользователя
damir_madaga
старшина
Сообщения: 447
Зарегистрирован: 2007-10-01 8:13:38
Откуда: Красноярск
Контактная информация:

Re: После переноса сайт не стартует

Непрочитанное сообщение damir_madaga » 2010-12-01 17:55:13

В битриксе есть стандартный и весьма правильный скрипт переноса, я его юзал и все срабатывало!
Женщины и софт - должны быть бесплатными!

Аватара пользователя
mr. brightside
сержант
Сообщения: 260
Зарегистрирован: 2010-04-17 17:32:39
Откуда: Saint-Petersburg

Re: После переноса сайт не стартует

Непрочитанное сообщение mr. brightside » 2010-12-01 19:20:37

В битриксе есть стандартный и весьма правильный скрипт переноса, я его юзал и все срабатывало!
Тебя то я и ждал)

Что это за скрипт?! По всему получается, что именно битрикс не работает - первыми строками в index-файле, который цепляется в первую очередь апачем, идут коннекты к битриксу, а тот, в свою очередь коннектится к БД.

Вот я и думаю, что раз сам я к базе подрубаюсь, пма тоже базу видит, апач настроен (другие приложения работают - например, roundcube) - значит дело в битриксе...

Так что же это за скрипт переноса? Подскажи, пожалуйста...
Только FreeBSD, только хардкор

Аватара пользователя
damir_madaga
старшина
Сообщения: 447
Зарегистрирован: 2007-10-01 8:13:38
Откуда: Красноярск
Контактная информация:

Re: После переноса сайт не стартует

Непрочитанное сообщение damir_madaga » 2010-12-01 19:51:35

В самой админке есть пункт что то типа переноса на другой сервер или как то так, на этой же страничке есть ссылка для скачки скрипта типа restore.php качаешь его и создаешь архив инструментом с этой странице. Дальше файлик restore.php кладешь на новый сервер и запускаешь в браузере дальше все по инструкции! Точно работает сам так переносил с тестового сервака на хостинг! На следующей недели вернусь с командировки смогу более подробно написать!
Женщины и софт - должны быть бесплатными!

Аватара пользователя
mr. brightside
сержант
Сообщения: 260
Зарегистрирован: 2010-04-17 17:32:39
Откуда: Saint-Petersburg

Re: После переноса сайт не стартует

Непрочитанное сообщение mr. brightside » 2010-12-01 21:04:43

На следующей недели вернусь с командировки смогу более подробно написать!
Слушай, это было бы очень круто! Спасибо большое!

я пока покурю документацию и инфу по битриксу, может у самого что-нибудь выйдет!
Только FreeBSD, только хардкор

Аватара пользователя
damir_madaga
старшина
Сообщения: 447
Зарегистрирован: 2007-10-01 8:13:38
Откуда: Красноярск
Контактная информация:

Re: После переноса сайт не стартует

Непрочитанное сообщение damir_madaga » 2010-12-02 11:27:04

У тебя есть какая нибудь демка или тестовый сайт, дай доступ к адмике я найду от сюда удаленно!
Женщины и софт - должны быть бесплатными!

Аватара пользователя
mr. brightside
сержант
Сообщения: 260
Зарегистрирован: 2010-04-17 17:32:39
Откуда: Saint-Petersburg

Re: После переноса сайт не стартует

Непрочитанное сообщение mr. brightside » 2010-12-03 19:10:37

У тебя есть какая нибудь демка или тестовый сайт, дай доступ к адмике я найду от сюда удаленно!
Да в принципе я нашел этот restore.php, но только он пустой. На сайте 1С-Битрикс сказано, что для данной версии битрикса restore.php должен лежать в /bitrix/modules/main/admin/, - только там его у меня нет=)

Можно скачать его, но тогда, как я понял, надо обновлять битрикс, чего, конечно, мне сделать не дадут.

Так же на сайте битрикса есть инфа по тому, как осуществляется рещервное копирование сайта и сказано, что он сжимается gzip'ом. Я же паковал таром и сжимал bzip'ом. Сейчас перепаковываю и еще раз перекину. Если после этого не поможет, то дам доступ на чтение к каталогу битрикса.

Хотя, не знаю, поможет ли доступ, ведь restore.php все равно пустой. Команде find я верю, да и руками пошарился в каталоге - других restore.php не нашел :crazy:
Только FreeBSD, только хардкор

Аватара пользователя
mr. brightside
сержант
Сообщения: 260
Зарегистрирован: 2010-04-17 17:32:39
Откуда: Saint-Petersburg

Re: После переноса сайт не стартует

Непрочитанное сообщение mr. brightside » 2010-12-03 19:25:33

Соврал =)

Спутал с файлом redumption.php - он пустой, а restore.php нету вообще...
Только FreeBSD, только хардкор

Аватара пользователя
damir_madaga
старшина
Сообщения: 447
Зарегистрирован: 2007-10-01 8:13:38
Откуда: Красноярск
Контактная информация:

Re: После переноса сайт не стартует

Непрочитанное сообщение damir_madaga » 2010-12-04 19:12:43

Млин! Я то сейчас как раз в питере! А ты в роде от туда! Так что если что могем в какой нибудь кафешке пересечься с инетом я тебе подсоблю! Если что звони 89818471878 номер питерский!
Женщины и софт - должны быть бесплатными!