ospf + gif

Настройка сетевых служб, маршрутизации, фаерволлов. Проблемы с сетевым оборудованием.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Aidaho
рядовой
Сообщения: 47
Зарегистрирован: 2008-11-19 13:13:29
Контактная информация:

ospf + gif

Непрочитанное сообщение Aidaho » 2010-08-17 8:53:21

Доброе время суток :)
Ни как не получается настроить связку quagga и gif.
Есть 2 маршрутизатора на FreeBSD 6.3 и 2 канала. Поверх этих двух каналов лежит IPSec работающий через гиф интерфейсы.
Вот настройки:
Первый сервер zebra:

Код: Выделить всё

hostname gw1
password zebra
enable password zebra
!
! Interface's description.
!
interface lo
description loop
interface gif0
description ISP1
interface gif1
description ISP2
!
log file /var/log/quagga/zebra.log
ospf:

Код: Выделить всё

!
hostname cos
password zebra
enable password superzebra
log file /var/log/quagga/ospfd.log
!
!
!
!
interface lo
!
interface gif0
ip ospf network point-to-point
ip ospf cost 10
ip ospf mtu-ignore
!
interface gif1
ip ospf network point-to-point
ip ospf cost 20
ip ospf mtu-ignore
!
router ospf
ospf router-id 192.168.100.1
redistribute connected
redistribute static
network 192.168.100.0/24 area 0
network 192.168.73.0/24 area 0
network 192.168.101.0/24 area 0
и собственно сами интерфейсы:

Код: Выделить всё

gif0: flags=8050<POINTOPOINT,RUNNING,MULTICAST> mtu 1376
        tunnel inet 10.10.10.4 --> 10.10.10.15
        inet 192.168.73.2 --> 192.168.73.1 netmask 0xffffff00 
gif1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1376
        tunnel inet 192.168.100.10 --> ччч.ччч.ччч.ччч
        inet 192.168.101.2 --> 192.168.101.1 netmask 0xffffff00
теперь второй сервак:
zebra

Код: Выделить всё

hostname gw2
password zebra
enable password zebra
!
! Interface's description.
!
interface lo
description loop
interface gif0
description ISP1
interface gif1
description ISP2
!
log file /var/log/quagga/zebra.log
ospf

Код: Выделить всё

!
hostname brands
password zebra
enable password superzebra
log file /var/log/quagga/ospfd.log
!
!
!
!
interface lo
!
interface gif0
ip ospf network point-to-point
ip ospf cost 10
ip ospf mtu-ignore
!
interface gif1
ip ospf network point-to-point
ip ospf cost 20
ip ospf mtu-ignore
!
router ospf
ospf router-id 192.168.72.1
redistribute connected
redistribute static
network 192.168.72.0/24 area 0
network 192.168.73.0/24 area 0
network 192.168.101.0/24 area 0
и интерфейсы:

Код: Выделить всё

gif0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1376
        tunnel inet 10.10.10.15 --> 10.10.10.4
        inet 192.168.73.1 --> 192.168.73.2 netmask 0xffffff00 
gif1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1376
        tunnel inet ччч.ччч.ччч.ччч --> ххх.ххх.ххх.ххх
        inet 192.168.101.1 --> 192.168.101.2 netmask 0xffffff00 
Теперь что собсвенно не работает. Если оба гиф интерфейса подняты, то все вроде ок, но дальше 192.168.100.10 (Первый сервер) не вижу. Так же есть только один сосед который висит на gif0. Если тушу гиф0, то проскакивает второй сосед, но дохнет по таймауту, через некоторое время, опять появляется и снова дохнет. При пинги такая вот интересная картина:

Код: Выделить всё

# ping 192.168.72.1
PING 192.168.72.1 (192.168.72.1): 56 data bytes
ping: sendto: Input/output error
ping: sendto: Network is unreachable
ping: sendto: Input/output error
... пропущенно....
ping: sendto: Input/output error
ping: sendto: Input/output error
64 bytes from 192.168.72.1: icmp_seq=65 ttl=64 time=1.958 ms
ping: sendto: Input/output error
ping: sendto: Network is unreachable
ping: sendto: Input/output error
... пропущенно....
ping: sendto: Input/output error
ping: sendto: Input/output error
64 bytes from 192.168.72.1: icmp_seq=65 ttl=64 time=1.958 ms
в логах оспф творится следующее:

Код: Выделить всё

2010/08/17 17:54:51 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 64, interface gif1, mtu 1376: Input/output error
2010/08/17 17:55:01 OSPF: Packet[DD]: Neighbor 192.168.72.1: Initial DBD from Slave, ignoring.
2010/08/17 17:55:01 OSPF: Packet[DD]: Neighbor 192.168.72.1 Negotiation done (Master).
2010/08/17 17:55:01 OSPF: nsm_change_state(192.168.72.1, Loading -> Full): scheduling new router-LSA origination
2010/08/17 17:55:21 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 68, interface gif1, mtu 1376: Network is unreachable
2010/08/17 17:55:31 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 68, interface gif1, mtu 1376: Input/output error
2010/08/17 17:55:41 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 68, interface gif1, mtu 1376: Network is unreachable
2010/08/17 17:55:51 OSPF: nsm_change_state(192.168.72.1, Full -> Deleted): scheduling new router-LSA origination
2010/08/17 17:55:51 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 68, interface gif1, mtu 1376: Input/output error
2010/08/17 17:56:01 OSPF: Packet[DD]: Neighbor 192.168.72.1: Initial DBD from Slave, ignoring.
2010/08/17 17:56:01 OSPF: Packet[DD]: Neighbor 192.168.72.1 Negotiation done (Master).
2010/08/17 17:56:01 OSPF: nsm_change_state(192.168.72.1, Loading -> Full): scheduling new router-LSA origination
2010/08/17 17:56:21 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 68, interface gif1, mtu 1376: Network is unreachable
2010/08/17 17:56:31 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 68, interface gif1, mtu 1376: Input/output error
2010/08/17 17:56:41 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 68, interface gif1, mtu 1376: Network is unreachable
2010/08/17 17:56:51 OSPF: nsm_change_state(192.168.72.1, Full -> Deleted): scheduling new router-LSA origination
2010/08/17 17:56:51 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 64, interface gif1, mtu 1376: Input/output error
2010/08/17 17:57:01 OSPF: Packet[DD]: Neighbor 192.168.72.1: Initial DBD from Slave, ignoring.
2010/08/17 17:57:01 OSPF: Packet[DD]: Neighbor 192.168.72.1 Negotiation done (Master).
2010/08/17 17:57:01 OSPF: nsm_change_state(192.168.72.1, Loading -> Full): scheduling new router-LSA origination
парюсь уже вторую неделю, мозг себе уже сломал....
Кстати и без разницы, влючен ли IPSec или нет.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Aidaho
рядовой
Сообщения: 47
Зарегистрирован: 2008-11-19 13:13:29
Контактная информация:

Re: ospf + gif

Непрочитанное сообщение Aidaho » 2010-08-18 9:16:51

не уже ли ни кто не сталкивался с подобной проблемой? :(

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: ospf + gif

Непрочитанное сообщение hizel » 2010-08-18 9:38:40

интересно откуда мультикаст в point-to-point соединениях
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

Aidaho
рядовой
Сообщения: 47
Зарегистрирован: 2008-11-19 13:13:29
Контактная информация:

Re: ospf + gif

Непрочитанное сообщение Aidaho » 2010-08-18 9:41:07

Вы про gif туннели?
если да, то не знаю откуда... сама система так подняла, каких то специфических настроек я не делал...

Aidaho
рядовой
Сообщения: 47
Зарегистрирован: 2008-11-19 13:13:29
Контактная информация:

Re: ospf + gif

Непрочитанное сообщение Aidaho » 2010-08-24 11:30:35

все, разобрался. Дело оказалось в 1 не правильном маршруте.
Кстати, а кто нибудь настраивал по верх всего этого дело IPSec? )

ArcticFox
проходил мимо

Re: ospf + gif

Непрочитанное сообщение ArcticFox » 2012-07-23 9:56:18

какие характеристики были у битого маршрута? как его найти?

Aidaho
рядовой
Сообщения: 47
Зарегистрирован: 2008-11-19 13:13:29
Контактная информация:

Re: ospf + gif

Непрочитанное сообщение Aidaho » 2012-07-23 9:59:20

ArcticFox писал(а):какие характеристики были у битого маршрута? как его найти?
Это был директ маршрут по дефолту.

Гость
проходил мимо

Re: ospf + gif

Непрочитанное сообщение Гость » 2012-07-23 10:03:52

ArcticFox писал(а):какие характеристики были у битого маршрута? как его найти?
Как показало вскрытие, файрвол блокировал 89 порт и начинались танцы с буном, перезагрузка фильтров исправила ситуацию.