OSPF между Quagga FreeBSD vs Catalyst 3550

Настройка сетевых служб, маршрутизации, фаерволлов. Проблемы с сетевым оборудованием.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
savio
лейтенант
Сообщения: 813
Зарегистрирован: 2007-11-08 15:46:43
Откуда: UA
Контактная информация:

OSPF между Quagga FreeBSD vs Catalyst 3550

Непрочитанное сообщение savio » 2013-10-17 12:00:54

Есть с десяток серверов на FreeBSD, которые обмениваются маршрутами между собой используя OSPF-протокл в режиме brodcast.
Все отлично работает
ospfd.conf

Код: Выделить всё

router ospf
 ospf router-id XXX.XXX.38.3
 redistribute connected route-map TO-OSPF
 network XXX.XXX.38.0/28 area 0
!
ip prefix-list ospf-new seq 10 deny 192.168.0.0/16 le 32
ip prefix-list ospf-new seq 20 deny 172.16.0.0/16 le 32
ip prefix-list ospf-new seq 30 deny 10.0.0.0/8 le 32
ip prefix-list ospf-new seq 40 permit any
!
route-map TO-OSPF permit 10
 match ip address prefix-list ospf-new
!
line vty
!
Появилась старая CISCO Catalyst 3550, которую нужно аналогично включить в дружную компанию по OSPF

Код: Выделить всё

...
ip subnet-zero
ip routing
...
!
interface Vlan934
 ip address XXX.XXX.38.14 255.255.255.240
 ip ospf network broadcast
 ip ospf mtu-ignore
!
router ospf 100
 router-id XXX.XXX.38.14
 log-adjacency-changes
 redistribute connected subnets
 passive-interface default
 network XXX.XXX.38.14 0.0.0.0 area 0
 default-information originate
!
...
ip classless

с3550 не видит соседей, и соседи не видят ее
Включил всевозможные логи, но ничего не могу понять, что не так

Код: Выделить всё

catalyst#clear ip ospf process
Reset ALL OSPF processes? [no]: y
catalyst#
17:50:28: OSPF: Flushing External Links
17:50:28: OSPF: Flushing Opaque AS Links
17:50:28: OSPF: Flushing Link states in area 0
17:50:28: OSPF: Interface Vlan934 going Down
17:50:28: OSPF: XXX.XXX.38.14 address XXX.XXX.38.14 on Vlan934 is dead, state DOWN
17:50:28: OSPF: Neighbor change Event on interface Vlan934
17:50:28: OSPF: DR/BDR election on Vlan934
17:50:28: OSPF: Elect BDR 0.0.0.0
17:50:28: OSPF: Elect DR 0.0.0.0
17:50:28: OSPF: Elect BDR 0.0.0.0
17:50:28: OSPF: Elect DR 0.0.0.0
17:50:28:        DR: none    BDR: none
17:50:28: OSPF: Flush network LSA immediately
17:50:28: OSPF: scheduling NET lsa on Vlan934
17:50:28: OSPF: Remember old DR XXX.XXX.38.14 (id)
17:50:28: OSPF: scheduling rtr lsa for area 0 process 100
17:50:28: OSPF: scheduling rtr lsa for area 0 process 100
17:50:28: Stop timer for XXX.XXX.38.0 XXX.XXX.38.14 5 3
17:50:28: Stop timer for XXX.XXX.38.14 XXX.XXX.38.14 1 3
17:50:28: OSPF: destroyed TE Tunnel Table
17:50:28: OSPF: Interface Vlan934 going Up
17:50:28: OSPF: scheduling rtr lsa for area 0 process 100
17:50:28: OSPF: scheduling rtr lsa for area 0 process 100
17:50:28: OSPF: We are not DR to build Net Lsa for interface Vlan934
17:50:28: OSPF: For next LSA generation - wait : 0ms next: 5000ms
17:50:28: Add XXX.XXX.38.14 XXX.XXX.38.14 1 to min 63
17:50:28: Delay 600000/614586/778772/779520 translated to 63/57 for 52/0 748 (3)
17:50:28: OSPF: Build router LSA for area 0, router ID XXX.XXX.38.14, seq 0x80000001, process 100
17:50:28: OSPF: Schedule SPF in area 0
      Change in LS ID XXX.XXX.38.14, LSA type R, , spf-type Full
17:50:28: OSPF: forcing SPF in area 0
17:50:29: OSPF: Start redist-scanning, ospf process 100
17:50:29: OSPF: Scan the RIB for both redistribution and translation
17:50:29: OSPF: End scanning, Elapsed time 0ms
17:50:29: OSPF: For next LSA generation - wait : 0ms next: 5000ms
17:50:29: OSPF: Generate external LSA XXX.XXX.38.0, mask 255.255.255.240, type 5, age 0, metric 20, tag 0, metric-type 2, seq 0x80000001
17:50:29: Add XXX.XXX.38.0 XXX.XXX.38.14 5 to min 63
17:50:29: Delay 600000/613881/778264/778496 translated to 63/57 for 52/1 232 (3)
17:50:33: OSPF: running SPF for area 0, SPF-type Full
17:50:33: OSPF: Initializing to run spf
17:50:33:  OSPF - spf_intra() - rebuilding the tree
17:50:33: OSPF: No new path to LSID XXX.XXX.38.14, Adv. Rtr XXX.XXX.38.14, dest XXX.XXX.38.14
17:50:33:  It is a router LSA XXX.XXX.38.14. Link Count 1
17:50:33:   Processing link 0, id XXX.XXX.38.0, link data 255.255.255.240, type 3
17:50:33:    Add better path to LSA ID XXX.XXX.38.15, gateway XXX.XXX.38.0, dist 1
17:50:33:    Add path: next-hop XXX.XXX.38.14, interface Vlan934
17:50:33: OSPF: Adding Stub nets
17:50:33: OSPF: insert route list LS ID XXX.XXX.38.15, type 0, adv rtr XXX.XXX.38.14
17:50:33: OSPF: Entered old delete routine area 0
17:50:33: OSPF: ospf_gen_asbr_sum_all_areas
17:50:33: OSPF: running spf for summaries area 0
17:50:33: OSPF: sum_delete_old_routes area 0
17:50:33: OSPF: Started Building Type 5 External Routes
17:50:33: OSPF: ex_delete_old_routes
17:50:33: OSPF: Started Building Type 7 External Routes
17:50:33: OSPF: ex_delete_old_routes


Подскажите пожалуйста куда копать? что тут не так?

Код: Выделить всё

catalyst#show version
Cisco IOS Software, C3550 Software (C3550-IPSERVICESK9-M), Version 12.2(44)SE6, RELEASE SOFTWARE (fc1)
Помни о смерти, все суета сует....

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

lap
лейтенант
Сообщения: 608
Зарегистрирован: 2010-08-13 23:39:29
Откуда: Moscow
Контактная информация:

Re: OSPF между Quagga FreeBSD vs Catalyst 3550

Непрочитанное сообщение lap » 2013-10-21 9:43:44

Код: Выделить всё

 passive-interface default
надо сказать в роутере оспф "no passive-interface vlanXXXX"
Не сломалось - не чини.

Аватара пользователя
savio
лейтенант
Сообщения: 813
Зарегистрирован: 2007-11-08 15:46:43
Откуда: UA
Контактная информация:

Re: OSPF между Quagga FreeBSD vs Catalyst 3550

Непрочитанное сообщение savio » 2013-10-21 9:51:46

спасибо! помогло!
Помни о смерти, все суета сует....