Помогите настроить QUAGGA

Настройка сетевых служб, маршрутизации, фаерволлов. Проблемы с сетевым оборудованием.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Lizunovoo
проходил мимо
Сообщения: 3
Зарегистрирован: 2009-11-23 14:32:47

Помогите настроить QUAGGA

Непрочитанное сообщение Lizunovoo » 2009-11-23 15:18:46

Есть 2 гейта на FreeBSD 7.2, хочу настроить OSPF.
QUAGGA чето мне очень тяжело дается, ПОДСКАЖИТЕ !!!!!
tun0.jpg
Карта сети
Вот настройки сервера (Разница между ними только IP)

bsd2# uname -a

Код: Выделить всё

FreeBSD bsd2.ua 7.2-RELEASE FreeBSD 7.2-RELEASE #0: Fri May  1 08:49:13 UTC 2009     root@walker.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  i386
cat /etc/rc.conf

Код: Выделить всё

ifconfig_em0="inet 172.200.10.5  netmask 255.255.255.0"
ifconfig_em1="inet 172.200.15.5  netmask 255.255.255.0"

ifconfig_em2="inet 192.168.80.1  netmask 255.255.255.0"
ifconfig_em2_alias0="inet 192.168.81.1  netmask 255.255.255.0"
ifconfig_em2_alias1="inet 192.168.82.1  netmask 255.255.255.0"
ifconfig_em2_alias2="inet 192.168.83.1  netmask 255.255.255.0"

#defaultrouter="172.200.10.1"

moused_enable="YES"
hostname="bsd2.ua"
sshd_enable="YES"
fusefs_enable="YES"
sendmail_enable="NONE"

gateway_enable="YES"

cloned_interfaces="gif0 gif1 gif2 gif3"

gifconfig_gif0="172.200.10.5 172.200.0.5"
ifconfig_gif0="192.168.80.1 192.168.90.1"

gifconfig_gif1="172.200.15.5 172.200.0.5"
ifconfig_gif1="192.168.81.1 192.168.91.1"

gifconfig_gif2="172.200.10.5 172.200.5.5"
ifconfig_gif2="192.168.82.1 192.168.92.1"

gifconfig_gif3="172.200.15.5 172.200.5.5"
ifconfig_gif3="192.168.83.1 192.168.93.1"

static_routes="01 51"
route_01="-net 172.200.10.0/24 -host 172.200.10.1"
route_05="-net 172.200.15.0/24 -host 172.200.15.1"

quagga_enable="YES"
quagga_demons="zebra ospfd bgpd"
quagga_flags="-d -A 127.0.0.1"
bsd2# cat /usr/local/etc/quagga/zebra.conf

Код: Выделить всё

!
! Zebra configuration saved from vty
!   2009/11/24 11:44:14
!
hostname Router
password zebra
log file /var/log/quagga/zebra.log
!
interface em0
 ipv6 nd suppress-ra
!
interface em1
 ipv6 nd suppress-ra
!
interface em2
 ipv6 nd suppress-ra
!
interface gif0
 ipv6 nd suppress-ra
!
interface gif1
 ipv6 nd suppress-ra
!
interface gif2
 ipv6 nd suppress-ra
!
interface gif3
 ipv6 nd suppress-ra
!
interface lo0
!
interface plip0
 ipv6 nd suppress-ra
!
ip forwarding
!
!
line vty
!
bsd2# cat /usr/local/etc/quagga/ospfd.conf

Код: Выделить всё

!
! Zebra configuration saved from vty
!   2009/11/24 12:47:11
!
hostname ospfd
password zebra
log file /var/log/quagga/ospfd.log
log stdout
!
!
!
interface em0
!
interface em1
!
interface em2
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 Qq1Ee
 ip ospf cost 5
!
interface gif0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 Qq1Ee
 ip ospf cost 10
!
interface gif1
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 Qq1Ee
 ip ospf cost 20
!
interface gif2
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 Qq1Ee
 ip ospf cost 30
!
interface gif3
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 Qq1Ee
 ip ospf cost 40
!
interface lo0
!
interface plip0
!
router ospf
 ospf router-id 192.168.80.1
 redistribute connected route-map Local_Net
 network 192.168.80.0/24 area 0.0.0.0
 network 192.168.81.0/24 area 0.0.0.0
 network 192.168.82.0/24 area 0.0.0.0
 network 192.168.83.0/24 area 0.0.0.0
 area 0.0.0.0 authentication message-digest
!
ip prefix-list Local_Net seq 10 permit 192.168.80.0/24
ip prefix-list Local_Net seq 100 deny any
!
route-map Local_Net permit 10
 match ip address prefix-list Local_Net
!
line vty
!

bsd2# cat /var/log/quagga/zebra.log

Код: Выделить всё

2009/11/24 10:09:47 ZEBRA: Zebra 0.99.15 starting: vty@2601
2009/11/24 11:56:03 ZEBRA: Terminating on signal

[b]bsd2# cat /var/log/quagga/ospfd.log[/b]
2009/11/24 12:51:10 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 80, interface em2, mtu 1500: Network is down
2009/11/24 12:51:10 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 80, interface em2, mtu 1500: Network is down
2009/11/24 12:51:10 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 80, interface em2, mtu 1500: Network is down
........
2009/11/24 12:51:20 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 80, interface em2, mtu 1500: Network is down
2009/11/24 12:51:20 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 80, interface em2, mtu 1500: Network is down
2009/11/24 12:51:30 OSPF: DR-Election[1st]: Backup 192.168.80.1
2009/11/24 12:51:30 OSPF: DR-Election[1st]: DR     192.168.80.1
2009/11/24 12:51:30 OSPF: DR-Election[2nd]: Backup 0.0.0.0
2009/11/24 12:51:30 OSPF: DR-Election[2nd]: DR     192.168.80.1
2009/11/24 12:51:30 OSPF: interface 192.168.80.1 [3] join AllDRouters Multicast group.
2009/11/24 12:51:30 OSPF: DR-Election[1st]: Backup 192.168.81.1
2009/11/24 12:51:30 OSPF: DR-Election[1st]: DR     192.168.81.1
2009/11/24 12:51:30 OSPF: DR-Election[2nd]: Backup 0.0.0.0
2009/11/24 12:51:30 OSPF: DR-Election[2nd]: DR     192.168.81.1
2009/11/24 12:51:30 OSPF: interface 192.168.81.1 [3] join AllDRouters Multicast group.
2009/11/24 12:51:30 OSPF: DR-Election[1st]: Backup 192.168.82.1
2009/11/24 12:51:30 OSPF: DR-Election[1st]: DR     192.168.82.1
2009/11/24 12:51:30 OSPF: DR-Election[2nd]: Backup 0.0.0.0
2009/11/24 12:51:30 OSPF: DR-Election[2nd]: DR     192.168.82.1
2009/11/24 12:51:30 OSPF: interface 192.168.82.1 [3] join AllDRouters Multicast group.
2009/11/24 12:51:30 OSPF: DR-Election[1st]: Backup 192.168.83.1
2009/11/24 12:51:30 OSPF: DR-Election[1st]: DR     192.168.83.1
2009/11/24 12:51:30 OSPF: DR-Election[2nd]: Backup 0.0.0.0
2009/11/24 12:51:30 OSPF: DR-Election[2nd]: DR     192.168.83.1
2009/11/24 12:51:30 OSPF: interface 192.168.83.1 [3] join AllDRouters Multicast group.
2009/11/24 12:51:30 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 80, interface em2, mtu 1500: Network is down
.....
2009/11/24 12:51:40 OSPF: *** sendmsg in ospf_write failed to 224.0.0.5, id 0, off 0, len 80, interface em2, mtu 1500: Network is down
Хотя
ospfd# show ip ospf interface

Код: Выделить всё

em0 is up
  ifindex 1, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST>
  OSPF not enabled on this interface
em1 is up
  ifindex 2, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST>
  OSPF not enabled on this interface
[b]em2 is up[/b]
  ifindex 3, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST>
  Internet Address 192.168.80.1/24, Broadcast 192.168.80.255, Area 0.0.0.0
  MTU mismatch detection:enabled
  Router ID 192.168.80.1, Network Type BROADCAST, Cost: 5
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 192.168.80.1, Interface Address 192.168.80.1
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters OSPFDesignatedRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 3.168s
.........
Последний раз редактировалось Lizunovoo 2009-11-24 15:11:56, всего редактировалось 5 раз.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: Помогите настроить QUAGGA

Непрочитанное сообщение hizel » 2009-11-23 15:57:06

пахнет сессией парни :]

хм, какой протокол динамической маршрутизации то нужен?
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.