Встроенная сетевая карта Realtek на FreeBSD

Настройка сетевых служб, маршрутизации, фаерволлов. Проблемы с сетевым оборудованием.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
kuhar2007
сержант
Сообщения: 243
Зарегистрирован: 2008-12-22 14:40:35

Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение kuhar2007 » 2009-09-24 9:41:13

Всем привет, столкнулся я с такой проблемой. У меня сламалась внешняя сетевая карта Realtek под которой я работал во фре, хочу витую пару подключит к встроенной, при написании команды ifconfig пишет что видно две сетевухи re0 и rl0 и обе они в состоянии no carrier. Rl0- это внешняя не рабочая сетевуха через, которую я раньше работал. Re0- встроення, на сколько я понял, но почему то она no carrier, хотя кабель воткнут и она на винде работает. Когда пытаюсь я подрубиться к pppoe, где в конфиге указана именно re0 сетевуха, она сразу переходит из статуса no carrier в active, но при этом инета нет. Помогите плиззз, в чем это бок может быть, слышал что фря конфликтует со встроенными сетевухами.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение paradox » 2009-09-24 9:50:41

переткни кабель
но карриер = кабель не подключен

uname -a
возможно прийдеться обновиться

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение zingel » 2009-09-24 10:08:05

переткни кабель
но карриер = кабель не подключен
по возможности отключите её и купите нормальную сетевуху.
Z301171463546 - можно пожертвовать мне денег

kuhar2007
сержант
Сообщения: 243
Зарегистрирован: 2008-12-22 14:40:35

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение kuhar2007 » 2009-09-24 12:54:16

Кабель реально подключен, под виндой пашет. Я просто хочу в этом разобраться так как у меня на ноуте со встроенной тоже самое было. А на ПК я в любом случае буду покупать новую сетевуху. Просто на будущее, чтобы на ноуте не возникало такого же, хочу понять. У меня стоит FreeBSD Release 7.2 Помогите плиззз.

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение paradox » 2009-09-24 13:54:32

Код: Выделить всё

pciconf -lvcb
и что там dmesg пишет во время загрузки
и во время перевтыкания кабеля в ту сетевку

kuhar2007
сержант
Сообщения: 243
Зарегистрирован: 2008-12-22 14:40:35

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение kuhar2007 » 2009-10-02 12:22:37

Всем привет, ссори что так долго не писал инета дома небыло.
при команде

Код: Выделить всё

pciconf -lvbc

Код: Выделить всё

re0@pci0:4:0:0:	class=0x020000 card=0xe0001458 chip=0x816810ec rev=0x01 hdr=0x00
    vendor     = 'Realtek Semiconductor'
    device     = 'RTL8168/8111 PCI-E Gigabit Ethernet NIC'
    class      = network
    subclass   = ethernet
    bar   [10] = type I/O Port, range 32, base 0xc000, size 256, enabled
    bar   [18] = type Memory, range 64, base 0xf5000000, size 4096, enabled
    cap 01[40] = powerspec 2  supports D0 D1 D2 D3  current D0
    cap 03[48] = VPD
    cap 05[50] = MSI supports 2 messages, 64 bit enabled with 1 message
    cap 10[60] = PCI-Express 1 endpoint
    cap 09[84] = vendor (length 76)
В

Код: Выделить всё

re0: <RealTek 8168/8168B/8168C/8168CP/8168D/8111B/8111C/8111CP PCIe Gigabit Ethernet> port 0xc000-0xc0ff mem 0xf5000000-0xf5000fff irq 17 at device 0.0 on pci4
re0: Using 1 MSI messages
re0: Chip rev. 0x38000000
re0: MAC rev. 0x00000000
miibus0: <MII bus> on re0
rgephy0: <RTL8169S/8110S/8211B media interface> PHY 1 on miibus0
rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
re0: Ethernet address: 00:1a:4d:55:e9:5f
re0: [FILTER]
После перевтыкания кабеля ничего не миняется. Может она как-то выключена во фре?

paradox
проходил мимо
Сообщения: 11620
Зарегистрирован: 2008-02-21 18:15:41

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение paradox » 2009-10-02 15:06:16

ну и какая это сетевка? встроеная или ту что вставили?
весь вывод давайте


kuhar2007
сержант
Сообщения: 243
Зарегистрирован: 2008-12-22 14:40:35

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение kuhar2007 » 2009-10-06 9:18:31

А во фре есть возможность включать сетевухи и выключать?

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение zingel » 2009-10-06 10:09:52

Код: Выделить всё

ifconfig <interface> down
Z301171463546 - можно пожертвовать мне денег

Аватара пользователя
manefesto
Группенфюррер
Сообщения: 6934
Зарегистрирован: 2007-07-20 8:27:30
Откуда: Пермь
Контактная информация:

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение manefesto » 2009-10-07 15:32:06

точно не помню...но разве сетевуху не надо для начала настроить ?
я такой яростный шо аж пиздеЦ
Изображение

kuhar2007
сержант
Сообщения: 243
Зарегистрирован: 2008-12-22 14:40:35

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение kuhar2007 » 2009-10-07 22:11:30

manefesto писал(а):точно не помню...но разве сетевуху не надо для начала настроить ?
Ну я внешнии не настраивал, они сразу видели что кабель подключен.

kuhar2007
сержант
Сообщения: 243
Зарегистрирован: 2008-12-22 14:40:35

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение kuhar2007 » 2009-10-07 22:13:51

zingel писал(а):

Код: Выделить всё

ifconfig <interface> down
попробывал, ничего не дало

Код: Выделить всё

ifconfig re0 down
как было так и осталось no carrier. :(

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение Mobilesfinks » 2009-11-06 21:10:20

Столкнулся с тем же. Только у меня интегрированная пашет а PCI платы не хотят. И мне кажется случилось это после пересборки ядра. Сейчас попробую на Дженерик откатится

uname -a

Код: Выделить всё

uname -a
FreeBSD bicom.ru 7.2-RELEASE-p4 FreeBSD 7.2-RELEASE-p4 #2: Thu Nov  5 11:40:25 EET 2009     user@bicom.ru:/usr/obj/usr/src/sys/gatekeeper.oct2009  i386
ifconfig

Код: Выделить всё

ifconfig
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC>
        ether 00:19:db:ad:43:a3
        inet 83.234.5.34 netmask 0xffffff00 broadcast 83.234.5.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8<VLAN_MTU>
        ether 00:16:0a:07:fc:3b
        inet 192.168.254.1 netmask 0xffffff00 broadcast 192.168.254.255
        media: Ethernet autoselect (none)
        status: no carrier
rl1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8<VLAN_MTU>
        ether 00:16:0a:08:0c:2a
        inet 192.168.253.100 netmask 0xffffff00 broadcast 192.168.253.255
        media: Ethernet autoselect (none)
        status: no carrier
plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST,NEEDSGIANT> metric 0 mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        inet 127.0.0.1 netmask 0xff000000
Стопроцентно к одной из карт подключён кабель, проверено, что рабочий. Второй конец в циску воткнут. Там пишет что интерфейс Up а вот протокол Down. Короче какой то порожняк - не могу въехать.
Если кто в курсе поможите пожалуйста

Гость
проходил мимо

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение Гость » 2009-11-06 21:32:43

Стопроцентно к одной из карт подключён кабель, проверено, что рабочий
re0: status: active
подключена
работает
что вы еще хотите?

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение Mobilesfinks » 2009-11-06 21:41:39

Внимательно(!!!) читаем - я сказал что она работает - это интегрированная, а вот две одинаковые PCI не пашут!!!
и в одну из PCI плат воткнут кабель. Даже раньше наблюдал, что линию фря видела.

ЗЫ откат на Дженерик Ядро не помог - косяк какойто.

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение zingel » 2009-11-07 9:58:01

а к чему она подключена кабелем?
Z301171463546 - можно пожертвовать мне денег

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение Mobilesfinks » 2009-11-07 14:49:17

zingel писал(а):а к чему она подключена кабелем?
интегрированная подключена к коммутатору, всё работает.

PCI карта подключена к CISCO AS5300 FastEthernet 0 прямым кабелем обжатым по варианту B
На циске show int fa 0 выдаёт что линк Up а протокол Down.
ХЗ может конечно дело в циске - я с ними мало общался. Вот show run из неё

Код: Выделить всё

show run
Building configuration...

Current configuration : 1099 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
!
!
resource-pool disable
!
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
controller E1 0
 clock source line primary
!
controller E1 1
 clock source line secondary 1
!
controller E1 2
 clock source line secondary 2
!
 --More--         controller E1 3
 clock source line secondary 3
!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 shutdown
 clock rate 2015232
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
 clock rate 2015232
 no fair-queue
!
interface Serial2
 no ip address
 --More--          shutdown
 clock rate 2015232
 no fair-queue
!
interface Serial3
 no ip address
 shutdown
 clock rate 2015232
 no fair-queue
!
interface FastEthernet0
 ip address 192.168.254.2 255.255.255.0
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
тут вроде всё как положено, конфиг снёс заново сделал. Так что думаю не в Циске дело.

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение zingel » 2009-11-07 15:30:25

выставляйте на кошке

Код: Выделить всё

duplex full speed 100

и дайте оттуда мне вывод команд

Код: Выделить всё

sh int Fa0 statu
Z301171463546 - можно пожертвовать мне денег

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение Mobilesfinks » 2009-11-07 22:01:45

Cоединил комп с Циской кроссовером и всё заработало.

(ред. Mobilesfinks)
PS: Вопрос к знатокам. Почему маршрутизатор сам не "перевернул" подключение? В коммутаторах автоматом всё происходит.

hackmetwice
проходил мимо

Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение hackmetwice » 2015-08-05 9:30:34

Intel® Desktop Board D525MW, почти такая же проблема вставляю вторую сетевую карточку в разъем PCI. Встроенная карточка перестает работать. Через ifconfig определяются обе, но работает только, та что через PCI.

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35411
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Встроенная сетевая карта Realtek на FreeBSD

Непрочитанное сообщение Alex Keda » 2015-08-09 10:55:29

попробуйте ручками прерывания да даипазоны ввода-вывода разрулить
Убей их всех! Бог потом рассортирует...