Нужна помощь в тестировании программы Cinelerra.

FreeBSD и прочие в роли десктопа.
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
fidaj
мл. сержант
Сообщения: 136
Зарегистрирован: 2009-12-19 20:54:03

Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение fidaj » 2011-11-17 9:01:05

Требуется помощь в тестировании Cinelerra...
http://svn.bluelife.at/index.cgi/bluepo ... rra-devel/

Спасибо!

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35462
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение Alex Keda » 2011-11-17 20:48:45

люблю я такие весёлые сайтики...

всегда хотел спросить - а какого хрена нет возможности скачать архив порта одним файлом?! =)

тема интересная, но выковыривать два десятка файлов по одному - тупо лень.
за это время оно поди собралось бы и уже тестить бы начал
Убей их всех! Бог потом рассортирует...

fidaj
мл. сержант
Сообщения: 136
Зарегистрирован: 2009-12-19 20:54:03

Re: Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение fidaj » 2011-11-17 21:05:21

Alex Keda писал(а):люблю я такие весёлые сайтики...

всегда хотел спросить - а какого хрена нет возможности скачать архив порта одним файлом?! =)

тема интересная, но выковыривать два десятка файлов по одному - тупо лень.
за это время оно поди собралось бы и уже тестить бы начал
ну что вы - увольте :)

Код: Выделить всё

svn co http://svn.bluelife.at/projects/blueports/multimedia/cinelerra-devel
зачем же выковыривать?
но кажись там проблемы с svn...
куда мне архив порта перебросить на шару? у меня крайне плохой инет (GSM-modem) наближайшее время :( для "комфортных телодвижений"...
Последний раз редактировалось fidaj 2011-11-17 21:07:15, всего редактировалось 1 раз.

Аватара пользователя
f_andrey
майор
Сообщения: 2651
Зарегистрирован: 2007-12-26 1:22:58
Откуда: СПб
Контактная информация:

Re: Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение f_andrey » 2011-11-17 21:06:56

Alex Keda писал(а):всегда хотел спросить - а какого хрена нет возможности скачать архив порта одним файлом?! =)
ну ета, не позорься, ну или открой для себя svn ;)

Хотя есть площадки понавороченнее и там можно скачать архивчик нужной ревизии, из веб морды.
Если ваша тема перенесена, то смотри http://forum.lissyara.su/viewtopic.php?f=1&t=32308

fidaj
мл. сержант
Сообщения: 136
Зарегистрирован: 2009-12-19 20:54:03

Re: Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение fidaj » 2011-11-17 22:03:08

Alex Keda писал(а):люблю я такие весёлые сайтики...

всегда хотел спросить - а какого хрена нет возможности скачать архив порта одним файлом?! =)

тема интересная, но выковыривать два десятка файлов по одному - тупо лень.
за это время оно поди собралось бы и уже тестить бы начал
Вот архив порта - той же ревизии (r1403) что и в svn на теперешний момент...

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35462
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение Alex Keda » 2011-11-18 18:06:20

Код: Выделить всё

===>  Installing for x264-0.116.2076
===>   Generating temporary packing list
===>  Checking if multimedia/x264 already installed
===>   x264-0.116.2076 is already installed
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of multimedia/x264
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/multimedia/x264.
*** Error code 1

Stop in /usr/ports/multimedia/x264.
*** Error code 1

Stop in /usr/ports/multimedia/cinelerra-devel.
dc7700p# pkg_delete x264-0.116.2076
pkg_delete: package 'x264-0.116.2076' is required by these other packages
and may not be deinstalled:
blinken-4.7.3
cantor-4.7.3
ffmpeg-0.7.7,1
filelight-4.7.3
gwenview-4.7.3
ja-kiten-4.7.3
jovie-4.7.3
kaffeine-1.2.2
kalgebra-4.7.3
kalzium-4.7.3
kamera-4.7.3
kanagram-4.7.3
kate-4.7.3
kbruch-4.7.3
kcolorchooser-4.7.3
kde-baseapps-4.7.3
kde-runtime-4.7.3
kde-wallpapers-4.7.3
kde-windeco-crystal-2.1.0
kde-workspace-4.7.3
kde4-4.7.2_1
kdeaccessibility-4.7.3
kdeadmin-4.7.3
kdeartwork-4.7.3
kdeedu-4.7.3
kdegames-4.7.2
kdegraphics-4.7.3
kdegraphics-mobipocket-4.7.3
kdegraphics-strigi-analyzer-4.7.3
kdegraphics-svgpart-4.7.3
kdegraphics-thumbnailers-4.7.3
kdelibs-4.7.3
kdemultimedia-4.7.3
kdenetwork-4.7.3
kdepim-4.4.11.1_1
kdepim-runtime-4.4.11.1
kdepimlibs-4.7.3
kdeplasma-addons-4.7.2
kdesdk-4.7.3
kdesvn-1.5.5
kdetoys-4.7.2
kdeutils-4.7.3
kdeutils-printer-applet-4.7.3
kdewebdev-4.7.3
kgamma-4.7.3
kgeography-4.7.3
khangman-4.7.3
kig-4.7.3
klettres-4.7.3
kmplot-4.7.3
knemo-0.7.2_1
kolourpaint-4.7.3
konsole-4.7.3
kruler-4.7.3
ksaneplugin-4.7.3
ksnapshot-4.7.3
kstars-4.7.3
ktouch-4.7.3
kturtle-4.7.3
kwordquiz-4.7.3
libkdcraw-4.7.3
libkdeedu-4.7.3
libkexiv2-4.7.3
libkipi-4.7.3
libksane-4.7.3
libktorrent-1.1.2_1
libxine-1.1.19_7
marble-4.7.3
okular-4.7.3
opera-11.52
parley-4.7.3
polkit-kde-0.99.0_1
py27-kdebindings-pykde4-4.7.3
py27-kdebindings-pykdeuic4-4.7.3
rocs-4.7.3
ru-kde-l10n-4.7.3
step-4.7.3
strigi-0.7.6
system-config-printer-kde-4.7.3
dc7700p# pkg_delete -f x264-0.116.2076
pkg_delete: package 'x264-0.116.2076' is required by these other packages
and may not be deinstalled (but I'll delete it anyway):
blinken-4.7.3
cantor-4.7.3
ffmpeg-0.7.7,1
filelight-4.7.3
gwenview-4.7.3
ja-kiten-4.7.3
jovie-4.7.3
kaffeine-1.2.2
kalgebra-4.7.3
kalzium-4.7.3
kamera-4.7.3
kanagram-4.7.3
kate-4.7.3
kbruch-4.7.3
kcolorchooser-4.7.3
kde-baseapps-4.7.3
kde-runtime-4.7.3
kde-wallpapers-4.7.3
kde-windeco-crystal-2.1.0
kde-workspace-4.7.3
kde4-4.7.2_1
kdeaccessibility-4.7.3
kdeadmin-4.7.3
kdeartwork-4.7.3
kdeedu-4.7.3
kdegames-4.7.2
kdegraphics-4.7.3
kdegraphics-mobipocket-4.7.3
kdegraphics-strigi-analyzer-4.7.3
kdegraphics-svgpart-4.7.3
kdegraphics-thumbnailers-4.7.3
kdelibs-4.7.3
kdemultimedia-4.7.3
kdenetwork-4.7.3
kdepim-4.4.11.1_1
kdepim-runtime-4.4.11.1
kdepimlibs-4.7.3
kdeplasma-addons-4.7.2
kdesdk-4.7.3
kdesvn-1.5.5
kdetoys-4.7.2
kdeutils-4.7.3
kdeutils-printer-applet-4.7.3
kdewebdev-4.7.3
kgamma-4.7.3
kgeography-4.7.3
khangman-4.7.3
kig-4.7.3
klettres-4.7.3
kmplot-4.7.3
knemo-0.7.2_1
kolourpaint-4.7.3
konsole-4.7.3
kruler-4.7.3
ksaneplugin-4.7.3
ksnapshot-4.7.3
kstars-4.7.3
ktouch-4.7.3
kturtle-4.7.3
kwordquiz-4.7.3
libkdcraw-4.7.3
libkdeedu-4.7.3
libkexiv2-4.7.3
libkipi-4.7.3
libksane-4.7.3
libktorrent-1.1.2_1
libxine-1.1.19_7
marble-4.7.3
okular-4.7.3
opera-11.52
parley-4.7.3
polkit-kde-0.99.0_1
py27-kdebindings-pykde4-4.7.3
py27-kdebindings-pykdeuic4-4.7.3
rocs-4.7.3
ru-kde-l10n-4.7.3
step-4.7.3
strigi-0.7.6
system-config-printer-kde-4.7.3
dc7700p# make
===>   cinelerra-devel-2.1 depends on file: /usr/local/include/linux/videodev.h - found
===>   cinelerra-devel-2.1 depends on executable: gmake - found
===>   cinelerra-devel-2.1 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   cinelerra-devel-2.1 depends on file: /usr/local/libdata/pkgconfig/xxf86vm.pc - found
===>   cinelerra-devel-2.1 depends on file: /usr/local/libdata/pkgconfig/xv.pc - found
===>   cinelerra-devel-2.1 depends on file: /usr/local/bin/automake-1.11 - found
===>   cinelerra-devel-2.1 depends on file: /usr/local/bin/autoconf-2.68 - found
===>   cinelerra-devel-2.1 depends on package: libtool>=2.4 - found
===>   cinelerra-devel-2.1 depends on shared library: tiff.4 - found
===>   cinelerra-devel-2.1 depends on shared library: faad.2 - found
===>   cinelerra-devel-2.1 depends on shared library: faac.0 - found
===>   cinelerra-devel-2.1 depends on shared library: fftw3 - found
===>   cinelerra-devel-2.1 depends on shared library: lavjpeg-2.0 - found
===>   cinelerra-devel-2.1 depends on shared library: jpeg - found
===>   cinelerra-devel-2.1 depends on shared library: a52.0 - found
===>   cinelerra-devel-2.1 depends on shared library: png.6 - found
===>   cinelerra-devel-2.1 depends on shared library: sndfile.1 - found
===>   cinelerra-devel-2.1 depends on shared library: mp3lame.0 - found
===>   cinelerra-devel-2.1 depends on shared library: x264.115 - not found
===>    Verifying install for x264.115 in /usr/ports/multimedia/x264
===>  Installing for x264-0.116.2076
===>   x264-0.116.2076 depends on shared library: gpac.1 - found
===>   Generating temporary packing list
===>  Checking if multimedia/x264 already installed
install -d /usr/local/bin
install x264 /usr/local/bin
install -d /usr/local/include
install -d /usr/local/lib
install -d /usr/local/libdata/pkgconfig
install -m 644 x264.h /usr/local/include
install -m 644 x264_config.h /usr/local/include
install -m 644 x264.pc /usr/local/libdata/pkgconfig
ln -f -s libx264.so.116 /usr/local/lib/libx264.so
install -m 755 libx264.so.116 /usr/local/lib
install -m 644 libx264.a /usr/local/lib
ranlib /usr/local/lib/libx264.a
===>   Running ldconfig
/sbin/ldconfig -m /usr/local/lib
===>   Registering installation for x264-0.116.2076
===>   Returning to build of cinelerra-devel-2.1
Error: shared library "x264.115" does not exist
*** Error code 1

Stop in /usr/ports/multimedia/cinelerra-devel.
dc7700p# 
но это, поди глюки моего каррента какие-то
Убей их всех! Бог потом рассортирует...

Аватара пользователя
f_andrey
майор
Сообщения: 2651
Зарегистрирован: 2007-12-26 1:22:58
Откуда: СПб
Контактная информация:

Re: Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение f_andrey » 2011-11-18 21:36:12

Что то у меня тоже не хочет собираться, хотя тоже CURRENT и порты примерно недельной давности, сейчас попытаюсь пообновлять, если не забью то отпишусь
Если ваша тема перенесена, то смотри http://forum.lissyara.su/viewtopic.php?f=1&t=32308

залетный
проходил мимо

Re: Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение залетный » 2011-11-19 0:13:12

но это, поди глюки моего каррента какие-то
Да нет, пишет-же
Returning to build of cinelerra-devel-2.1
Error: shared library "x264.115" does not exist
а стоит
Registering installation for x264-0.116.2076
У меня на 9.0-RC2 то-же самое.

Аватара пользователя
f_andrey
майор
Сообщения: 2651
Зарегистрирован: 2007-12-26 1:22:58
Откуда: СПб
Контактная информация:

Re: Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение f_andrey » 2011-11-19 9:38:21

Код: Выделить всё

# diff -up cinelerra-devel/Makefile cinelerra-devel/Makefile.1
--- cinelerra-devel/Makefile    2011-07-14 10:14:44.000000000 +0400
+++ cinelerra-devel/Makefile.1  2011-11-19 09:25:41.000000000 +0300
@@ -24,7 +24,7 @@ LIB_DEPENDS=  tiff.4:${PORTSDIR}/graphics
                png.6:${PORTSDIR}/graphics/png \
                sndfile.1:${PORTSDIR}/audio/libsndfile \
                mp3lame.0:${PORTSDIR}/audio/lame \
-               x264.116:${PORTSDIR}/multimedia/x264 \
+               x264.115:${PORTSDIR}/multimedia/x264 \
                theora.0:${PORTSDIR}/multimedia/libtheora \
                vorbis.4:${PORTSDIR}/audio/libvorbis \
                avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
после такого всё собралось и заинсталлилось без ошибок, при запуске даже открывается окошко, но нефига в нём нет, в консоль тоже ничего криминального вроде не ругается, при запуске.
Если ваша тема перенесена, то смотри http://forum.lissyara.su/viewtopic.php?f=1&t=32308

fidaj
мл. сержант
Сообщения: 136
Зарегистрирован: 2009-12-19 20:54:03

Re: Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение fidaj » 2011-11-20 8:12:29

Да - у меня порты старые еще (обновлюсь когда домой доберусь)... поэтому и
- x264.116:${PORTSDIR}/multimedia/x264 \
+ x264.115:${PORTSDIR}/multimedia/x264 \
но меня именно интересует именно возможность в нем что-либо осуществить (есть ли возможность сделать какую-то обработку видео...) - баги могут быть глубоко зарыты - например в специфические кодеки или аппаратнозависимые участки...

Я попросил-то не порт тестить а именно программу ;)


Аватара пользователя
f_andrey
майор
Сообщения: 2651
Зарегистрирован: 2007-12-26 1:22:58
Откуда: СПб
Контактная информация:

Re: Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение f_andrey » 2012-01-10 0:50:19

А как успехи то? движухи вроде особой не видно
Если ваша тема перенесена, то смотри http://forum.lissyara.su/viewtopic.php?f=1&t=32308

fidaj
мл. сержант
Сообщения: 136
Зарегистрирован: 2009-12-19 20:54:03

Re: Нужна помощь в тестировании программы Cinelerra.

Непрочитанное сообщение fidaj » 2012-01-10 0:59:20

f_andrey писал(а):А как успехи то? движухи вроде особой не видно
На текущем этапе - программа работает, но есть редкие сбои при определенных форматах файлов (все сам выловить не могу)...
Сейчас очень многое меняется в ядре и портах - есть много несовместимости по версиям, поэтому роюсь в аналогичной программе но комюнити версии - она поновее будет, а большая часть кода практически та же...

Текущюю можно просто обкатать, но в порты я не хочу что бы она попала - много багов в коде... - но это поможет мне при портировании новой версии cinelerra4.3...