Страница 1 из 1

postfix backup mx

Добавлено: 2010-03-03 12:45:22
LimpTeaM
Здравствуйте! подскажите пожалуйста по легкому вопросу. ну не понимаю я это))
Есть 2 сервера postfix каждый держит по одному домену на разных серверах.
1. limpteam.ru
2. microhost.su
второй решил сделать резервным для первого. прописал на нем

Код: Выделить всё

relay_domains = limpteam.ru 
записи в днс сделал.
потом выключил первый для проверки.
и на втором получил такое:

Код: Выделить всё

warning: host mx1.limpteam.ru[77.246.106.26]:25 replied to HELO/EHLO with my own hostname microhost.su
microhost postfix/smtp[60127]: warning: host mx1.limpteam.ru[77.246.106.26]:25 greeted me with my own hostname microhost.su
:(
Подскажите как побороть и правильно ли я вообще настроил backup mx?
некоторая информация:

ДНС:

Код: Выделить всё

0	mx.limpteam.ru 	77.246.107.77
5	mx1.limpteam.ru 77.246.106.26
main.cf на первом (limpteam.ru ) который должен бекапится

Код: Выделить всё

myhostname = mx.limpteam.ru
hostname сервера limpteam

второй сервер (microhost.su)

Код: Выделить всё

myhostname = microhost.su
relay_domains = limpteam.ru
hostname сервера microhost.su

Код: Выделить всё

mailq
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
C756F284F8    10543 Wed Mar  3 12:46:36  6007747u44a22856@bridgestone.co.jp
                                   (mail for limpteam.ru loops back to myself)
                                         limp@limpteam.ru
Большое спасибо за ответы, и прошу очень рассказать на пальцах в чем косяк, чтобы врубится самому, а не тупо переделать :)

UPD: помойму анчал понимать. указав в transport вроде начало просто накапливаться без ошибок

Re: postfix backup mx

Добавлено: 2010-03-03 13:50:04
LimpTeaM
вроде разобрался
когда первый сервер выключен, у второго в очереди вот так вот:

Код: Выделить всё

 mailq
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
C4346284E5     2051 Wed Mar  3 13:14:40  limpteam@gmail.com
             (connect to mx.limpteam.ru[77.246.107.77]:25: Connection refused)
                                         limp@limpteam.ru

на втором сервере добавил в transport путь до первого сервера
это нормально? :) все ли правильно настроил?