Страница 1 из 1

Трабл с apache2+php+fastcgi

Добавлено: 2008-10-02 16:13:44
70n0ff
Всем привет.
Ставил апачку2 по статье Лиса, во первых почемуто пришлось при сборке пхп тянуть патч php-5.2.5-mail-header.patch
Мол самой системен не подсилу. это фигня так просто для внимания.
Далее, как бы все установилось, домен обозвал dark-tm.ru, понимаю не важно как, просто чтобы было меньше абстракции,
завел юзверя ессно группу (dark-tm), добавил в группу www. Конфиг апачи исправил с коректировками на имя.
В общем обычные странички html на ура, ещё бы, а вот скриптиковые выдает такую фишку

You don't have permission to access /php-fcgi/php.sh/index.php

Я уж всей папке ставил 777 фиолет. в общем помогите нубу. кто чем может.

Re: Трабл с apache2+php+fastcgi

Добавлено: 2008-10-02 16:17:13
Larin
70n0ff писал(а):Всем привет.
Ставил апачку2 по статье Лиса, во первых почемуто пришлось при сборке пхп тянуть патч php-5.2.5-mail-header.patch
Мол самой системен не подсилу. это фигня так просто для внимания.
Далее, как бы все установилось, домен обозвал dark-tm.ru, понимаю не важно как, просто чтобы было меньше абстракции,
завел юзверя ессно группу (dark-tm), добавил в группу www. Конфиг апачи исправил с коректировками на имя.
В общем обычные странички html на ура, ещё бы, а вот скриптиковые выдает такую фишку

You don't have permission to access /php-fcgi/php.sh/index.php

Я уж всей папке ставил 777 фиолет. в общем помогите нубу. кто чем может.
логи что говорят?
буквально вчера ставил по той же статье. все ништяг. кроме того, что апач не скушал настройки make.conf и собрался без suexec... пришлось вручную указать ему...

Re: Трабл с apache2+php+fastcgi

Добавлено: 2008-10-03 5:24:15
70n0ff
httpd-error.log

[Thu Oct 02 11:53:49 2008] [error] [client 10.0.0.28] client denied by server co
nfiguration: /usr/home/dark-tm/www/cgi-bin/php.sh

Это)

Re: Трабл с apache2+php+fastcgi

Добавлено: 2008-10-03 8:20:17
zingel

Re: Трабл с apache2+php+fastcgi

Добавлено: 2008-10-03 12:41:42
70n0ff
Фурычит)))
Спасибо за помощь!
Всему виной моя невнимательность. :oops: Забыл прописать в коняфиге апачи строчки

<Directory "/usr/home/*/www/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

после этого конечно не пустил :x , кстати suexec и не пустил, так что все нормально он собрался )))))
поменял chmod 755 и все ок)
всем спасибо. :good: Закрывайте и киляйте топик)))