Nginx и net::err_spdy_protocol_error

Проблемы с установкой, настройкой и работой системных и сетевых программ.

Модераторы: GRooVE, alexco

Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Shad!
проходил мимо
Сообщения: 4
Зарегистрирован: 2018-03-09 23:46:53

Nginx и net::err_spdy_protocol_error

Непрочитанное сообщение Shad! » 2018-03-10 0:03:37

Доброго дня.
После перевода сайтов на https вылезла следующая проблема: если на странице много картинок - они грузятся через раз. Chrome показывает ошибку net::err_spdy_protocol_error при попытке загрузки (если нажать на ссылку, у которой ошибка - картинка откроется), firefox ошибок не показывает, но некоторые картинки не отображаются (причем не отображаются рандомно, т.е вопрос не в отсутствии файлов). В логах сервера ошибок нет, в access.log - отданная картинка со статусом 200. Сайтов 2, оба на wordpress, картина одинаковая на обоих. По http страница открывается без каких либо проблем.
Сбрасывать и переставлять браузер пробовал, проблему не решает, да и ошибки эти появляются только на сайтах, которые на этом сервере, т.е проблема серверная, судя по всему.
На сервере установлена freebsd 11.1 с последними обновлениями, nginx, php-fpm и mariaDB в качестве бд. Весь софт обновлен до последних версий (обновление проблему не решило).
ssl настройки nginx:

Код: Выделить всё

ssl on;
ssl_certificate /usr/local/etc/letsencrypt/live/tso/fullchain.pem;
ssl_certificate_key /usr/local/etc/letsencrypt/live/tso/privkey.pem;
ssl_ciphers "ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:ECDHE-RSA-DES-CBC3-SHA:AES256-GCM-SHA384:AES128-GCM-SHA256:AES256-SHA256:AES128-SHA256:AES256-SHA:AES128-SHA:DES-CBC3-SHA:!aNULL:!eNULL:!EXPORT:!DES:!MD5:!PSK:!RC4";
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_prefer_server_ciphers on;
ssl_session_cache shared:SSL:10m;
ssl_session_timeout 5m;
Если кто сталкивался с чем-то подобным - подскажите, плиз, в чем может быть проблема?

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2460 рублей (8 CPU, 8Gb RAM, 2x500Gb HDD, RAID 3ware 9750):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35056
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Nginx и net::err_spdy_protocol_error

Непрочитанное сообщение Alex Keda » 2018-03-18 20:50:23

слишком много параллельных соединений?
Убей их всех! Бог потом рассортирует...

Shad!
проходил мимо
Сообщения: 4
Зарегистрирован: 2018-03-09 23:46:53

Nginx и net::err_spdy_protocol_error

Непрочитанное сообщение Shad! » 2018-04-07 10:03:05

Не похоже: ошибок в логах нет, все картинки в логах висят со статусом 200.

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35056
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Nginx и net::err_spdy_protocol_error

Непрочитанное сообщение Alex Keda » 2018-04-15 22:05:10

а те которые не открываются? они в логе в это соединение есть или нет?

вообще, ну очень похоже на слишком много соединенией...
Убей их всех! Бог потом рассортирует...

Shad!
проходил мимо
Сообщения: 4
Зарегистрирован: 2018-03-09 23:46:53

Nginx и net::err_spdy_protocol_error

Непрочитанное сообщение Shad! » 2018-04-18 20:07:28

Ага, они есть в логе. Со статусом 200, что интересно :)

Shad!
проходил мимо
Сообщения: 4
Зарегистрирован: 2018-03-09 23:46:53

Nginx и net::err_spdy_protocol_error

Непрочитанное сообщение Shad! » 2018-04-30 20:39:35

Стало еще интереснее: после очередного обновления хрома какие-либо вменяемые ошибки вообще пропали :) Теперь так (первое - строка из лога, а скрин из хрома при загрузке того же файла):
81.5.108.* - - [30/Apr/2018:20:34:39 +0300] "GET /images/units/icon_bandit_boss5.png HTTP/2.0" 200 240 "https://ru.tsomaps.com/tools/generator/" "Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36" "-"
Изображение