Страница 1 из 4

падает bgp сессия при отключении pppoe

Добавлено: 2008-06-13 22:41:55
at
Каким оразом можно отучить bgpd из quagga реагировать на удаление pppoe интефейсов

Код: Выделить всё

2008/06/13 19:08:53 ZEBRA: if_ioctl(SIOCGIFFLAGS) failed: Device not configured
2008/06/13 19:08:53 ZEBRA: Can't lookup mtu by ioctl(SIOCGIFMTU)
как следствеи падение bgp сесии

для ospf

Код: Выделить всё

passive-interface ng0
типа помогает

касетельно bgp пока ничего похожего не нашол
на стороне сервера у pppoe серый ip у клиета реальный

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-14 17:34:51
paradox
а нефиг bgp тулить на тунели
кто вам вообще еще AS дал
при таком канале

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-14 23:16:43
at
wan статический + bgp quagga
lan планирутеся pppoe

при таком раскладе, падает bgp wan при авто удалении ng интерфейса, в этом и проблема

paradox так что не суетись )) все намально ;-)

пока тест все на 1 металоломе,
планирую вынести все что касается глобального рутинга на другой желез но сейчас так и проблема такая, и адекватного решения пока нет .....

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-14 23:20:53
paradox
хм
каким это образом падает quagga если она про тот интефейс ничего незнает?? про ng0
ммм

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-14 23:23:40
at
я ей говорил что есть у меня ng0 но она при его удалении всеравно падает, может статически создать N ng интерфейсов и сказать ей что они есть у меня

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-14 23:26:47
at
на создание нового ng quagga не реагирует никак, но на удаление начинает материться, и падает bgp сесия

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-14 23:30:03
paradox
а зачем ей говорить что у вас динамический интерфейс?

можно на конфиг глянуть?

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-14 23:37:56
at
еще раз обяьясняю топологию,

wan - статический реальный ip
lan - реальные ip (рутинг по bgp)+ планируется pppoe

Код: Выделить всё

cat /usr/local/etc/quagga/zebra.conf
! -*- zebra -*-
interface lo0
! description test of desc.
!
interface bge0
interface em0
interface em1
interface ng0
interface ng1
! multicast
!
!
! Static default route sample.
!

ip route 0.0.0.0/0 111.111.11.111
ip route 22.22.22.0/22 0.0.0.0
!
!
log file /var/log/zebra.log
!log syslog

Код: Выделить всё

cat /usr/local/etc/quagga/bgpd.conf
!
!
router bgp 12345
network 22.22.22.0/22
neighbor 111.111.11.111 remote-as 22234
neighbor 111.111.11.111 next-hop-self
neighbor 111.111.11.111 soft-reconfiguration inbound
!passive-interface ng0
!
line vty
!

это что что сейчас работает

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-14 23:39:55
at
я ей как только не пытался обьяснить что ng интерфейсы дело не твое не трогай их ... ничего не вышло

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-14 23:41:35
paradox
просить что бы айпи выдавали статический
и вместо интерфейса указать айпиадресс
попробуй
непомню zabra/quagga умеет или нет

если нет
на днях загляну в соурсы как можно обойти

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-14 23:47:27
at
при добавлении ng девайса она походу начинает что то сним мутить, но при удалении незнает как себя всести ...
как по моему в эту сторону нужно смотреть, но я не настолько спец в С ((((

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-14 23:55:37
paradox
!passive-interface ng0
заменить на
!passive-interface 1.1.1.1

так катит?


или у вас еще и айпишник pppoe будет динамически давать?)))

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:00:58
at
у меня нет дтнамических ip
только mpd5 создает динамически интрфейсы при подключении

pppoe дает статичный ip из радиуса
на passive-interface в bgpd.conf зебра категорически матеится в любой вариации

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:04:44
paradox
либо надо на loopback как то закручивать
либо передописывать зебру или куагу
что бы можно было вставлять вместо имени интерфейса его айпишник

потому как ситуация когда исчезает интерфейс на который опираемся третей ногой - не есть нормальная ситуация)
в этом виноват админ с его топологией

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:14:30
at
не админ виноват )) что предлагаеш из дома cisco приташить и поставить для bgp )))

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:17:27
paradox
если автономка реальная и ее видно в нета
то за глюки с bgp вас запинают
(блин забыл как умное слово называеться) =)))

для реальных автономок токо циска
потому как ни зебра ни куаага
не держит (уже блин непомню) какойто обьем (какогто уровня)

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:20:17
at
я то поставлю отдельный металомом под рутитнг, из того что есть в наличии если ничего не решиться ....
история вроди бы и банальная, но странно что ни укого на эту тему до меня небыло воросов, я не нарыл ничего похожего разве что для ospf но для bgp тоже не работает

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:22:23
at
на тему запинают так и есть, но и за циску тоже прибьют сначала потом не купят )))

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:25:45
paradox
у вас реальная автономка?
скоко сеть? /22 если да то даже и незадумывайся КИСКА ОДНОЗНАЧНО

иначе пинальти запинают
а потом могут и сеть отобрать))))

токо если меньше /22 и то с напрягом можешь ставить quagga
зебру не советую)

с интерфейсом немного непонял

можно топологию что бы понять почем pppoe итд

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:36:31
at
всё реальное
стоит quagga сейчас
рельно рутятся 2 сети /24 ip

на тему топологии

wan - статичекский реальный ip
lan - реальные ip из моей AS

сейчас на лан средствами простого рутинга дается нет
возникла идея не просто рутить а давать ip через pppoe

всё на 1 сервере IBM

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:39:49
paradox
эт типа клинетам раздавать по pppoe реальные айпи
а квага что бы это рулила

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:40:49
at
так и получается

только ничего не получается :ROFL:

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:48:27
paradox
думать мне щас влом
но чего то там в понимании реализации у вас не так

вы ж клиентам по одному айпи раздаете
а не по несколько сетей

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:50:33
at
по 1 Ip и в чем проблема, связи не вижу

Re: падает bgp сессия при отключении pppoe

Добавлено: 2008-06-15 0:57:27
paradox
думать щас влом :-D
я вот в другой ветке шокирован тем что циска оказываеться
вместо сеанса ppp ipcp
запускает DHCP :shock: и раздает таким макаром айпи
[цензура][цензура]