Страница 1 из 1

[misc/mc] ошибка make install

Добавлено: 2010-10-03 1:42:29
hurid
При попытке установить что не будь из портов появляется такая вот ошибка :cry: :cry: :cry:

Код: Выделить всё

server# cd /usr/ports/misc/mc
server# make
===>   mc-4.6.2 depends on executable: pkg-config - found
===>   mc-4.6.2 depends on executable: gmake - found
===>   mc-4.6.2 depends on file: /usr/local/bin/perl5.8.9 - found
===>   mc-4.6.2 depends on file: /usr/local/bin/automake-1.9 - not found
===>    Verifying install for /usr/local/bin/automake-1.9 in /usr/ports/devel/automake19
===>   automake-1.9.6_3 depends on file: /usr/local/bin/perl5.8.9 - found
===>   automake-1.9.6_3 depends on file: /usr/local/bin/autoconf-2.62 - found
===>  Configuring for automake-1.9.6_3
checking build system type... amd64-portbld-freebsd8.0
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... nawk
checking whether make sets $(MAKE)... yes
checking for perl... /usr/local/bin/perl
checking for tex... no
checking whether autoconf is installed... yes
checking whether autoconf works... no
configure: error: The installed version of autoconf does not work.
    Please check config.log for error messages before this one.
===>  Script "configure" failed unexpectedly.
Please report the problem to ade@FreeBSD.org [maintainer] and attach the
"/usr/ports/devel/automake19/work/automake-1.9.6/config.log" including the
output of the failure of your make command. Also, it might be a good idea to
provide an overview of all packages installed on your system (e.g. an `ls
/var/db/pkg`).
*** Error code 1

Stop in /usr/ports/devel/automake19.
*** Error code 1

Stop in /usr/ports/misc/mc.
*** Error code 1

Stop in /usr/ports/misc/mc.

Re: ошибка make install

Добавлено: 2010-10-03 1:57:02
Гость
configure: error: The installed version of autoconf does not work.
в какой букве у вас затруднения с переводом?

Re: ошибка make install

Добавлено: 2010-10-03 2:03:00
hurid
Извините, просто я новичок в *nix.

Re: ошибка make install

Добавлено: 2010-10-03 2:18:18
Гость
вы где нибудь видели что бы дети с 5 лет поступали сразу в 11 класс или еще лучше в окфорд или гарвард
и становились извесными учеными?
вот и я о том же
если вы новичек то начните с азов
это не первая ваша ошибка, и в ошибках нужно научится читать и разбиратся
подсказку я вам дал
если с англицким туго
возьмите переводчик

Re: ошибка make install

Добавлено: 2010-10-03 2:21:37
hurid
Спасибо, буду разбираться :smile: :oops:

Re: ошибка make install

Добавлено: 2010-10-04 8:27:05
Pablo
Обновить autoconf2.62 до autoconf2.67 согласно замечанию от 20100915 в /usr/ports/UPDATES (обязательно к чтению перед каждым обновлением!).
При использовании portupgrade это было, если не ошибаюсь:

Код: Выделить всё

portupgrade --origin autoconf267 autoconf-2.62
И все зависимые от него порты:

Код: Выделить всё

portupgrade --force --recursive --exclude autoconf-2.67 autoconf-2.67