Страница 1 из 1

Помогите победить ошибку.

Добавлено: 2011-01-29 17:58:16
kedr275
Добрый день.
Такая ошибка . Порты обновил. Вижу что пишут чтото про версию. Но как исправить незнаю.

Код: Выделить всё

1-2.0.la ../gdk/Gdk-2.0.gir Makefile --output Gtk-2.0.gir
/bin/sh /usr/ports/x11-toolkits/gtk20/work/gnome-libtool  --tag=CC   --mode=link cc  -DGDK_PIXBUF_DISABLE_DEPRECATED -O2 -pipe -fno-strict-aliasing -Wall  -L/usr/local/lib -o gtk-query-immodules-2.0 queryimmodules.o libgtk-x11-2.0.la ../gdk/libgdk-x11-2.0.la -pthread -L/usr/local/lib -lpangocairo-1.0 -lX11 -lXcomposite -lXdamage -lXfixes -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lpng -lz -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lm -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lglib-2.0 -pthread -L/usr/local/lib -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lglib-2.0
/usr/local/share/gir-1.0/Atk-1.0.gir: Incompatible version 1.0 (supported: 1.2)
gmake[4]: *** [Gtk-2.0.gir] Ошибка 1
gmake[4]: *** Ожидание завершения заданий...
gnome-libtool: link: cc -DGDK_PIXBUF_DISABLE_DEPRECATED -O2 -pipe -fno-strict-aliasing -Wall -o .libs/gtk-query-immodules-2.0 queryimmodules.o -pthread -pthread  -L/usr/local/lib ./.libs/libgtk-x11-2.0.so /usr/ports/x11-toolkits/gtk20/work/gtk+-2.22.1/gdk/.libs/libgdk-x11-2.0.so ../gdk/.libs/libgdk-x11-2.0.so /usr/local/lib/libXinerama.so /usr/local/lib/libXi.so /usr/local/lib/libXrandr.so /usr/local/lib/libXcursor.so /usr/local/lib/libpangocairo-1.0.so /usr/local/lib/libXcomposite.so /usr/local/lib/libXext.so /usr/local/lib/libXdamage.so /usr/local/lib/libXfixes.so /usr/local/lib/libatk-1.0.so /usr/local/lib/libcairo.so /usr/local/lib/libpixman-1.so /usr/local/lib/libxcb-shm.so /usr/local/lib/libxcb-render.so /usr/local/lib/libXrender.so /usr/local/lib/libX11.so /usr/local/lib/libxcb.so /usr/local/lib/libXau.so /usr/local/lib/libXdmcp.so /usr/local/lib/libpthread-stubs.so -lrpcsvc /usr/local/lib/libgdk_pixbuf-2.0.so -lpng /usr/local/lib/libgio-2.0.so /usr/local/lib/libpangoft2-1.0.so /usr/local/lib/libpango-1.0.so -lm /usr/local/lib/libfontconfig.so /usr/local/lib/libfreetype.so -lz /usr/local/lib/libexpat.so /usr/local/lib/libgobject-2.0.so /usr/local/lib/libgmodule-2.0.so /usr/local/lib/libgthread-2.0.so /usr/local/lib/libglib-2.0.so /usr/local/lib/libintl.so /usr/local/lib/libiconv.so /usr/local/lib/libpcre.so -pthread -Wl,-rpath -Wl,/usr/local/lib
gmake[4]: Leaving directory `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.22.1/gtk'
gmake[3]: *** [all-recursive] Ошибка 1
gmake[3]: Leaving directory `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.22.1/gtk'
gmake[2]: *** [all] Ошибка 2
gmake[2]: Leaving directory `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.22.1/gtk'
gmake[1]: *** [all-recursive] Ошибка 1
gmake[1]: Leaving directory `/usr/ports/x11-toolkits/gtk20/work/gtk+-2.22.1'
gmake: *** [all] Ошибка 2
*** Error code 1

Stop in /usr/ports/x11-toolkits/gtk20.
*** Error code 1

Stop in /usr/ports/x11-toolkits/gtk20

Re: Помогите победить ошибку.

Добавлено: 2011-01-29 18:11:44
Kesha
А что вы делаете?
Ставите или обновляете?
Ещё интересно - что? :roll:

Re: Помогите победить ошибку.

Добавлено: 2011-01-29 18:16:56
kedr275
Kesha писал(а):А что вы делаете?
Ставите или обновляете?
Ещё интересно - что? :roll:
ставил thunderbird. Вывалился с ошибкой в usr/ports/x11-toolkits/gtk20
перешел в usr/ports/x11-toolkits/gtk20 пытюсь установить, чтобы потом продолжить установку thunderbird.

Re: Помогите победить ошибку.

Добавлено: 2011-01-29 18:17:08
Gamerman
Судя по всему ставят (обновляют) gtk20
Скорее всего, нужно обновить gir

Re: Помогите победить ошибку.

Добавлено: 2011-01-29 18:38:05
kedr275
Gamerman писал(а):Судя по всему ставят (обновляют) gtk20
Скорее всего, нужно обновить gir
Что такое gir и где его искать в портах ?
А еше у меня так.

Код: Выделить всё

/usr/ports#pkg_version -v | grep need
bn-freebsd-doc-20100625             <   needs updating (port has 20110110)
da-freebsd-doc-20100625             <   needs updating (port has 20110110)
de-freebsd-doc-20100625             <   needs updating (port has 20110110)
el-freebsd-doc-20100625             <   needs updating (port has 20110110)
en-freebsd-doc-20100625             <   needs updating (port has 20110110)
es-freebsd-doc-20100625             <   needs updating (port has 20110110)
fr-freebsd-doc-20100625             <   needs updating (port has 20110110)
hu-freebsd-doc-20100625             <   needs updating (port has 20110110)
/usr/ports# 

Re: Помогите победить ошибку.

Добавлено: 2011-01-29 19:01:57
Gamerman
поставте portmaster и попробуйте установить thunderbird с его помошью. Ключик -f юзайте для принудительной пересборки всех нужных пакетов.

Re: Помогите победить ошибку.

Добавлено: 2011-01-29 21:00:21
Kesha
kedr275 писал(а): А еше у меня так.

Код: Выделить всё

/usr/ports#pkg_version -v | grep need
bn-freebsd-doc-20100625             <   needs updating (port has 20110110)
da-freebsd-doc-20100625             <   needs updating (port has 20110110)
de-freebsd-doc-20100625             <   needs updating (port has 20110110)
el-freebsd-doc-20100625             <   needs updating (port has 20110110)
en-freebsd-doc-20100625             <   needs updating (port has 20110110)
es-freebsd-doc-20100625             <   needs updating (port has 20110110)
fr-freebsd-doc-20100625             <   needs updating (port has 20110110)
hu-freebsd-doc-20100625             <   needs updating (port has 20110110)
/usr/ports# 
А "ru" куда делось? :smile:
Они вам нужны? Удалите их. Много места хотят и долго обновляются.