Страница 1 из 1

vsftpd на freebsd

Добавлено: 2011-08-18 12:53:36
system
Доброго времени суток всем.
Столкнулся с такой проблемой установил на freebsd 7.2 сервер ftp на vsftpd все работает тока скорость скачки очень низкая даже когда к серверу с ноутбуком подключаюсь качает 3 или 4 мегабита не больше хотя по витой паре должно 100мегабит качать. Прошу помощи.
Заранее спасибо.

Re: vsftpd на freebsd

Добавлено: 2011-08-18 13:20:45
bagas
я думаю vsftpd тут не причем.
настраивайте sysctrl систему...

Re: vsftpd на freebsd

Добавлено: 2011-08-18 13:22:31
system
sysctrl а по подробнее можно ??

Re: vsftpd на freebsd

Добавлено: 2011-08-18 13:33:29
bagas
sysctl - это интерфейс, позволяющий вам вносить изменения в работающую систему FreeBSD
я такие использую. можете попробовать.

Код: Выделить всё

net.inet.udp.recvspace=78840
net.inet.udp.maxdgram=57344
net.inet.tcp.sendspace=65435
net.inet.tcp.recvspace=65435
kern.ipc.maxsockbuf=16777216
kern.ipc.maxsockets=204800
kern.ipc.nmbclusters=32768
kern.ipc.somaxconn=32768
kern.maxfiles=256000
kern.maxfilesperproc=32768
kern.maxvnodes=800000

net.inet.tcp.delayed_ack=1
net.inet.tcp.delacktime=100
net.local.stream.sendspace=82320
net.local.stream.recvspace=82320
net.inet.tcp.local_slowstart_flightsize=10
net.inet.tcp.nolocaltimewait=1
net.inet.tcp.hostcache.expire=3900
kern.polling.burst_max=1000
kern.polling.idle_poll=0
kern.polling.each_burst=50
net.inet.tcp.hostcache.expire=3900
net.inet.tcp.slowstart_flightsize=54
net.inet.tcp.inflight.enable=1
net.inet.tcp.inflight.min=6144

Re: vsftpd на freebsd

Добавлено: 2011-08-18 13:56:16
system
/etc/rc.d/sysctl reload применил и даже перегрузил не работает все таки скорость закачки ниская с него.... :(

Re: vsftpd на freebsd

Добавлено: 2011-08-18 14:09:07
bagas
покажите ifconfig

Re: vsftpd на freebsd

Добавлено: 2011-08-18 14:31:35
bagas
забыл сказать вам. что конфиги нужно добавлять в файл /etc/sysctl.conf тогда они останутся после перезагрузки.

Re: vsftpd на freebsd

Добавлено: 2011-08-18 15:01:59
system
re0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC>
ether 00:1f:d0:9f:19:a7
media: Ethernet autoselect (10baseT/UTP <half-duplex>)
status: no carrier
rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 00:e0:7d:fe:7c:39
inet 77.244.145.249 netmask 0xfffffff0 broadcast 77.244.145.255
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active