Страница 1 из 1

прошу не бить ногами

Добавлено: 2011-08-31 10:29:06
kirill666
Доброго времени суток!
есть система: FreeBSD 8.2-STABLE FreeBSD 8.2-STABLE #0 r86: Mon Jul 25 21:39:03 IRKST 2011 root@freebsd8-amd64.ispsystem.net:/root/src/sys/amd64/compile/ISPSYSTEM amd64
на нее нужно установить ImageMagick устанавливаю через порты система ругается:

Код: Выделить всё

===>   ghostscript9-nox11-9.02_4 depends on shared library: cupsimage.2 - not found
===>    Verifying install for cupsimage.2 in /usr/ports/print/cups-image
===>   cups-image-1.4.8 depends on executable: gmake - found
===>   cups-image-1.4.8 depends on shared library: cups.2 - not found
===>    Verifying install for cups.2 in /usr/ports/print/cups-client
===>  cups-client-1.4.8 is marked as broken: gnutls does not support threads yet; disable the GNUTLS.
*** Error code 1

Stop in /usr/ports/print/cups-client.
*** Error code 1

Stop in /usr/ports/print/cups-image.
*** Error code 1

Stop in /usr/ports/print/cups-image.
*** Error code 1

Stop in /usr/ports/print/ghostscript9-nox11.
*** Error code 1

Stop in /usr/ports/print/ghostscript9-nox11.
*** Error code 1

Stop in /usr/ports/graphics/ImageMagick.
*** Error code 1

Stop in /usr/ports/graphics/ImageMagick.
Обновить порты через sysinstall не получается он вылетает, portsnap fetch update вроде отрабатывает, но результат такой же.

На сколько я понимаю нет зависимых портов, но они тоже не ставятся ругаясь друг на друга. Возможно я каких то не нужных параметров при первом запуске установки поставил, как переконфигурить порт при установке. Или подскажите куда копать

Re: прошу не бить ногами

Добавлено: 2011-08-31 10:41:35
schizoid
а CUPS вам нужен? посмотрите, где , в какой зависимости он включен и снимите галочку, а то скорее всего не ставится из-за
cups-client-1.4.8 is marked as broken

Re: прошу не бить ногами

Добавлено: 2011-08-31 11:18:22
Mox
schizoid писал(а):а CUPS вам нужен? посмотрите, где , в какой зависимости он включен и снимите галочку, а то скорее всего не ставится из-за
cups-client-1.4.8 is marked as broken
не вырывайте фразы из контекста!

Код: Выделить всё

cups-client-1.4.8 is marked as broken: gnutls does not support threads yet; disable the GNUTLS
2 автор: задизаблите у cups-client опцию GNUTLS. Подробности в /usr/ports/UPDATING

Re: прошу не бить ногами

Добавлено: 2011-08-31 12:07:25
kirill666
Mox писал(а):
schizoid писал(а):а CUPS вам нужен? посмотрите, где , в какой зависимости он включен и снимите галочку, а то скорее всего не ставится из-за
cups-client-1.4.8 is marked as broken
не вырывайте фразы из контекста!

Код: Выделить всё

cups-client-1.4.8 is marked as broken: gnutls does not support threads yet; disable the GNUTLS
2 автор: задизаблите у cups-client опцию GNUTLS. Подробности в /usr/ports/UPDATING
Как и где его запретить ?

Re: прошу не бить ногами

Добавлено: 2011-08-31 12:34:03
bagas
cd /usr/ports/print/cups-client && make config убрать поддержку GNUTLS ( убрать крестик)!

Re: прошу не бить ногами

Добавлено: 2011-08-31 12:57:00
tom.cat
Аналогично здесь тоже надо отключить:

Код: Выделить всё

cd /usr/ports/print/cups-image && make config
Вчера столкнулся с этим же обновлением. Отключение гнутлс решило проблему.

Re: прошу не бить ногами

Добавлено: 2011-08-31 14:40:18
kirill666
С этим разобрались, спасибо =)
Еще подскажите плиз как модуль gd подключить к php? как он должен прописываться в php.ini

Re: прошу не бить ногами

Добавлено: 2011-08-31 14:48:40
Mox
kirill666 писал(а):С этим разобрались, спасибо =)
Еще подскажите плиз как модуль gd подключить к php? как он должен прописываться в php.ini
в unix-подобных нет php.ini, а во фре оно само все пропишется куда надо при установке

Re: прошу не бить ногами

Добавлено: 2011-08-31 14:49:24
manefesto
модуль сам должен ставиться.
Глянь пример подключения модуля, среди тех что уже поставлены

Re: прошу не бить ногами

Добавлено: 2011-08-31 15:17:39
kirill666
в этой фре есть
/usr/local/etc/php.ini
там я раскоментил extension=php_gd2.dll уже после установки и
все равно результата ноль
в phpinfo нигде нет ничего про gd

Re: прошу не бить ногами

Добавлено: 2011-08-31 15:28:43
Mox
kirill666 писал(а):в этой фре есть
/usr/local/etc/php.ini
там я раскоментил extension=php_gd2.dll уже после установки и
все равно результата ноль
в phpinfo нигде нет ничего про gd
извините, попутал, есть конечно. Только в этом файле настройки. А расширения в /usr/local/etc/php/extensions.ini

Re: прошу не бить ногами

Добавлено: 2011-08-31 20:09:04
kirill666
В /usr/local/etc/php/extensions.ini дописал модуль, gd все перезапустил, все равно не phpinfo не выдает что модуль есть, куда копать

Re: прошу не бить ногами

Добавлено: 2011-08-31 20:50:09
Gendos
как модуль ставил?

Re: прошу не бить ногами

Добавлено: 2011-08-31 20:57:22
Gendos

Код: Выделить всё

cd /usr/ports/graphics/php5-gd && make install clean && rehash && /usr/local/etc/rc.d/apache22 restart

Re: прошу не бить ногами

Добавлено: 2011-08-31 21:43:54
kirill666
сначала ставил просто gd потом php-gd
cd /usr/ports/graphics/php52-gd && make install clean && rehash && /usr/local/etc/rc.d/apache22 restart
в /usr/local/etc/php/extensions.ini он сам прописался, но так и нет его в phpinfo
тихо схожу с ума.

Re: прошу не бить ногами

Добавлено: 2011-09-01 6:08:03
Gendos
Индейца не перезапустил
/usr/local/etc/rc.d/apache22 onerestart

Re: прошу не бить ногами

Добавлено: 2011-09-01 9:30:03
kirill666
Перезапустил, даже сервак ребутил... эффекта ноль

Re: прошу не бить ногами

Добавлено: 2011-09-01 10:23:09
FreeBSP
phpinfo() в студию
и httpd-error.log (часть после рестарта индейца)

Re: прошу не бить ногами

Добавлено: 2011-09-01 10:39:02
kirill666
Вот:
httpd-error.log

Код: Выделить всё

Thu Sep 01 08:31:30 2011] [notice] caught SIGTERM, shutting down
[Thu Sep 01 08:31:30 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Sep 01 08:31:30 2011] [warn] RSA server certificate CommonName (CN) `vm9219.majordomo.ru' does NOT match server name!?
[Thu Sep 01 08:31:30 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/local/sbin/suexec)
[Thu Sep 01 08:31:31 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Sep 01 08:31:31 2011] [warn] RSA server certificate CommonName (CN) `vm9219.majordomo.ru' does NOT match server name!?
[Thu Sep 01 08:31:31 2011] [notice] Digest: generating secret for digest authentication ...
[Thu Sep 01 08:31:31 2011] [notice] Digest: done
[Thu Sep 01 08:31:31 2011] [notice] Apache/2.2.19 (FreeBSD) mod_ssl/2.2.19 OpenSSL/0.9.8q DAV/2 PHP/5.2.17 with Suhosin-Patch configured -- resuming normal operations
а phpinfo можно посмотреть
http://nadejnei.net/php.php

Re: прошу не бить ногами

Добавлено: 2011-09-01 10:51:48
kirill666
было накосячиено в /usr/local/etc/php/extensions.ini
все работает СПС ОГРОМНОЕ

Re: прошу не бить ногами

Добавлено: 2011-09-01 16:17:43
kirill666
продолжаем тему с php модулями + :oops:
PHP XML Extensions: Not Installed
а их где найти ? и поставить ?

Re: прошу не бить ногами

Добавлено: 2011-09-01 19:22:02
Bayerische
Блин... А что вы метапорт не поставите?

Re: прошу не бить ногами

Добавлено: 2011-09-01 22:18:00
FreeBSP
метапорт-не тру

Код: Выделить всё

whereis php5-xml