Страница 1 из 1

не запускаеться апач после установки SAMS

Добавлено: 2011-09-08 16:55:47
tipaadmin
Freebsd 7.2
не запускаеться апач почле установки SAMS

Код: Выделить всё

ee /usr/local/etc/apache/httpd.conf

Alias /sams "/usr/local/share/sams/"
<Directory "/usr/local/share/sams/">
    AllowOverride AuthConfig
        Options Indexes MultiViews
        Order allow,deny
        Allow from all
</Directory>
все как по инструкции http://www.lissyara.su/articles/freebsd ... ik-adldap/
до этого проверял все работало :((

запуская апача он не работает пишет

Код: Выделить всё

# /usr/local/etc/rc.d/apache start
Starting apache.
Syntax error on line 9 of /usr/local/etc/apache/httpd.conf:
Invalid command 'Alias', perhaps mis-spelled or defined by a module not included in the server configuration
кто сможет объяснить в чем проблемка!!!????

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-08 17:48:04
tipaadmin
конфиг апача только то что добавлял


<Directory />
Options FollowSymLinks ExecCGI
AllowOverride None
</Directory>


Alias /sams "/usr/local/share/sams/"
<Directory "/usr/local/share/sams/">
AllowOverride AuthConfig
Options Indexes MultiViews
Order allow,deny
Allow from all
</Directory>

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-08 17:50:01
tipaadmin
и еще уменя одна сетевая корточка которая проначена

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-08 19:08:23
bagas

Код: Выделить всё

Syntax error on line 9 of /usr/local/etc/apache/httpd.conf:
Вроде скрипт говорит,что ошибка на девятой строке.

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-09 5:50:34
tipaadmin
:)) да но я разобрать не могу че за алияс зачем он нужен и что он делает?

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-09 6:26:03
tipaadmin
пишет что не включен в конфигурацию сервера :pardon:

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-09 6:27:22
tipaadmin
Alias /sams "/usr/local/share/sams/" вот это 9 строка

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-09 8:09:53
lap
Надо допейсать в глобальном конфиге чтото типа:

Код: Выделить всё

LoadModule alias_module libexec/apache22/mod_alias.so
или если все плохо - надо докомпилять соответствующий модуль.

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-09 8:35:04
tipaadmin
спасибо lap дописано все я столько времени портатил на поиск и не нашел, решил поробовать перенести строку в самый низ конфига помогло!!! но теперь у меня еще одна проблемма простите за назойливость в инструкции написанно Заходим в веб интерфейс, по умолчанию пользователь admin, пароль qwerty (всегда так), но я когда захожу http://ИП адрес сервера/sams/index.html? у меня не спрашивает не пароль не логин и не вижу настроик самого самса?

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-09 8:56:03
lap
ну смотри что в логи апача валится. может строчка с алиасом не работает.

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-09 9:23:37
tipaadmin
разобрался спасибо!!!!

теперь еще одна проблемка: ((( повторяюсь простите за глупые возможно вопросы

захожу в samse
Пользователи -> Загрузить всех пользователей домена
Найдены пользователи домена: И там будет список пользователей вашего домена

выдает ошибку
Регистрация новых пользователей, входящих в домен Active Directory
ERROR
FATAL: AD bind failed. Check the login credentials.

я так понял он жалуеться на логин эму прав не хватает? логин я так понял ldap@domen.local который я заводил в АД так я ему дал права админа

что не так?

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-09 9:50:18
tipaadmin
телнетом проваливаюсь на порт 389
домен пингую

подскажите где проблемма?

Re: не запускаеться апач после установки SAMS

Добавлено: 2011-09-09 12:56:52
tipaadmin
это уже другая тема создам другую...