Страница 1 из 1

pkg_install в DragonFlyBSD

Добавлено: 2011-10-03 17:03:19
basf
В версии 2.6 очень многое устанавливалось через #pkg_radd <имя> и работало сразу, за исключением mc.
В версии 2.10 и 2.8 при использовании pkg_radd ссылается на pkg_install:

Код: Выделить всё

# pkg_radd mc-4.6.1nb6
pkg_add: Error: package `mc-4.6.1nb6' was built with a newer pkg_install version
pkg_add: 1 package addition failed
При этом: #pkg_install - Command not found. Прошелся по подкаталогам - ничего не нашёл.
Пошел устанавливать:

Код: Выделить всё

#cd /usr/pkgsrc/pkgtools/pkg_install
#bmake install clean
...
===> Installing for pkg_install-20100915
ERROR: pkg_install-20100915 is already installed - perhaps an older version?
ERROR: If so, you may use either of:
ERROR:     - "pkg_delete pkg_install-20100915" and "/usr/pkg/bin/bmake reinstall"
Т.е. в системе всё-таки есть...
Никто не подскажет, как же им воспользоваться, вместо pkg_radd?

Re: pkg_install в DragonFlyBSD

Добавлено: 2012-02-19 17:13:51
Alex Keda
из портов может поставить?