Страница 1 из 1

Обновление системы.

Добавлено: 2012-02-07 18:07:27
slashka_ua
Добрый день(утро/вечер/ночь).

Сразу к делу:
достался почтовик

Код: Выделить всё

uname -a
FreeBSD ******** 6.2-RELEASE FreeBSD 6.2-RELEASE #0: Fri Jan 12 11:05:30 UTC 2007
связка Postfix + mysql + spamassassin + clamav, может еще что-то.
начал с антивируса: была версия 0.88.* удалил, пытаюсь постаквить 0.97.3 сначала выдавало что libtool "1.5.22_2 need 2.4.2", обновил.
теперь ругается:

Код: Выделить всё

post# cd /usr/ports/security/clamav
post# make install clean
===>   clamav-0.97.3_1 depends on file: /usr/local/bin/python2.7 - found
===>   clamav-0.97.3_1 depends on executable: gmake - found
===>   clamav-0.97.3_1 depends on shared library: iconv.3 - found
===>   clamav-0.97.3_1 depends on shared library: ltdl.7 - not found
===>    Verifying install for ltdl.7 in /usr/ports/devel/libltdl
===>  Building for libltdl-2.4.2
make  all-am
/bin/sh /usr/local/bin/libtool  --tag=CC   --mode=compile cc -DHAVE_CONFIG_H -I.  -DLTDLOPEN=libltdl -DLT_CONFIG_H='<config.h>' -DLTDL -I. -I.  -Ilibltdl -I./libltdl -I./libltdl   -O2 -fno-strict-aliasing -pipe -MT libltdl_la-preopen.lo -MD -MP -MF .deps/libltdl_la-preopen.Tpo -c -o libltdl_la-preopen.lo `test -f 'loaders/preopen.c' || echo './'`loaders/preopen.c
/usr/local/bin/libtool: Can't open /usr/local/bin/libtool: No such file or directory
*** Error code 2

Stop in /usr/ports/devel/libltdl/work/libtool-2.4.2/libltdl.
*** Error code 1

Stop in /usr/ports/devel/libltdl/work/libtool-2.4.2/libltdl.
*** Error code 1

Stop in /usr/ports/devel/libltdl.
*** Error code 1

Stop in /usr/ports/security/clamav.
*** Error code 1

Stop in /usr/ports/security/clamav.
Если я правильно понимаю, нужно обновить:

Код: Выделить всё

clamav-0.97.3_1 depends on shared library: ltdl.7 - not found
а именно сейчас есть

Код: Выделить всё

libltdl-1.5.22      
pkg_info _R libltdl-1.5.22
Information for libltdl-1.5.22:

Comment:
System independent dlopen wrapper


Required by:
php5-mcrypt-5.1.6_3
php5-extensions-1.0
courier-imap-4.1.1,1
courier-authlib-mysql-0.58_2
courier-authlib-base-0.58_2
courier-authlib-0.58_2
phpMyAdmin-2.9.0.2
openldap-server-2.3.27

нужен 2.4.2 ?
Можно это делать без негативных последствий на работающем сервере,не упадут ли службы и сервисы которым он необходим? Есть возможность остановить на 10-20 минут для теста/апдейта/настройки.

P.S.
Жду ваших ответов, полез ковырять спамфильтр.

Re: Обновление системы.

Добавлено: 2012-02-07 18:13:55
Electronik
FreeBSD 6.2-RELEASE не поддерживается точно также как и FreeBSD 6.4. И гарантии того что порт соберётся и будет корректно работать никакой, так что "Работает, не трож"(С)

Re: Обновление системы.

Добавлено: 2012-02-07 18:16:54
slashka_ua
Electronik писал(а):FreeBSD 6.2-RELEASE не поддерживается точно также как и FreeBSD 6.4. И гарантии того что порт соберётся и будет корректно работать никакой, так что "Работает, не трож"(С)

я бы с радостью, но это не вариант, нужно настроить.

Re: Обновление системы.

Добавлено: 2012-02-07 18:37:38
Alvares
я бы отбекапился для начала. Хотя б pkg_create

Re: Обновление системы.

Добавлено: 2012-02-07 18:51:33
slashka_ua
Alvares писал(а):я бы отбекапился для начала. Хотя б pkg_create
Забыл, совсем забыл, действительно, можно сделать бекап и обновить, в случае чего сделать откат потом?