Страница 1 из 1

запарка с shared library помогите

Добавлено: 2012-12-17 4:00:24
obli
После обновление pcre-8.31 до pcre-8.32(без этого не устанавливались php52-extensions) отвалился mc
выдает /libexec/ld-elf.so.1 Shared object "libpcre.so.1" not found, required by "mc"

кто нить может подсказать это как нить можно вылечить без пере установки mc смотрел от этого pcre еще куча софта зависит не хотелось бы усе пере устанавливать.

Re: запарка с shared library помогите

Добавлено: 2012-12-17 8:33:51
BirdGovorun
#cd /usr/local/lib
#ln -s libpcre.so.3 libpcre.so.1

Re: запарка с shared library помогите

Добавлено: 2012-12-17 10:11:05
FreeBSP
правильно - пересобрать

Re: запарка с shared library помогите

Добавлено: 2012-12-17 21:18:13
obli
работает )))
#ln -s libpcre.so.3 libpcre.so.1
а нельзя узнать как вы опредили что именно эта библиотека нужна а не
libpcre.so которя тоже есть в каталоге /usr/local/lib

Re: запарка с shared library помогите

Добавлено: 2012-12-17 23:30:44
FreeBSP
.so это симлинк на .so.1 скорее всего

Re: запарка с shared library помогите

Добавлено: 2012-12-17 23:32:07
BirdGovorun

Код: Выделить всё

/usr/local/lib # ls -l | grep libpcre.so
lrwxr-xr-x   1 root  wheel        12 15 дек 09:41 libpcre.so -> libpcre.so.3
-rwxr-xr-x   1 root  wheel    397822 15 дек 09:41 libpcre.so.3
/usr/local/lib # 
Так понятно?
Так как я "правильно" обновился, мне не надо ссылку делать.

Re: запарка с shared library помогите

Добавлено: 2012-12-18 0:11:10
mak_v_
BirdGovorun ну ткните уже человека
http://forum.lissyara.su/viewtopic.php? ... &start=100 - почти в самом низу