Страница 1 из 1

Vlan на FreeBSD и Foxgate

Добавлено: 2013-06-13 15:42:44
werder31
Добрый день!
Имеется 2-и тазика подключенных к FoxGateS6224-S2, и один шлюз на FreeBSD9.1
Нужно ограничить доступ тазиков между собой.
Пока FoxGateS6224-S2 нет на руках, но почитав мануал, наваял конф железки и Фряхи.
Прощу подсказать если что-то не так, и вообще это работоспособная конфигурация? )))
ПОРТ Tazik1:

Код: Выделить всё

Switch#configure terminal
Switch(Config)#vlan 1
Switch(Config-Vlan1)#name Tazik1
Switch(Config-Vlan1)#switchport interface ethernet 0/0/1
Switch(Config)#interface ethernet 0/0/1
Switch(Config-ethernet0/0/1)#switchport mode access
Switch(Config-ethernet0/0/1)#switchport access vlan 1
Switch(Config-ethernet0/0/1)#switchport port-security mac-address <mac-address>
Switch(Config-ethernet0/0/1)#switchport port-security maximum 1
Switch(Config-ethernet0/0/1)#switchport port-security violation shutdown
ПОРТ Tazik2:

Код: Выделить всё

Switch#configure terminal
Switch(Config)#vlan 2
Switch(Config-Vlan2)#name Tazik2
Switch(Config-Vlan2)#switchport interface ethernet 0/0/2
Switch(Config)#interface ethernet 0/0/2
Switch(Config-ethernet0/0/2)#switchport mode access
Switch(Config-ethernet0/0/2)#switchport access vlan 2
Switch(Config-ethernet0/0/2)#switchport port-security mac-address <mac-address>
Switch(Config-ethernet0/0/2)#switchport port-security maximum 1
Switch(Config-ethernet0/0/2)#switchport port-security violation shutdown
FreeBSD:

Код: Выделить всё

ifconfig_vlan1="inet 192.168.1.1 netmask 255.255.255.0 vlan 1 vlandev em0"
ifconfig_vlan2="inet 192.168.2.1 netmask 255.255.255.0 vlan 2 vlandev em0"
cloned_interfaces="vlan1 vlan2"
Заранее спасибо за советы/подсказки.

Re: Vlan на FreeBSD и Foxgate

Добавлено: 2013-06-14 14:33:07
vadim64
ну всё ок, должно взлететь, молодца

Re: Vlan на FreeBSD и Foxgate

Добавлено: 2013-06-14 15:58:07
werder31
Спасибо :))
Дождусь железки, протестирую

Re: Vlan на FreeBSD и Foxgate

Добавлено: 2013-06-14 17:44:49
tynix
Не взлетит.
Ты забыл порт ethernet 0/0/3, который должен быть в режиме trunk (или tagged, по-разному называется), состоять в vlan1 и vlan2, и смотреть как раз в em0 твоей фряхи. Чтобы друг друга не видели через шлюз- правь фаерволл.
Здесь много и хорошо.