Страница 1 из 1

SAMS+SQLITE

Добавлено: 2013-10-07 8:47:54
tatarin
Добрый день. все делал по статье http://www.lissyara.su/articles/freebsd ... ejik-ntlm/ сейчас пытаюсь установить sams но после make install clean выпадает ошибка unknown extension sqlite for php 55.
Переустановил php extensions но не помогло.
Что делать не знаю :unknown: собираю первый :roll: .

Re: SAMS+SQLITE

Добавлено: 2013-10-07 9:19:28
werder31

Код: Выделить всё

unknown extension sqlite for php 55
Или переустановите php55-sqlite, или же удалите с файла /usr/local/etc/php/extension строку с sqlite

Re: SAMS+SQLITE

Добавлено: 2013-10-07 9:33:35
tatarin
пробовал переустанавливать весь extensions удалить нельзя так как судя по статье оно нужно для работы самса

Re: SAMS+SQLITE

Добавлено: 2013-10-07 9:46:51
werder31
я бы удалил, установил без него, а потом отдельно установил php55-sqlite

Re: SAMS+SQLITE

Добавлено: 2013-10-07 10:37:58
tatarin
удалил строчки в extensions.ini сделал
apachectl graceful
service apache22 restart
и всё равно самс ругается на sqlite

Re: SAMS+SQLITE

Добавлено: 2014-01-10 11:38:02
MrSeasAdmin
tatarin писал(а):удалил строчки в extensions.ini сделал
apachectl graceful
service apache22 restart
и всё равно самс ругается на sqlite
Я подозреваю, вы как и я ставили PHP-Extension с поддержкой версии sqlite3, а в samse 1.0.5 стоит в мэйкфале поддержка просто sqlite.
У меня после изменения Makefile sams-a установился.

Код: Выделить всё

cd /usr/ports/www/sams/
Редактируем Makefile в одном месте:

Код: Выделить всё

USE_GMAKE=      yes
GNU_CONFIGURE=  yes
USE_BZIP2=      yes
USE_PHP=        ctype curl gettext hash iconv json mysql \
                pcre pdo pdo_sqlite posix session \
                simplexml spl [b]sqlite3[/b] tokenizer \  - - - > было просто sqlite
                xmlwriter zlib xmlreader
Далее make install clean. У меня он установился, продолжаю установку))

Re: SAMS+SQLITE

Добавлено: 2014-01-10 12:54:24
MrSeasAdmin
Буду удалять 5.5 - он не работает с safe_mode=on (с версии 5.4 отключили)..Прийдется ставить 5.3
http://us3.php.net/manual/ru/ini.sect.safe-mode.php