Страница 1 из 1
FastCgi Error
Добавлено: 2008-08-24 2:21:40
serge
Код: Выделить всё
[Sun Aug 24 03:18:11 2008] [alert] [client 82.114.238.227] (2)No such file or directory: FastCGI: failed to connect to (dynamic) server "/home/h1003/data/php-bin/php.sh": something is seriously wrong, any chance the socket/named_pipe directory was removed?, see the FastCgiIpcDir directive, referer: http://www.server.ru/index.php
Ктонить сталкивался? Вылетает с непонятной периодичностью. Как лечить ?

Re: FastCgi Error
Добавлено: 2008-08-24 8:08:14
ProFTP
У меня он тоже много чего пишет, apache не работает?
Re: FastCgi Error
Добавлено: 2008-08-24 8:54:26
serge
Апач вылетает с ошибкой 500 "Internal Server Error".
Re: FastCgi Error
Добавлено: 2008-08-24 14:29:34
ProFTP
а много пользователей ( или хитов) на этом сайте или на сервере?
если по дефолту работает, то скорее всего перегруз... наверное...
Re: FastCgi Error
Добавлено: 2008-08-24 18:22:59
serge
Дык в том-то и дело, что один сижу и F5 жму часто и сразу практически вылетает

Больше пользователей нет.
Re: FastCgi Error
Добавлено: 2008-08-24 19:12:12
Daywalker
serge писал(а):Код: Выделить всё
[Sun Aug 24 03:18:11 2008] [alert] [client 82.114.238.227] (2)No such file or directory: FastCGI: failed to connect to (dynamic) server "/home/h1003/data/php-bin/php.sh": something is seriously wrong, any chance the socket/named_pipe directory was removed?, see the FastCgiIpcDir directive, referer: http://www.server.ru/index.php
Ктонить сталкивался? Вылетает с непонятной периодичностью. Как лечить ?

Сегодня только ставил по статье. Была такая ошибка. Так как я новичок в настройках, на всякий случай переделал все заново по статье. Какие права у диры, где находится php.sh и у FastCgiIpcDir?
P.S. Была такая проблема, но я ее победил. Правда пока не знаю в чем именно была загвоздка.
Re: FastCgi Error
Добавлено: 2008-08-24 19:21:15
serge
Код: Выделить всё
srv# cd /usr/local/etc/apache22/
srv# grep 'FastCgiIpcDir' httpd.conf
FastCgiIpcDir /var/run/fastcgi
srv# ll /var/run/ | grep fastcgi
drwx------ 3 www www - 512B 21 авг 00:24 fastcgi
srv# ll /var/run/fastcgi
total 2
drwx------ 2 www www - 512B 24 авг 20:16 dynamic
srv# ll /home/h1003/data/ | grep php
drwxr-x--x 2 h1003 h1003 schg 512B 23 авг 20:37 php-bin
srv# ll /home/h1003/data/php-bin/
total 6
-r-xr-xr-x 1 h1003 h1003 schg 25B 23 авг 20:36 php
-r-------- 1 h1003 h1003 schg 563B 24 авг 03:06 php.ini
-r-xr-xr-x 1 h1003 h1003 schg 119B 23 авг 20:40 php.sh
Сейчас вроде отпустило

Странно, хотя ничего не делал

Re: FastCgi Error
Добавлено: 2008-08-24 19:54:52
Daywalker
У меня скрипты от пользователя fastcgi
И запускается Апачт только если у /var/run/fastcgi полные права (777), иначе
Код: Выделить всё
/usr/local/etc/apache22# apachectl start
Syntax error on line 146 of /usr/local/etc/apache22/httpd.conf:
FastCgiIpcDir /var/run/fastcgi: access for server (uid -1, gid -1) failed: read not allowed
Даже частичные права (770) не помогают.
Хотя пользователь входит в группу www, от которой запускается Апачь
Код: Выделить всё
less /etc/group | grep www
www:*:80:
fastcgi:*:1008:www
Почему так не знаю, может гуру подскажут с какими правами должна быть дира /var/run/fastcgi
Re: FastCgi Error
Добавлено: 2008-08-24 20:03:31
serge
Код: Выделить всё
srv# cd /usr/local/etc/apache22/
srv# grep 'SuexecUserGroup' httpd.conf
SuexecUserGroup h1003 h1003
SuexecUserGroup h1004 h1004
У меня скрипты запускаются от их владельца.
Вот это, кста, тоже важно.
Код: Выделить всё
srv# suexec -V
-D AP_DOC_ROOT="/"
-D AP_GID_MIN=1000
-D AP_HTTPD_USER="www"
-D AP_LOG_EXEC="/var/log/httpd-suexec.log"
-D AP_SAFE_PATH="/usr/local/bin:/usr/local/bin:/usr/bin:/bin"
-D AP_UID_MIN=1000
-D AP_USERDIR_SUFFIX="www"
У тебя какие параметры прописаны в suexec?
Собственно поэтому у меня права на сокет fastcgi принадлежат www. Причем я их не выставлял и диры сам не создавал.
Re: FastCgi Error
Добавлено: 2008-08-24 20:12:24
Daywalker
Код: Выделить всё
suexec -V
-D AP_DOC_ROOT="/usr/local/www/apache22"
-D AP_GID_MIN=1000
-D AP_HTTPD_USER="www"
-D AP_LOG_EXEC="/var/log/suexec.log"
-D AP_SAFE_PATH="/usr/local/bin:/usr/local/bin:/usr/bin:/bin"
-D AP_UID_MIN=1000
-D AP_USERDIR_SUFFIX="public_html"
Беспокоит вот этот параметр
Не знаю, что тут надо прописывать.