squid не всех пускает в интернет
Добавлено: 2008-09-19 7:47:17
Вообщем настроил прозрачный squid 3.0 вроде все работает но не для всех....Некоторым юзерам говорит Access denied хотя в acl Они прописаны нормально. В чем может быть причина?
Код: Выделить всё
#auth_param basic program /usr/local/libexec/squid/ncsa_auth /usr/local/etc/squid/ncsa.sams
#auth_param basic children 5
#auth_param basic realm Squid proxy-caching web server
#auth_param basic credentialsttl 2 hours
#auth_param basic casesensitive off
http_port 127.0.0.1:3128 transparent accel vhost
#forwarded_for off
error_directory /usr/local/etc/squid/errors/Russian-1251
acl QUERY urlpath_regex cgi-bin \?
no_cache deny QUERY
cache_mem 100 MB
maximum_object_size 16384 KB
dns_nameservers 85.28.24.4
visible_hostname GATE.OOMIISERVER.RU
cache_dir ufs /var/squid/cache 100 16 256
cache_mgr sofinan@rambler.ru
cache_access_log /var/squid/logs/access.log
cache_store_log /var/squid/logs/store.log
#acl squidusers proxy_auth REQUIRED
acl banners url_regex "/usr/local/etc/squid/banners"
acl all src 0.0.0.0/0.0.0.0
acl admin src 192.168.0.3
acl denied_sites dstdomain "/usr/local/etc/squid/denied_sites"
acl limited_IP src "/usr/local/etc/squid/limited_IP"
acl multimedia url_regex -i \.JPG$ \.jpeg$ \.gif$ \.mp3$ \.mpeg4$ \.avi$ \.mov$ \.zip$ \.exe$ \.swf$ \.rar$ \.mpg$ \.mpe$ \.wav$
http_access allow admin
http_access deny multimedia banners
http_access deny denied_sites
http_access allow limited_IP
#http_access allow squidusers
http_access deny all