Страница 1 из 1

LDAP 2.3 Репликация Master to Slave

Добавлено: 2008-09-23 17:56:25
Oloremo
Всем привет.

Есть задача настроить репликацию в LDAP.
Я долго мучался с slurpd - постоянно выскакивали какие-то проблемы. Потоп прочитал что это по сути уже деприкейтед и нужно использовать syncrepl.

Документация не очень внятна, на мой взгляд.
Я сделал следующее:
master:

Код: Выделить всё

database   bdb
suffix          "dc=domain,dc=org"
rootdn        "cn=root,dc=domain,dc=org"

overlay syncprov
syncprov-checkpoint 100 10
syncprov-sessionlog 100
slave:

Код: Выделить всё

database   bdb
suffix          "dc=domain,dc=org"
rootdn        "cn=root,dc=domain,dc=org"

syncrepl rid=123
provider=ldap://172.16.1.2:389
type=refreshOnly
interval=0:01:00:00
searchbase="dc=domain,dc=org"
filter="(objectClass=*)"
scope=sub
attrs="*"
schemachecking=off
bindmethod=simple
binddn=""cn=replicator,ou=sys,dc=domain,dc=org"
updatedn=""cn=replicator,ou=sys,dc=domain,dc=org"
credentials=123
Но slave ldap не стартует с ошибкой:

Код: Выделить всё

slapd[43092]: /usr/local/etc/openldap/slapd.conf: line 65: Error: Malformed "syncrepl" line in slapd config file, missing provider searchbase.
slapd[43092]: failed to add syncinfo
slapd[43092]: slapd stopped.
slapd[43092]: connections_destroy: nothing to destroy.
Что за беда?
Сторока 65 это: "syncrepl rid=123"

Re: LDAP 2.3 Репликация Master to Slave

Добавлено: 2008-09-24 13:04:57
Oloremo
Никаких идей?...