Страница 1 из 1

VPN

Добавлено: 2007-03-03 20:11:20
Blacking
Необходимо подключиться во FreeBSD к VPN, делается сие при помощи pptp, вот конфиг его:

Код: Выделить всё

###/etc/ppp/ppp.conf###
default:
 set log phase chat connect lcp ipcp command
vpn:
 set authname login_vpn
 set authkey password_vpn
 set timeout 0
 set ifaddr 0 0
 add default HISADDR

###options.pptp###
proxyarp
+MSChap-V2 mppe-128 mppe-stateless
при выполнении команды:

Код: Выделить всё

# pptp vpn.server.ru vpn
появляется интерфейс tun0, с которого данные отправляются, но он ни чего не получает, сие видно из phpsysinfo и в cacti.

defaultroute указан сервера vpn который выдается при соединении.

в итоге ничего не пингуется и не открывается :(

подскажите плиз в чем пожет быть проблемка...

Добавлено: 2007-03-03 20:46:22
Dmitriy.A

Добавлено: 2007-03-03 21:00:38
Blacking
спасибо, буду разбираться...

Добавлено: 2007-03-03 21:13:36
Blacking
только там в конце темы написано, что про создание впн подключения это не в эту тему...
Да и при тех настройках подключение даже не поднимается...

Добавлено: 2007-03-03 23:43:21
kolesya
Коллеги, статью соображу в ближайшее время по VPN (на базе openVPN).
На своей шкуру убедился, OpenVPN рулит .... Неделя, потолок две :P

Добавлено: 2007-03-04 15:31:28
Гость
мой рабочий вариант, имеем ноут с сетевой картой RealTek 8139, локальную сеть со шлюзом IP-10.32.24.1, VPN_сервер (vpn.ustu, IP- 10.1.1.10)
1. # cat /etc/ppp/ppp.conf

default:
set log phase chat lcp ipcp ccp tun command
vpn:
set log Phase Warning Alert Error command
set device "!pptp 10.1.1.10 --nolaunchpppd"
disable ipv6cp
disable acfcomp
disable protocomp
set mtu max 1492
disable lqr
disable pred1 deflate deflate24 protocomp acfcomp shortseq vj
deny pred1 deflate deflate24 protocomp acfcomp shortseq vj
disable mppe
set timeout 0
set openmode passive
delete ALL
add default HISADDR
set timeout 0
set authname логин
set authkey пароль
2. # cat /etc/ppp/ppp.linkdown
vpn:
!bg /sbin/route delete HISADDR
!bg /sbin/route change default 10.32.24.1 # шлюз
3. # cat /etc/ppp/ppp.linkup
vpn:
!bg /sbin/route delete HISADDR
!bg /sbin/route add HISADDR 10.32.24.1 # шлюз
!bg /sbin/route change default HISADDR
!bg /sbin/route add -host 10.1.1.10 10.32.24.1 # маршрут до VPN сервера, где
# /sbin/route add -host IP_address_of_VPN_server gateway,
# IP_address_of_VPN_server: 10.1.1.10
# gateway: 10.32.24.1
# IP_address_VPN сервера можно определить пингом в моем
# случае vpn.ustu
4. в файле /etc/rc.conf:
firewall_enable="YES"
firewall_type="OPEN"
gateway_enable="YES"
dhcp_enable="YES"
ppp_enable="YES"
ppp_mode="ddial"
ppp_profile="pptp"
ifconfig_rl0="DHCP" # rl0 для интерфейса моей сетевой карты
network_interfaces="lo0 rl0 ng0"
5. в /boot/loader.conf дабавляю строку
if_rl_load="YES" # для сетевой карты RealTek 8139
6. ну и прописал в /etc/resolv.conf DNS серверы, хотя можно просто указать в ppp.conf
строчку enable dns.
7. Перегружаемся , командой # ifconfig наблюдаем

# ifconfig
rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=8<VLAN_MTU>
inet6 fe80::20a:e4ff:feea:7816%rl0 prefixlen 64 scopeid 0x1
inet 10.32.24.42 netmask 0xffffff00 broadcast 10.32.24.255
ether 00:0a:e4:ea:78:16
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
inet 127.0.0.1 netmask 0xff000000
tun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
Opened by PID 216
что карточка работает, я в локальной сети.
8. подключаемся к интернету командой ppp -ddial vpn:
# ppp -ddial vpn
Working in ddial mode
Using interface: tun1
поднялся интерфейс
9. опять ifconfig ,
# ifconfig
rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=8<VLAN_MTU>
inet6 fe80::20a:e4ff:feea:7816%rl0 prefixlen 64 scopeid 0x1
inet 10.32.24.42 netmask 0xffffff00 broadcast 10.32.24.255
ether 00:0a:e4:ea:78:16
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
inet 127.0.0.1 netmask 0xff000000
tun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
Opened by PID 216
tun1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1460
inet 10.236.1.151 --> 10.128.0.0 netmask 0xffffffff
Opened by PID 834
все отлично.
10. # ping mail.ru
PING mail.ru (194.67.57.26): 56 data bytes
64 bytes from 194.67.57.26: icmp_seq=0 ttl=111 time=73.424 ms
64 bytes from 194.67.57.26: icmp_seq=1 ttl=111 time=76.531 ms
^C
--- mail.ru ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
11. Отключаю интеренет, прибивая процесс PID 834 (ppp -ddial vpn) , командой
# kill 834
Вроде ниче не забыл :)

Добавлено: 2007-03-04 15:37:44
err0r
P.S. хм, странно, вроде логинился, почему гость, я errOr который мимо проходил :)

Добавлено: 2007-03-04 16:49:03
Alex Keda
до 10 сообщений, мимо проходили все, в том числе и я :))

Re: VPN

Добавлено: 2007-03-05 13:14:09
err0r
Blacking писал(а):Необходимо подключиться во FreeBSD к VPN, делается сие при помощи pptp

при выполнении команды:

Код: Выделить всё

# pptp vpn.server.ru vpn
появляется интерфейс tun0, с которого данные отправляются, но он ни чего не получает
покажи ifconfig и еще попробуй принудительно после подключения задать маршрут командой:
# !bg /sbin/route add -host IP_vpn_сервер IP_шлюз

Re: VPN

Добавлено: 2007-03-06 4:08:27
Blacking
err0r писал(а):
Blacking писал(а):Необходимо подключиться во FreeBSD к VPN, делается сие при помощи pptp

при выполнении команды:

Код: Выделить всё

# pptp vpn.server.ru vpn
появляется интерфейс tun0, с которого данные отправляются, но он ни чего не получает
покажи ifconfig и еще попробуй принудительно после подключения задать маршрут командой:
# !bg /sbin/route add -host IP_vpn_сервер IP_шлюз

Код: Выделить всё

rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=8<VLAN_MTU>
        inet 88.204.58.39 netmask 0xffffff00 broadcast 88.204.58.255
        ether 00:50:bf:12:0c:54
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
fxp0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=8<VLAN_MTU>
        inet 192.168.0.1 netmask 0xffffff00 broadcast 192.168.0.255
        ether 08:00:09:dc:5a:4d
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST,NEEDSGIANT> mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
        inet 127.0.0.1 netmask 0xff000000
tun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
        inet 88.204.49.121 --> 88.204.49.192 netmask 0xffffff00
        Opened by PID 20492
route add -host IP_vpn_сервер IP_шлюз ltделал...не могает..

Re: VPN

Добавлено: 2007-03-06 8:54:13
Alex Keda
Blacking писал(а): ltделал...
xneur?
У меня такой же глюк...

Добавлено: 2007-03-07 15:44:59
err0r
Blacking

Проверь с отключенным интерфейсом fxp0.

Добавлено: 2007-03-07 16:14:54
err0r
и правила ipfw смотреть нужно, видел топик на похожую тему vpn с маршрутизацией во внутреннюю сеть, найду кину ссылкой.

Добавлено: 2007-03-09 20:00:31
err0r
http://homenet.corbina.net/index.php?showtopic=94658
"настройка mpd и nat на два интерфейса"

Добавлено: 2007-03-12 9:24:31
Blacking
спасибо за ссылку...
настроил я pptp
все подключается но при пинговании чего либо выдается сообщение:

Код: Выделить всё

ping: sendto: No buffer space available 
в ядре maxusers 32 стоит...

Добавлено: 2007-03-12 9:25:16
Alex Keda
sysctl?

Добавлено: 2007-03-12 10:03:21
Blacking
в нем пусто... какие опции надо туда поставить и с какими значениями?