Страница 1 из 2

И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2007-08-21 15:47:43
set
Как уже сказал снова проблемы с описанной в статье связкой Apache2 + PHP5 + fast-cgi

Как говорили предидущие ораторы в своих топиках "все делал по статье с незначительными изминениями под себя"
Таже с нуля поставленная фря 6.2 с предварительно обновленными портами:
на всякийслучай:

Код: Выделить всё

apache-2.0.59       Version 2 of Apache web server with prefork MPM.
mod_fastcgi-2.4.2_1 A fast-cgi module for Apache
mysql-client-4.1.22 Multithreaded SQL database (client)
mysql-server-4.1.22 Multithreaded SQL database (server)
php5-5.2.3_1        PHP Scripting Language (Apache Module and CLI)
php5-bz2-5.2.3_1    The bz2 shared extension for php
php5-calendar-5.2.3_1 The calendar shared extension for php
php5-ctype-5.2.3_1  The ctype shared extension for php
php5-curl-5.2.3_1   The curl shared extension for php
php5-dom-5.2.3_1    The dom shared extension for php
php5-ftp-5.2.3_1    The ftp shared extension for php
php5-gd-5.2.3_1     The gd shared extension for php
php5-iconv-5.2.3_1  The iconv shared extension for php
php5-mssql-5.2.3_1  The mssql shared extension for php
php5-mysql-5.2.3_1  The mysql shared extension for php
php5-mysqli-5.2.3_1 The mysqli shared extension for php
php5-pcre-5.2.3_1   The pcre shared extension for php
php5-simplexml-5.2.3_1 The simplexml shared extension for php
php5-spl-5.2.3_1    The spl shared extension for php
Apache то работает но вот када дело доходит до php скрипта... броузер после непродолжительного раздумья выдает:

Код: Выделить всё

Error 500: Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
и примерно такое пишет в логах:

Код: Выделить всё

[Wed Aug 22 01:39:03 2007] [error] [client 82.137.152.32] FastCGI: comm with (dynamic) server "/home/srv/www/cgi-bin/php.sh"
aborted: (first read) idle timeout (400 sec), referer: http://my.homenet.ru/
[Wed Aug 22 01:39:03 2007] [error] [client 82.137.152.32] FastCGI: incomplete headers (0 bytes) received from server "/home/srv/www/cgi-bin/php.sh",
referer: http://my.homenet.ru/

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2007-08-21 15:54:29
set
все пути проверил... права тоже
Буду признателен за любой конструктивный совет или подсказку

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2007-08-21 16:45:07
set
все... разобрался сам... не работал suexec изза неправильно прописанного docroot...

PS:
автор МОЛОДЦА... все статьи замечательные... respect

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 12:26:13
MAKSA
Привет всем! :"":
Та же проблема.... :cry:
httpd-error.log

Код: Выделить всё

[error] [client 10.9.5.18] FastCGI: incomplete headers (0 bytes) received from server "/usr/home/ito/www/cgi-bin/php.sh  referer: http://ito11.domain.ru/customer/module/review_tt.php
Даже не знаю куда копать..... :cz2:

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 12:30:31
zingel
сохашные крипты

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 12:31:51
MAKSA
извиняюсь,а чтобы это значило ? :oops:

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 12:36:04
MAKSA
причем...что большенство обычных скриптов запускаться . ....

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 12:36:26
zingel
что в скрипте и логи апача, из профайла сохашного убейте заодно все алиасы, проверьте нету ли на /bin/sh самлинков

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 12:42:53
MAKSA
проверил...но что-то безрезультатно.....(

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 12:52:32
MAKSA

Код: Выделить всё

[Fri Jul 18 18:39:37 2008] [warn] FastCGI: (dynamic) server "/usr/home/ito/www/cgi-bin/php.sh" (uid 1003, gid 1003) started (pid 99514)

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 12:53:09
Alex Keda
это нормально

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 13:15:55
MAKSA
а какие ещё могут быть причины необработки скриптов и ошибки 500?...все было поставленное с нуля и настроенно как в статье...
А значения в make.conf надо менять ?
SUEXEC_DOCROOT= /
SUEXEC_USERDIR= www

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 13:23:52
Alex Keda
ну,вообще стоило бы =)
=======
ты эта, suexec.log глянь...
а вообще - все 500 ошибки подробно протоклируются сервером.
ищи.

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 13:30:25
MAKSA
вот лог:

Код: Выделить всё

ito11# tail /var/log/httpd/suexec.log
[2008-07-18 14:06:55]: uid: (ito/ito) gid: (1004/1004) cmd: php.sh
[2008-07-18 14:07:04]: uid: (ito/ito) gid: (1004/1004) cmd: php.sh
[2008-07-18 14:07:40]: uid: (ito/ito) gid: (1004/1004) cmd: php.sh
[2008-07-18 14:08:09]: uid: (ito/ito) gid: (1004/1004) cmd: php.sh
[2008-07-18 14:08:28]: uid: (ito/ito) gid: (1004/1004) cmd: php.sh
[2008-07-18 14:08:34]: uid: (ito/ito) gid: (1004/1004) cmd: php.sh
[2008-07-18 14:08:54]: uid: (ito/ito) gid: (1004/1004) cmd: php.sh
[2008-07-18 14:08:59]: uid: (ito/ito) gid: (1004/1004) cmd: php.sh
[2008-07-18 14:09:06]: uid: (ito/ito) gid: (1004/1004) cmd: php.sh
[2008-07-18 14:09:11]: uid: (ito/ito) gid: (1004/1004) cmd: php.sh
в логах апача единственные ошибки....которые я указал выше!
И где ошибки которые более подробно протоколируются сервером,кроме как логи апатча?

А make.conf ,должен вот так выглядеть,если брать структуру такую же как у вас в статье??

Код: Выделить всё

# Корневая директория suExec
SUEXEC_DOCROOT=         /usr/home/*/data/
# Cубдиректория пользователя
SUEXEC_USERDIR=        www

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 13:32:16
Alex Keda
ищщи.
должны быть ещё

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 13:58:29
MAKSA
А поточнее нельзя,уже все перерыл ?
пожалуйста :unknown:

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 14:00:27
Alex Keda
я вличку вроде тебе ответил уже.
=======
логи виртхосчов смотри и лог самого апача

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 14:07:49
MAKSA
лог самого апача:

Код: Выделить всё

ito11# tail /var/log/httpd-error.log

[Fri Jul 18 14:30:17 2008] [warn] FastCGI: restarting old server "/usr/home/ito/www/cgi-bin/php.sh" processes, newer version found
[Fri Jul 18 14:30:18 2008] [warn] FastCGI: (dynamic) server "/usr/home/ito/www/cgi-bin/php.sh" (pid 132) terminated by calling exit with status '0'
[Fri Jul 18 14:30:21 2008] [warn] FastCGI: (dynamic) server "/usr/home/ito/www/cgi-bin/php.sh" (uid 1004, gid 1004) restarted (pid 146)
и лог виртуального хоста:

Код: Выделить всё

ito11# tail /var/log/httpd/httpd-error.log

[Fri Jul 18 14:30:22 2008] [error] [client 10.9.5.169] FastCGI: incomplete headers (0 bytes) received from server "/usr/home/ito/www/cgi-bin/php.sh", referer: http://ito11.domain.ru/
[Fri Jul 18 14:30:23 2008] [error] [client 10.9.5.169] FastCGI: incomplete headers (0 bytes) received from server "/usr/home/ito/www/cgi-bin/php.sh", referer: http://ito11.domain.ru/

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 20:52:28
zingel
конфиги виртуальных хостов кривые, скорее всего, проблема с uid/gid

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 21:04:15
MAKSA

Код: Выделить всё

<VirtualHost *:80>
        ServerAdmin     admin@myomain.ru
#       AliasMatch      ^/~([^/]+)(/.*)*        /usr/home/$1/data$2
        DocumentRoot    /usr/home/ito/www/data
        ServerName      ito11.mydomain.ru
        SuexecUserGroup ito   ito
        Alias           /php-fcgi/      /usr/home/ito/www/cgi-bin/
        CustomLog       /var/log/httpd/httpd-access.log common
        ErrorLog        /var/log/httpd/httpd-error.log
</VirtualHost>
Все делалось,как в статье
А в чем проблема uid -gid может заключаться?

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-18 21:13:04
zingel

Код: Выделить всё

       /* kill old server(s) */
                    for (i = 0; i < dynamicMaxClassProcs; i++) 
                    {
                        if (s->procs[i].pid > 0 
                            && stbuf.st_mtime > s->procs[i].start_time) 
                        {
                            fcgi_kill(&s->procs[i], SIGTERM);
                            do_restart++;
                        }
                    }

                    if (do_restart)
                    {
                        ap_log_error(FCGI_LOG_WARN_NOERRNO, 
                            fcgi_apache_main_server, "FastCGI: restarting "
                            "old server \"%s\" processes, newer version "
                            "found", app_path);
                    }
                }

судя по-всему в SuexecUserGroup....вообще народ советует обновится, обновить апачь...

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-19 1:04:56
MAKSA
обновил все....ататч,пхп,фаст-сги.
Вот почему такой преметивный скипт у него вызывает ошибку 500? :(

Код: Выделить всё

<?php
session_start();
$connect = OCILogon("ada", "ada", "BASE") or die ("fuck" );
?>
поддержка оракла включена......

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-19 1:35:35
CTOPMbI4
При запуске apache2 ругается
sh apache2 start

Код: Выделить всё

vidcontrol: getting active vty: Inappropriate ioctl for device
Performing sanity check on apache2 configuration:
В чем косяк? :smile:

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-19 1:56:40
CTOPMbI4
теперь просто не запускается ошибок не выдает. :cz2:

Re: И снова проблемы с Apache2 + php5(fastcgi)

Добавлено: 2008-07-19 2:01:50
zingel
что говорит

Код: Выделить всё

apachectl configtest