Страница 1 из 1

Perl 5-й ветки на FreeBSD 4.2

Добавлено: 2006-06-17 14:17:26
BAYES
:? Не могу установить perl 5.8, да и вообще perl 5 ветки на FreeBSD 4.2, из портов не получается (perl-5.00502 is forbidden: perl is in system.), хотел обновить порты(через sysinstall пробовал) нет 4.2 в поддержки. Руками ставлю perl-5.8.8.tar.gz (./Configure make make test make install) на make test ошибки.

Вопрос собственно:
Реально ли поставить 5.8.х на FreeBSD 4.2, или придется обновлять систему до 4.11 или выше - которые поддерживают и есть новые порты.

Добавлено: 2006-06-17 14:20:15
Alex Keda
лучше обновись до 4.11...
я думаю, можно исейчас поставить - но плясать придётся...

Добавлено: 2006-06-17 19:01:02
BAYES
Это и понятно, что можно поставить 4.11, но кажется к 4.2 была портирована 5.0.хх ветка, но не могу ее никак найти.
Хотелось именно найти порт, а то руками не получается поставить. Пробовал искать установочный диск с 4.2 и оттуда взять порт, тоже проблема найти.

Добавлено: 2006-06-17 19:34:01
Alex Keda
4.11 не ставить надо, а обновить систему.
все программы останутся.

Добавлено: 2006-06-17 21:16:28
BAYES
Да понятно все, что и как обновляют.
Т.е. получается, что проще будет обновить систему, чем плясать над установкой?

Добавлено: 2006-06-17 21:19:47
Alex Keda
да дело-то даже и не в перле же.
сёдня перл, завтра ещё что-то надо будет....
лучше обновиться и всё...