Страница 1 из 1

FreeBSD 6.3 не стартует APACHE + PHP5.2.5

Добавлено: 2008-02-10 12:04:06
k_i_r_y
поставил из портов
пишет start Apache а в процессах нет
если закоментить в конфиге апача lib5php.so то все ок
сам модуль лежит на месте

Re: FreeBSD 6.3 не стартует APACHE + PHP5.2.5

Добавлено: 2008-02-10 12:57:21
f_andrey
а apache_enable="YES" в rc.conf положил?
Насчет точного синтаксиса что добавлять уточни в pkg_message, зависит от версии апача, и заодно на перед прочти pkg_message для ПХП небось тоже что нибудь забыл :)

Re: FreeBSD 6.3 не стартует APACHE + PHP5.2.5

Добавлено: 2008-02-10 14:05:14
k_i_r_y
apache_enable положил
решилось обновлением портов ну и запуск с помощью
apachectl start

Re: FreeBSD 6.3 не стартует APACHE + PHP5.2.5

Добавлено: 2008-11-11 15:17:10
vosiley
Фтопку passphrase - и тогда взлетает

Re: FreeBSD 6.3 не стартует APACHE + PHP5.2.5

Добавлено: 2008-11-11 15:50:00
Yam
k_i_r_y писал(а):apache_enable положил
решилось обновлением портов ну и запуск с помощью
apachectl start
Лучше причину найти, а не костыли лепить. какой апач ставили?

Re: FreeBSD 6.3 не стартует APACHE + PHP5.2.5

Добавлено: 2009-01-05 19:18:11
server801
то же самое ,но только с apache22
не грузится php
строчку с с модулем расскоментировал,конфиг штатный,расскоментирована строчка

Код: Выделить всё

# Virtual hosts
Include etc/apache22/extra/httpd-vhosts.conf
httpd.vhosts.conf

Код: Выделить всё

VirtualHost *:80>
    ServerAdmin freebsd-net.vfose.ru
    DocumentRoot "/usr/local/www/freebsd-net/"
    ServerName freebsd-net.vfose.ru
    ServerAlias www.freebsd-net.vfose.ru
    Options Indexes MultiViews
    ErrorLog "/var/log/freebsd-net-error_log"
    CustomLog "/var/log/freebsd-net-access_log" common
 </VirtualHost>


<VirtualHost *:80>
    ServerAdmin nodupdate.vfose.ru
    DocumentRoot "/usr/local/www/nodupdate"
    ServerName nodupdate.vfose.ru
    ServerAlias www.nodupdate.vfose.ru
    Options Indexes MultiViews
    ErrorLog "/var/log/nod-error_log"
    CustomLog "/var/log/nod-access_log" common
 </VirtualHost>

<VirtualHost *:80>
    ServerAdmin serveroot.vfose.ru
    DocumentRoot "/usr/local/www/freebsd/data"
    ServerName serveroot.vfose.ru
    ServerAlias www.serveroot.vfose.ru
    Options Indexes MultiViews
    ErrorLog "/var/log/serveroot.vfose.ru-error_log"
    CustomLog "/var/log/serveroot.vfose.ru-access_log" common
</VirtualHost >
как подгрузить модуль чтоб работал в связке с апачем?
сильно не пинайте только :smile:

Re: FreeBSD 6.3 не стартует APACHE + PHP5.2.5

Добавлено: 2009-01-05 21:50:14
zg
server801 писал(а):как подгрузить модуль чтоб работал в связке с апачем?
пхп сам прописывает через apxs , если конечно опция была указана при установке пхп

и не забудь

Код: Выделить всё

    <IfModule mod_php5.c>
        AddType application/x-httpd-php .php
        DirectoryIndex index.php index.html index.htm
    </IfModule>

Re: FreeBSD 6.3 не стартует APACHE + PHP5.2.5

Добавлено: 2009-01-06 1:06:29
server801
спасибо!