Страница 1 из 1

vsftpd+mysql Настройка

Добавлено: 2008-04-22 14:14:02
XliN
Сделал как написано в инструкции на этом сайте. Все сделал как написано, но появились проблемы.
1. vsftpd не стартует без параметра в конфиге background=YES
2. И в базе создал пользователя test с поролем 123456. Под этим пользователем не хочет логиниться. Проше говоря, создавай, не создавай пользователей. Никто не входит.

Мускул ругается так: vsftpd: pam_mysql - mysql error (Access denied for user 'vsftpd'@'localhost' (using password: YES))

P.S. Да, вот что еще. select * from accounts; показывает что пороль зашифрован. Вместо моего 123456, написано куча цифр и букв. Так и должно быть?
P.S.S. в ipfw ничего не писал, так как там я порты не закрывал.
А если всетаки надо, то подскажите как прописать.

Re: vsftpd+mysql Настройка

Добавлено: 2008-04-22 23:34:40
Alex Keda
параметры для БД в конфиге неверные

Re: vsftpd+mysql Настройка

Добавлено: 2008-04-23 8:20:58
sktv
А подробнее можно? У меня база мускула без пороля. Т.е. mysql -u root не просит пароль.

Re: vsftpd+mysql Настройка

Добавлено: 2008-04-28 23:56:13
Alex Keda
sktv писал(а):А подробнее можно? У меня база мускула без пороля. Т.е. mysql -u root не просит пароль.
и что?

Re: vsftpd+mysql Настройка

Добавлено: 2008-11-28 16:42:22
JaNet
ответ в

Код: Выделить всё

cat /etc/pam.d/vsftpd