Страница 1 из 4
Apache PHP MySql
Добавлено: 2008-05-04 12:05:51
stup
Ногами не бейте, но поюзав поиск нашел упоминание о моей проблеме весьма расплывчатое. Делал все по этой статье (
http://www.lissyara.su/?id=1360) При попытке запустить Апача ругается так:
- Performing sanity check on apache22 configuration:
Syntax error on line 466 of /usr/local/etc/apache22/httpd.conf:
FastCgiWrapper: "/usr/local/sbin/suexec" execute access for server (uid 80, gid 80) failed: stat(/usr/local/sbin/suexec) failed: No such file or directory
Starting apache22.
Syntax error on line 466 of /usr/local/etc/apache22/httpd.conf:
FastCgiWrapper: "/usr/local/sbin/suexec" execute access for server (uid 80, gid 80) failed: stat(/usr/local/sbin/suexec) failed: No such file or directory
Что с этим нужно делать? Файла там действительно нет. В чем ошибка?
Re: Apache PHP MySql
Добавлено: 2008-05-04 12:13:46
stup
Кажется сам понял - Апач был собран без поддержки этого модуля, попробую пересобрать с поддержкой.
Re: Apache PHP MySql
Добавлено: 2008-05-04 15:18:19
stup
Появилась проблема не могу разобраться в чем дело. Сервер в ошибках пишит следущее
Код: Выделить всё
[Sun May 04 16:05:53 2008] [notice] Digest: generating secret for digest authent
ication ...
[Sun May 04 16:05:53 2008] [notice] Digest: done
[Sun May 04 16:05:53 2008] [notice] FastCGI: wrapper mechanism enabled (wrapper:
/usr/local/sbin/suexec)
[Sun May 04 16:05:53 2008] [notice] FastCGI: process manager initialized (pid 12
64)
[Sun May 04 16:05:53 2008] [notice] Apache/2.2.8 (FreeBSD) DAV/2 mod_fastcgi/2.4
.6 configured -- resuming normal operations
[Sun May 04 16:06:32 2008] [warn] FastCGI: (dynamic) server "/usr/home/gella/www
/cgi-bin/php.sh" (uid 1003, gid 1003) started (pid 1271)
suexec failure: could not open log file
fopen: No such file or directory
[Sun May 04 16:06:32 2008] [warn] FastCGI: (dynamic) server "/usr/home/gella/www
/cgi-bin/php.sh" (pid 1271) terminated by calling exit with status '1'
[Sun May 04 16:06:37 2008] [warn] FastCGI: (dynamic) server "/usr/home/gella/www
/cgi-bin/php.sh" (uid 1003, gid 1003) restarted (pid 1273)
suexec failure: could not open log file
fopen: No such file or directory
[Sun May 04 16:06:37 2008] [warn] FastCGI: (dynamic) server "/usr/home/gella/www
/cgi-bin/php.sh" (pid 1273) terminated by calling exit with status '1'
[Sun May 04 16:06:42 2008] [warn] FastCGI: (dynamic) server "/usr/home/gella/www
/cgi-bin/php.sh" (uid 1003, gid 1003) restarted (pid 1275)
[Sun May 04 16:12:08 2008] [warn] FastCGI: (dynamic) server "/usr/home/gella/www
/cgi-bin/php.sh" has failed to remain running for 30 seconds given 3 attempts, i
ts restart interval has been backed off to 600 seconds
[Sun May 04 16:12:11 2008] [warn] FastCGI: (dynamic) server "/usr/home/gella/www
/cgi-bin/php.sh" has failed to remain running for 30 seconds given 3 attempts, i
ts restart interval has been backed off to 600 seconds
[Sun May 04 16:12:11 2008] [warn] FastCGI: (dynamic) server "/usr/home/gella/www
/cgi-bin/php.sh" has failed to remain running for 30 seconds given 3 attempts, i
ts restart interval has been backed off to 600 seconds
Что с этим делать? Если убираю из конфига упоминание о виртуальном хосте, все пашет по дефолту изменив только ServerName. Если включаю виртуальный хост, то такие вот сообщения.
Re: Apache PHP MySql
Добавлено: 2008-05-04 15:28:43
Alex Keda
сообщения нормально оформляйте
Re: Apache PHP MySql
Добавлено: 2008-05-04 15:35:58
stup
lissyara писал(а):сообщения нормально оформляйте
Переоформлю, подскажите, что именно не так.
Re: Apache PHP MySql
Добавлено: 2008-05-04 15:44:40
Alex Keda
директория для лога суэкзека есть?
Re: Apache PHP MySql
Добавлено: 2008-05-04 15:49:53
stup
Видимо нет, раз ругается. Где она должна быть? По статье в конфиге я не увидел этой опции, или она сама должна создаться?
Re: Apache PHP MySql
Добавлено: 2008-05-04 20:24:29
stup
Народ! Может все-таки есть у кого какие идеи? Верю, что с таким никто не сталкивался, но не бывает же чудес! Думаю, что по статье далеко не один я ставил все это дело. Подскажите, что за лог для суэкзека должен быть? И где именно он должен быть? Если дело конечно только в этом.
Re: Apache PHP MySql
Добавлено: 2008-05-04 20:47:33
ProFTPD
набери в гугле эту строку
has failed to remain running for 30 seconds given 3 attempts, i
ts restart interval has been backed off to 600 seconds
у меня наприер сейчас белый экран и никуя нету
хотя пхп работает phpinfo(); я только переставил бля
Re: Apache PHP MySql
Добавлено: 2008-05-04 21:11:30
Alex Keda
ищи...
кто ищет - тот обрящет

там причин - немного совсем...
Re: Apache PHP MySql
Добавлено: 2008-05-04 21:27:49
stup
lissyara писал(а):ищи...
кто ищет - тот обрящет

там причин - немного совсем...
Нашел вот подобную тему
http://forum.lissyara.su/viewtopic.php?f=8&p=62813, там в последнем посте было написано
[2008-04-02 14:46:12]: uid: (vhost/vhost) gid: (10031/10031) cmd: calc.php
[2008-04-02 14:46:12]: (8)Exec format error: exec failed (calc.php)
, далее последовал ответ
в поиск по форуму с этой строкой про экзек.
был уже такой вопрос недавно.
и решение было
. Искал, но ничего не нашел из тех 2-ух строк.
Re: Apache PHP MySql
Добавлено: 2008-05-04 22:03:18
Alex Keda
suexec failure: could not open log file
fopen: No such file or directory
у тебя чётко написана причина.
причём на что именно он ругается - я указал.
думай.
Re: Apache PHP MySql
Добавлено: 2008-05-04 22:16:33
stup
Я слабо себе все это представляю, на работе завтра конечно гляну. Но никак не могу вразуметь, где вобще у суэкзека должен быть этот лог.
Re: Apache PHP MySql
Добавлено: 2008-05-04 22:26:42
Alex Keda
Код: Выделить всё
hosting$ ll /var/log/httpd/suexec_log
-rw-r--r-- 1 root wheel 7,1M 4 май 23:25 /var/log/httpd/suexec_log
hosting$
например.
Re: Apache PHP MySql
Добавлено: 2008-05-05 10:56:42
stup
Вот все, что есть в
/var/log
Код: Выделить всё
auth.log lastlog maillog.6.bz2 sendmail.st.1
cron lpd-errs messages setuid.today
cron.0.bz2 maillog mount.today setuid.yesterday
cron.1.bz2 maillog.0.bz2 mysql.log slip.log
debug.log maillog.1.bz2 pf.today userlog
dmesg.today maillog.2.bz2 ppp.log wtmp
dmesg.yesterday maillog.3.bz2 security wtmp.0
httpd-access.log maillog.4.bz2 sendmail.st xferlog
httpd-error.log maillog.5.bz2 sendmail.st.0
В настройках виртуального сервера тоже написано
Код: Выделить всё
<VirtualHost *:80>
ServerAdmin admin@my-domain.ru
DocumentRoot /usr/home/gella/www/data
ServerName host.gella
SuexecUserGroup gella gella
Alias /php-fcgi/ /usr/home/gella/www/cgi-bin/
CustomLog /var/log/httpd-access.log combined
ErrorLog /var/log/httpd-error.log
</VirtualHost>
Такого пути как
нет, но make.conf я рехтовал и дописывал туда
Код: Выделить всё
# Файл лога suExec
SUEXEC_LOGFILE= /var/log/httpd/suexec.log
Вот листинг файла make.conf
Код: Выделить всё
# Settings Apache and PHP
# default PHP version
DEFAULT_PHP_VER=5
PORTSDIR?= /usr/ports
# apache2
.if ${.CURDIR} == ${PORTSDIR}/www/apache22
# SSL - кому надо - включат - мне на этой машине не нужен
WITHOUT_SSL= YES
# Включение поддержки suExec
WITH_SUEXEC= YES
# Корневая директория suExec
SUEXEC_DOCROOT= /
# Cубдиректория пользователя
SUEXEC_USERDIR= www
# Файл лога suExec
SUEXEC_LOGFILE= /var/log/httpd/suexec.log
.endif
Т.е. при сборке он по идее должен брать все с этого файла, но он не берет настройки из этого файла. Так как по логике он должен был собраться с самого начала с суэкзеком, пока я ему это явно не указал через make config собирался он без этого модуля.
Re: Apache PHP MySql
Добавлено: 2008-05-05 15:31:36
ProFTP
выполни файл есть? в чем проблема?
Re: Apache PHP MySql
Добавлено: 2008-05-05 22:06:09
stup
ProFTP писал(а):
выполни файл есть? в чем проблема?
Проблема в том, что не то, что файла, а даже директории такой нет как
. Я все это выше писал и выкладывал листинг в том числе и директории
полностью.
Re: Apache PHP MySql
Добавлено: 2008-05-05 22:42:27
Alex Keda
песдец...
=========
дамы, я извиняюсь...
нет слов...
Re: Apache PHP MySql
Добавлено: 2008-05-05 23:18:10
ProFTP
создай каталог
создай файл
может права нужны будут
в крайнем случае
Re: Apache PHP MySql
Добавлено: 2008-05-06 15:01:10
stup
ProFTP писал(а):создай каталог
создай файл
может права нужны будут
в крайнем случае
Спасибо большое, все это помогло. Но никак не могу вразуметь почему все это не было создано из make.conf если руководствоваться только статьей, то будет то же самое, на что попал я. И уж никак само все это не сделается.
Re: Apache PHP MySql
Добавлено: 2008-05-13 14:28:39
guinness
Помогите начинающему....... У меня вот такая вот проблемка...помогите. кажется мне что у меня тоже без суекзека собрался.
пробывал make install WITH_APACHE_SUEXEC=yes. непомогло.
Пишет:
//>/usr/local/etc/rc.d/apache2.sh start
Starting apache2.
Syntax error on line 1120 of /usr/local/etc/apache2/httpd.conf:
Invalid command 'SuexecUserGroup', perhaps mis-spelled or defined by a module not included in the server configuration
Re: Apache PHP MySql
Добавлено: 2008-05-13 22:43:52
stup
Пересобери с поддержкой. Просто делаешь make config (правда я перед этим делал make uninstall и убивал директорию work). Далее выбираешь там опцию про суэкзек. Ну и собираешь с ним. На все те вещи которые описаны в статье про апач в статье в файле make.conf он плюет. Впрочем об этом говорит последний комментарий в статье.
Re: Apache PHP MySql
Добавлено: 2008-05-14 11:23:15
guinness
чет не получается.
/usr/ports/www/apache20/>make config
===> No options to configure
"правда я перед этим делал make uninstall и убивал директорию work"... зделал make deinstall clean. а вот насчет директории work не понял... где она должна быть. Мож доку какуюто посоветуйте или статью.......
Подскажите пожалуйста ламеру.
Re: Apache PHP MySql
Добавлено: 2008-05-14 21:47:44
stup
guinness писал(а):чет не получается.
/usr/ports/www/apache20/>make config
===> No options to configure
зделал make deinstall clean. а вот насчет директории work не понял...
Верно - перепутал именно make deinstall, но без clean. А work создается в /usr/ports/www/apache20/ во время инсталляции. Я clean никогда не делаю. Кому-то удобно - мне нет. Кроме всего я делал все с apache22 точнее /usr/ports/www/apache22/. Видимо апач20 может собраться с опциями указанными в /etc/make.conf, а апач22 не может. Но то, что в апач22 отрабатывает make config - это точно. Мои точные команды таковы без директории work:
Re: Apache PHP MySql
Добавлено: 2008-05-15 15:18:28
guinness
Спасибо.......пробую.