Страница 1 из 1

nss_lpap

Добавлено: 2008-05-30 8:51:45
f0s
Есть три сервера:

fileserver.artpaint (192.168.10.6)
router.artpaint (192.168.10.7)
mail.artpaint (192.168.10.8) на нем стоит openldap-server и PDC

e fileserver && mail все ок, хотя не всегда, но бывает у fileserver не может найти лдап сервер, типа такого:

Код: Выделить всё

fileserver.artpaint login failures:
May 23 11:12:10 fileserver sshd[62872]: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 23 11:12:13 fileserver su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
но в целом ок, а вот router все время каждый лень одно и то же выдает:

Код: Выделить всё

router.artpaint login failures:
May 28 00:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 01:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 02:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 03:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 04:02:01 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 05:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 06:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 07:02:01 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 08:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 09:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 10:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 11:02:01 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 12:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 13:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 14:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 15:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 16:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 17:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 18:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 19:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 20:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 21:02:01 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 22:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
May 28 23:02:00 router su: nss_ldap: failed to bind to LDAP server ldap://192.168.10.8: Can't contact LDAP server
то есть каждый час у него какие-то проблемы... причем так вроде все работает. даже не знаю, куда еще сомтреть

Re: nss_lpap

Добавлено: 2008-05-30 9:40:27
Lehan
А никуда. Больше года бились с аналогичной проблемой. Перенесли все на линух - там без проблем. Пришли к выводу, что это из-за кривой реализации nss_ldap во фре.

Re: nss_lpap

Добавлено: 2008-05-30 9:43:42
Alex Keda
хм... может из-за крвисти рук того кто писал этот нсслдап - он же из портов вроде =)

Re: nss_lpap

Добавлено: 2008-05-30 10:14:09
Lehan
Однако-ж на линухе тот же nss_ldap работает без таких вот проблем. Я не агитирую в пользу линуха, просто такие вот моменты довольно часто встречаются на практике.

PS: В конечном итоге отказались и от линуха и поставили windows server 2008 в качестве AD и PDC :)

Re: nss_lpap

Добавлено: 2008-05-30 10:15:50
manefesto
Lehan писал(а):Однако-ж на линухе тот же nss_ldap работает без таких вот проблем. Я не агитирую в пользу линуха, просто такие вот моменты довольно часто встречаются на практике.

PS: В конечном итоге отказались и от линуха и поставили windows server 2008 в качестве AD и PDC :)
ниасилили....фе....