Страница 1 из 1

Postfixadmin

Добавлено: 2008-06-02 19:31:14
SCREEN
Здрасте.
При попытке посавить postfixadmin возникает вот такя ошибка в чем может быть трабла , подскажите пожаслта.
Связка стаит apache-1.3.37_1 +mysql--5.0.27+php5-5.1.6_3

Код: Выделить всё

5-spl/work/php-5.2.6/ext/spl/php_spl.c  -fPIC -DPIC -o .libs/php_spl.o
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c: In function `PHP_GINIT_FUNCTION':
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:61: error: invalid type argument of `->'
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:62: error: invalid type argument of `->'
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:63: error: invalid type argument of `->'
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:64: error: invalid type argument of `->'
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c: At top level:
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:776: error: `spl' undeclared here (not in a function)
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:776: error: initializer element is not constant
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:776: error: (near initialization for `spl_module_entry.post_deactivate_func')
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:777: error: initializer element is not constant
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:777: error: (near initialization for `spl_module_entry.globals_id')
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:778: warning: initialization makes integer from pointer without a cast
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:779: warning: initialization makes integer from pointer without a cast
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:780: warning: excess elements in struct initializer
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:780: warning: (near initialization for `spl_module_entry')
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:780: warning: excess elements in struct initializer
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:780: warning: (near initialization for `spl_module_entry')
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:781: warning: excess elements in struct initializer
/usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl/php_spl.c:781: warning: (near initialization for `spl_module_entry')
*** Error code 1

Stop in /usr/ports/devel/php5-spl/work/php-5.2.6/ext/spl.
*** Error code 1

Stop in /usr/ports/devel/php5-spl.
*** Error code 1

Stop in /usr/ports/databases/php5-mysqli.
*** Error code 1

Stop in /usr/ports/mail/postfixadmin.
*** Error code 1

Stop in /usr/ports/mail/postfixadmin.

Re: Postfixadmin

Добавлено: 2008-06-02 20:29:39
SCREEN
Спасибо разобрался сам, глаза уже надо новые покупать :twisted:

Re: Postfixadmin

Добавлено: 2008-11-19 19:40:06
quest77
у меня такая же ошибка при попытке поставить phpmyadmin - в чем причина???