Страница 1 из 1

NTPd

Добавлено: 2008-06-09 4:21:55
Гость
Всем привет.
В первые столкнулся с такой проблемой.
На FreeBSD 7.0 Stable поднимаю ntpd:

Код: Выделить всё

cat /etc/ntp.conf
server 193.125.143.173
server 80.68.242.188
server 84.204.87.243
server 193.124.11.11

restrict 127.0.0.1
restrict pool.ntp.org noquery notrap
restrict 0.pool.ntp.org noquery notrap
restrict 1.pool.ntp.org noquery notrap
restrict 2.pool.ntp.org noquery notrap

restrict 192.168.хх.0 mask 255.255.254.0 nomodify notrap
restrict 192.168.уу.0 mask 255.255.255.0 nomodify notrap

driftfile /etc/ntp.drift

Код: Выделить всё

cat /etc/rc.conf | grep ntp
ntpd_enable="YES"              # Run ntpd Network Time Protocol (or NO).
ntpd_program="/usr/sbin/ntpd"   # path to ntpd, if you want a different one.
ntpd_config="/etc/ntp.conf"     # ntpd(8) configuration file
ntpd_sync_on_start="YES"      # Sync time on ntpd startup, even if offset is high
ntpd_flags="-p /var/run/ntpd.pid -f /etc/ntp.drift"

Код: Выделить всё

sockstat

root     ntpd       896   5  udp4   192.168.13.186:123    *:*
root     ntpd       896   6  udp4   192.168.15.100:123    *:*

Код: Выделить всё

 ntpq -p -n
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 193.125.143.173 193.125.143.172  3 u   62   64    1  111.101   -1.341   0.002
 80.68.242.188   193.124.11.11    3 u   61   64    1  111.389    5.339   0.002
 84.204.87.243   62.117.76.142    2 u   61   64    1  123.199    0.245   0.002
 193.124.11.11   62.117.76.141    2 u   62   64    1  120.399    2.304   0.002
Вроде всё хорошо, но когда пытаюсь зацепится телнетом на порт 123 он откидывает, вырубаю файервол и эффект тот же, даже с локалхоста не хочет на себя телнетится, в чём дело не пойму((

Код: Выделить всё

telnet localhost 123
Trying ::1...
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused
telnet: Unable to connect to remote host
Хотя как я показал сокстатом 123 порт слушается

Re: NTPd

Добавлено: 2008-06-09 7:32:16
abanamat
udp

Re: NTPd

Добавлено: 2008-06-09 23:02:02
zingel
Выполните, команду:

Код: Выделить всё

ntptrace -d

Re: NTPd

Добавлено: 2008-06-10 2:12:53
Гость
ntptrace -d
Unknown option: d
localhost: stratum 3, offset -0.000192, root distance 0.138833
84.204.87.243: timed out, nothing received
***Request timed out

Re: NTPd

Добавлено: 2008-06-10 2:18:03
zingel
А что говорит:

Код: Выделить всё

nc -vvu localhost 123

Re: NTPd

Добавлено: 2008-06-11 2:11:11
Гость
nc -vvu localhost 123
Connection to localhost 123 port [udp/ntp] succeeded!

Re: NTPd

Добавлено: 2008-06-11 8:22:59
zingel
значит дело в конфигах...

Re: NTPd

Добавлено: 2008-07-03 9:05:07
Гость
Люди ну это какойто непреодалимейший глюк, виндовая машина в заданное время синхронизирует часики с фряхи, а вот чтобы подцепится тем же телнетом на 123 порт, тут она меня откидывает и всё.

Re: NTPd

Добавлено: 2008-07-03 9:07:47
zingel

Код: Выделить всё

sockstat -4c -p 123

Re: NTPd

Добавлено: 2008-07-04 1:20:21
Гость
sockstat -4c -p 123
USER COMMAND PID FD PROTO LOCAL ADDRESS FOREIGN ADDRESS

Re: NTPd

Добавлено: 2008-07-04 9:53:48
sheva.sv
Что бы не создавать новую тему пиши сдесь, да простит меня создавший ее)
Пробую запустить NTPD с такими вот конфигами

Код: Выделить всё

[9:42]  /usr/home/sheva > cat /etc/rc.conf | grep ntp
ntpd_enable="YES"
ntpd_program="/usr/sbin/ntpd"
ntpd_config="/etc/ntp.conf"   
ntpd_sync_on_start="YES"      
ntpd_flags="-p /var/run/ntpd.pid -f /etc/ntp.drift"

[9:47]  /usr/home/sheva > cat /etc/ntp.conf
server 193.125.143.173
server 80.68.242.188
server 84.204.87.243
server 193.124.11.11

restrict 127.0.0.1
restrict pool.ntp.org noquery notrap
restrict 0.pool.ntp.org noquery notrap
restrict 1.pool.ntp.org noquery notrap
restrict 2.pool.ntp.org noquery notrap

restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap
restrict 192.168.0.0 mask 255.255.255.0 nomodify notrap

driftfile /etc/ntp.driftу из 

и вижу в логах такую ругань по поводу локального адреса 192.168.1.251 и сооьветственно не могу синхронизировать виндовую машину из локальной сети

Код: Выделить всё

 4 Jul 09:41:52 ntpd[25939]: ntpd exiting on signal 15
 4 Jul 09:42:53 ntpd[32154]: logging to file /var/log/ntp.log
 4 Jul 09:42:53 ntpd[32154]: ntpd 4.2.0-a Wed Apr 16 10:55:25 EEST 2008 (1)
 4 Jul 09:42:53 ntpd[32154]: precision = 1.676 usec
 4 Jul 09:42:53 ntpd[32154]: no IPv6 interfaces found
 4 Jul 09:42:53 ntpd[32154]: bind() fd 10, family 2, port 123, addr 192.168.1.251, in_classd=0 flags=0 fails: Address already in use
 4 Jul 09:42:53 ntpd[32154]: bind() fd 10, family 2, port 123, addr 192.168.1.251, in_classd=0 flags=0 fails: Address already in use
 4 Jul 09:42:53 ntpd[32154]: bind() fd 10, family 2, port 123, addr 192.168.1.251, in_classd=0 flags=0 fails: Address already in use
 4 Jul 09:42:53 ntpd[32154]: kernel time sync status 2040
 4 Jul 09:42:53 ntpd[32154]: frequency initialized 9.139 PPM from /etc/ntp.drift
 4 Jul 09:42:54 ntpd[32154]: frequency initialized 9.139 PPM from /etc/ntp.drift

Re: NTPd

Добавлено: 2008-07-04 12:49:44
zingel
не может забиндится на 123 порт, потому, что он уже занят, нужно убить, то что там уже висит и запустить ntpd заново

Re: NTPd

Добавлено: 2008-07-08 16:16:50
freeman
Гость писал(а):Люди ну это какойто непреодалимейший глюк, виндовая машина в заданное время синхронизирует часики с фряхи, а вот чтобы подцепится тем же телнетом на 123 порт, тут она меня откидывает и всё.
Этот глюк не в ntpd, а в непонимании команды telnet - нефиг пытатся ей к udp порту ntpd приконектится.