AS5300 и gnuGK

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-14 16:48:10

Вобщем то проблема заключается в том что CISCO не регится на GNUGK.

GNUGK запущен на freebsd 7.2, в логах gnugk

Код: Выделить всё

>tail -f /var/log/gnugk/gnugk.log
2009/11/14 14:56:38.217 1                 gk.cxx(591)   GNU Gatekeeper with ID 'localhost' started
Gatekeeper(GNU) Version(2.3.0) Ext(pthreads=1,radius=1,mysql=1,pgsql=1,firebird=0,odbc=1,sqlite=1,large_fdset=0,crypto/ssl=1,h46018=1) Build(Jun 10 2009, 22:31:30) Sys(FreeBSD i386 7.2-RELEASE-p4)

2009/11/14 14:56:38.218 1             RasSrv.cxx(527)   Listening to 192.168.254.1:1719(U)
2009/11/14 14:56:38.220 1             RasSrv.cxx(527)   Listening to 192.168.254.1:1718(Mcast)
2009/11/14 14:56:38.220 1             RasSrv.cxx(527)   Listening to 192.168.254.1:1721
2009/11/14 14:56:38.220 1             RasSrv.cxx(527)   Listening to 192.168.254.1:7000
2009/11/14 14:56:38.221 1             RasSrv.cxx(893)   RAS     Broadcast listener listening at 0.0.0.0:1719(Bcast)
2009/11/14 14:56:38.221 1             gkauth.cxx(291)   GKAUTH  RadAliasAuth rule added to check RAS: ARQ RRQ, OTHER: NONE
2009/11/14 14:56:38.222 1             gkauth.cxx(291)   GKAUTH  default rule added to check RAS: ARQ BRQ DRQ GRQ IRQ LRQ RRQ URQ, OTHER: SETUP SETUPUNREG
на циске в параметрах интерфейса:

Код: Выделить всё

interface FastEthernet0
 ip address 192.168.254.2 255.255.255.0
 no ip mroute-cache
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip id localhost ipaddr 192.168.254.1
 h323-gateway voip h323-id cisco
в итоге постоянно при sh gateway видим:

Код: Выделить всё

H.323 ITU-T Version: 4.0   H323 Stack Version: 0.1

 H.323 service is up
 Gateway  cisco  is not registered to any gatekeeper

Alias list (CLI configured)
 H323-ID cisco
Alias list (last RCF) is empty
ну и для полной картины конфиг Gnugk:

Код: Выделить всё

cat /usr/local/etc/gnugk.ini
; An example configuration for
; RADIUS authentication using RadAliasAuth module
;
; Author:
;  Michal Zygmuntowicz <m.zygmuntowicz@onet.pl>

; Standard stuff
[Gatekeeper::Main]
Fortytwo=42
TimeToLive=600
Name=localhost
Home=192.168.254.1

[RoutedMode]
GKRouted=1
H245Routed=0

[GkStatus::Auth]
rule=allow

[RasSrv::GWPrefixes]
cisco=8

; Put RadAliasAuth entry if RADIUS authentication
; should be used (you may also put additional
; entries for other authenticators)

; Currently only RRQ, ARQ and Setup are supported
[Gatekeeper::Auth]
RadAliasAuth=required;RRQ,ARQ
default=allow

; Configuration section for RadAuth authenticator module
[RadAliasAuth]

; List of RADIUS servers separated by ';'. Server name
; is specified as:
;       <DNS or IP>[:auth_port[:acct_port[:secret]]]
; if port is ommited, default is taken from:
;       1. DefaultAuthPort key;
;       2. /etc/services ('radius') if 1. not specified.
Servers=127.0.0.1:1812
;Servers=192.168.1.1:1812:1813:secret1;192.168.2.1:1812:1813:secret2

; Local network interface address that RADIUS client should use
; when communicating with RADIUS server. Leave empty (not set)
; to be able to communicate with RADIUS servers on different
; subnets.
LocalInterface=

; By default (if this option is not set) RADIUS client
; allocates ports dynamically as specified by the operating system.
; If you want to restrict RADIUS client to use only some
; port range - set this parameter
RadiusPortRange=10000-11000

; Default port where non-accounting packets will be sent to.
; Overrides /etc/services and can be overriden in Servers key
; for particular RADIUS servers
DefaultAuthPort=1812

; Secret shared between the GNU Gk (NAS) and a RADIUS servers.
; Should be a cryptographically-strong password
; You can override this setting by setting a secret in the Servers line
SharedSecret=secret

; Timeout value (ms) for a single RADIUS request
RequestTimeout=2000

; Time interval (ms) for RADIUS requests identifiers to be unique
IdCacheTimeout=9000

; Timeout value (ms) for unused RADIUS sockets to be deleted
SocketDeleteTimeout=60000

; Number of request retransmissions per RADIUS server (1==no retransmission)
RequestRetransmissions=2

; How requests should be retransmitted
; 0: Server A attempt #1, ..., Server A attempt #RequestRetransmissions;
;        Server B attempt #1, ..., Server B attempt #RequestRetransmissions;
;        ...
; 1: Server A attempt #1, Server B attempt #1, ...
;        ...
;        Server A attempt #RequestRetransmissions, Server B attempt #RequestRetransmissions, ...
RoundRobinServers=1

; Set to 1 if RADIUS packets should contain Cisco VSAs
; (h323-conf-id,h323-call-type,h323-call-origin,etc.)
AppendCiscoAttributes=1

; Set to 1 if RADIUS packets should contain a Cisco h323-ivr-out VSA
; containing a list of all aliases the endpoint wishes to register
; AppendCiscoAttributes must be set to 1 above.
IncludeTerminalAliases=1

; If not set, approtiate alias it extracted from RRQ or ARQ.
; Otherwise, this string is used as User-Name attribute
; for outgoing RADIUS requests
FixedUsername=

; If not set, User-Password attribute is set to the value
; copied from User-Name (example: if User-Name="user1",
; then User-Password="user1" too).
; Otherwise, this string is used as User-Password attribute
; for outgoing RADIUS requests
FixedPassword=

; Choose between the original dialed number and the rewritten one
UseDialedNumber=0

; EOF


Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-14 22:00:16

Добился что бы шлюз стал хотя бы пытаться регится на гейткипере.
Основные данные по настройке шлюза взял отсюда. Это ФАК GNUGK.org.
Первая ошибка была указывал неправильно id Гейткипера - исправил.
и ещё момент - в режиме конфигурации нужно сделать

Код: Выделить всё

(config)#no gateway
(config)#gateway
что перезапустит VOIP сервисы шлюза. (для умных - Я просто с циской на ВЫ, поэтому ещё разбираюсь пока)
Дальше чёт не хочет проходить регистрацию, вот что показывает sh log на циске:

Код: Выделить всё

Router#sh log
Syslog logging: enabled (9 messages dropped, 3 messages rate-limited, 0 flushes, 0 overruns, xml disabled)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled
    Buffer logging: level debugging, 7622 messages logged, xml disabled
    Logging Exception size (4096 bytes)
    Count and timestamp logging messages: disabled
    Trap logging: level informational, 555 message lines logged

Log Buffer (8192 bytes):
ven after 2 retriesh323chan_dgram_send:Sent UDP msg. Bytes sent: 67 to 192.168.254.1:1719 fd=2
Nov 14 18:50:41.168: RASLib::GW_RASSendGRQ: GRQ (seq# 995) sent to 192.168.254.1
Nov 14 18:50:41.168: h323chan_chn_process_read_socket
Nov 14 18:50:41.168: h323chan_chn_process_read_socket: fd=2 of type CONNECTED has data
Nov 14 18:50:41.168:  h323chan_chn_process_read_socket: h323chan accepted/connected fd=2
Nov 14 18:50:41.168: h323chan_dgram_recvdata:rcvd from [192.168.254.1:1719] on fd=2
Nov 14 18:50:41.168: GCF (seq# 995) rcvd from h323chan_dgram_send:Sent UDP msg. Bytes sent: 98 to 192.168.254.1:1719 fd=2
Nov 14 18:50:41.172: RASLib::GW_RASSendRRQ: RRQ (seq# 996) sent to 192.168.254.1
Nov 14 18:50:41.224: h323chan_chn_process_read_socket
Nov 14 18:50:41.224: h323chan_chn_process_read_socket: fd=2 of type CONNECTED has data
Nov 14 18:50:41.224:  h323chan_chn_process_read_socket: h323chan accepted/connected fd=2
Nov 14 18:50:41.224: h323chan_dgram_recvdata:rcvd from [192.168.254.1:1719] on fd=2
Nov 14 18:50:41.224: RRJ (seq# 996) rcvd
Nov 14 18:50:41.224: %CCH323-2-GTWY_REGSTR_FAILED: Gateway cisco failed to register with Gatekeeper localhost even after 2 retriesh323chan_dgram_send:Sent UDP msg. Bytes sent: 67 to 192.168.254.1:1719 fd=2
Вот sh run cо шлюза, ткните пожалуйста пальцем ГДЕ я закосячил:

Код: Выделить всё

Router#
sh run
Building configuration...

Current configuration : 2881 bytes
!
! Last configuration change at 20:32:10 EET Sat Nov 14 2009 by user
! NVRAM config last updated at 20:31:53 EET Sat Nov 14 2009 by user
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 0 secret
!
!
!
resource-pool disable
clock timezone EET 2
!
aaa new-model
!
!
aaa authentication login h323 group radius
aaa authorization exec h323 group radius
aaa accounting connection h323 start-stop group radius
aaa session-id common
ip subnet-zero
no ip domain lookup
!
!
isdn switch-type primary-net5
!
!
voice service voip
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
 codec preference 3 g723r63
!
!
!
!
!
!
!
!
!
username user secret 0 secret
!
!
controller E1 0
 pri-group timeslots 1-31
!
controller E1 1
 clock source line secondary 1
!
controller E1 2
 clock source line secondary 2
!
controller E1 3
 clock source line secondary 3
!
gw-accounting aaa
 acct-template callhistory-detail
!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 shutdown
 clock rate 2015232
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
 clock rate 2015232
 no fair-queue
!
interface Serial2
 no ip address
 shutdown
 clock rate 2015232
 no fair-queue
!
interface Serial3
 no ip address
 shutdown
 clock rate 2015232
 no fair-queue
!
interface Serial0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice modem
 isdn bchan-number-order ascending
 isdn sending-complete
 no cdp enable
!
interface FastEthernet0
 ip address 192.168.254.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 duplex auto
 speed auto
 keepalive 60
 h323-gateway voip interface
 h323-gateway voip id localhost ipaddr 192.168.254.1 1718
 h323-gateway voip h323-id cisco
!
ip classless
no ip http server
!
!
access-list 2 permit 192.168.254.1
!
!
!
radius-server host 192.168.254.1 auth-port 1812 acct-port 1813
radius-server key secret
radius-server vsa send accounting
radius-server vsa send authentication
!
call application voice debit tftp://192.168.254.1/app_debitcard.2.0.2.3_ru.tcl
call application voice debit uid-len 4
call application voice debit pin-len 6
call application voice debit language 0 ru
call application voice debit set-location ru 0 tftp://192.168.254.1/prompts/ru/
!
voice-port 0:D
 playout-delay maximum 250
 playout-delay minimum low
 cptone RU
!
!
!
dial-peer voice 2 voip
 destination-pattern .T
 voice-class codec 1
 session target ras
!
dial-peer voice 1 pots
 application debit
 destination-pattern T
 direct-inward-dial
 port 0:D
 prefix 96
!
gateway
!
!
line con 0
line aux 0
line vty 0 4
!
ntp clock-period 17180244
ntp server 192.168.254.1 prefer
end


Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-14 23:28:47

В общем сейчас уже обрисовалась проблема, гейт не регится на ГК из-за того, что ГК запрашивает у Радиус сервера проверку логина cisco, там его не находит и даёт отбой.

Настраиваю всё на биллинге Netup UTM5.2

Сейчас пытаюсь въехать в какой тип пользователей нужно воткнуть этого. или может в чём то другой косяк... разбираюсь

Гость
проходил мимо

Re: AS5300 и gnuGK

Непрочитанное сообщение Гость » 2009-11-15 1:37:10

почему циска в режиме гейткипера? зачем вам это?
переведите в обычный сигналинг
tftp://192.168.254.1/app_debitcard.2.0.2.3_ru.tcl
где то я это уже видел :-D
одну и туже циску администрирует пол интернета?
или это такая маничка у всех :-D

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-15 14:20:46

Гость писал(а):почему циска в режиме гейткипера? зачем вам это?
переведите в обычный сигналинг
1.Где видно что ЦИСКА в режиме гейт кипера? - вообще то гейткипер (gnugk) запущен на отдельной машине
Куда что перевести и как? - если бы знал давно уже перевел бы и не писал бы тут постов
Гость писал(а):
tftp://192.168.254.1/app_debitcard.2.0.2.3_ru.tcl
где то я это уже видел :-D
ну если вы товарищь не знаете, то это скрипт для IVR. А видеть вы могли где угодно.
Гость писал(а):одну и туже циску администрирует пол интернета?
или это такая маничка у всех :-D
ну во первых, что дали то и админю мне выбирать не пришлось, ну а во вторых - видимо это один из нормальных серверов доступа.
[оффтоп]Вообще я помощи прошу, а не обсуждения что и как. И всегда находятся самые умные. :st:

Гость
проходил мимо

Re: AS5300 и gnuGK

Непрочитанное сообщение Гость » 2009-11-15 19:06:10

1.Где видно что ЦИСКА в режиме гейт кипера?
Добился что бы шлюз стал хотя бы пытаться регится на гейткипере.
ну если вы товарищь не знаете, то это скрипт для IVR. А видеть вы могли где угодно.
я знаю что это скрипт IVR
но с такими настройками tftp я уже где то видел такое :-D

ну во первых, что дали то и админю мне выбирать не пришлось, ну а во вторых - видимо это один из нормальных серверов доступа.
asterisk не пробовали не?

вообще то все доки по настройке циски есть на http://www.cisco.com

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-15 19:17:29

шлюз это AS5300, гейткипер это GNUGK (ГК) на машине под FreeBSD. Шлюз должен зарегистрироваться на ГК (не я эту схему придумал) и ГК рулит шлюзом.
Зачем мне астериск? Как он может заменить GNUGK?

Мне всего лишь нужно врубиться какого пользователя завести в NetUp что бы шлюз зарегился?
А насчёт "где то видел" - зайди на сайт netup'а и глянь, да и не только там.
И хватит под гостем ходить, логиниться надо.

Аватара пользователя
Alex Keda
стреляли...
Сообщения: 35462
Зарегистрирован: 2004-10-18 14:25:19
Откуда: Made in USSR
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Alex Keda » 2009-11-16 0:44:47

Mobilesfinks писал(а):И хватит под гостем ходить, логиниться надо.
ему лень =)
а у меня теперь новая игра - отличи мессаги парадокса от мессаг Гвеста =)
с учётом что оба отвечают грамотно, удаётся тока по стилю, и то не всегда =)))
Убей их всех! Бог потом рассортирует...

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-16 1:57:37

Зарегил. Создал в биллинге пользователя с именем и паролем cisco (это id шлюза).
Всё теперь подключается, но проблема, IVR не хотеть запускаться.
tcl скрипт подтягивается (видно sh call application voice debit), шлюз отвечает, но в трубке тишина и секунд через 5-10 идёт отбой.
Может кто скажет где дебаг глянуть. В логах ни у гейт кипера ни у Радиус сервера нету ничего.

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-16 1:58:13

lissyara писал(а):ему лень =)
Ну дык для энтого и придумали пароли сохранять ))

Гость
проходил мимо

Re: AS5300 и gnuGK

Непрочитанное сообщение Гость » 2009-11-16 3:08:21

логи выполнения tcl скрипта есть и на циске
включите и посмотрите как выполняеться ваш скрипт
если лога радиуса и gnugk недостаточно

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-16 18:08:27

проблема в телефонной станции была. Просто звонок не проходил на циску вообще.
Так что троллл молодца, соображаешь. Когда звонок приходит где то логи но есть.

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-19 1:31:44

разобрался практически со всем, теперь вот только одна закавыка. Когда приходит звонок на шлюз, срабатывает IVR, я ввожу пин и мне в ответ "извините система перегружена".
в логах Циски:

Код: Выделить всё

Nov 18 22:24:23.521: %AAA-3-BADSERVERTYPEERROR: Cannot process accounting server type radius (UNKNOWN)
Nov 18 22:24:24.161: %ISDN-6-CONNECT: Interface Serial0:7 is now connected to 74012 N/A
Nov 18 22:24:42.854: %ISDN-6-DISCONNECT: Interface Serial0:7  disconnected from 74012 , call lasted 18 seconds
На гейт кипере циска зарегилась, с биллингом разобрался, а вот дальше косяк какой то, чёт ей не нравится. Может кто подскажет где копать? Если нужно отвечу более подробно. Только не надо "обходными" путями посылать.
Я вижу что написано, но при регистрации на Гейткипере циска регится по RadAlias, а вот потом по RadAcc даже не хочет. В логах Радиуса пусто, в логах ГК пусто.

Вот мой конфиг циски:

Код: Выделить всё

sh run
Current configuration : 2839 bytes
!
! No configuration change since last restart
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$afr.ljk,j`,
!
!
!
resource-pool disable
clock timezone EET 2
!
aaa new-model
!
!
aaa authentication login h323 group radius
aaa authorization exec h323 group radius
aaa accounting connection h323 start-stop group radius
aaa session-id common
ip subnet-zero
no ip domain lookup
!
!
isdn switch-type primary-net5
!
!
voice service voip
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
 codec preference 3 g723r63
!
!
!
!
!
!
!
!
!
username user secret 5 $1$1afr.ljk,j`,!
!
controller E1 0
 pri-group timeslots 1-31
!
controller E1 1
 clock source line secondary 1
!
controller E1 2
 clock source line secondary 2
!
controller E1 3
 clock source line secondary 3
!
gw-accounting aaa
 acct-template callhistory-detail
!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 shutdown
 clock rate 2015232
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
 clock rate 2015232
 no fair-queue
!
interface Serial2
 no ip address
 shutdown
 clock rate 2015232
 no fair-queue
!
interface Serial3
 no ip address
 shutdown
 clock rate 2015232
 no fair-queue
!
interface Serial0:15
 description AS5300 <--E1--> ATC M-200
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice modem
 isdn map address .* plan isdn type unknown
 isdn T310 50000
 isdn bchan-number-order ascending
 isdn sending-complete
 isdn outgoing-voice info-transfer-capability 3.1kHz-audio
 no fair-queue
 no cdp enable
!
interface FastEthernet0
 ip address 192.168.254.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 duplex auto
 speed auto
 keepalive 60
 h323-gateway voip interface
 h323-gateway voip id localhost ipaddr 192.168.254.1 1718
 h323-gateway voip h323-id cisco
!
ip classless
no ip http server
!
!
access-list 2 permit 192.168.254.1
!
!
!
radius-server vsa send accounting
radius-server vsa send authentication
!
call application voice debit tftp://192.168.254.1/app_debitcard.2.0.2.3_ru.tcl
call application voice debit uid-len 4
call application voice debit pin-len 8
call application voice debit language 0 ru
call application voice debit set-location ru 0 tftp://192.168.254.1/prompts/ru/
!
voice-port 0:D
 cptone RU
!
!
!
dial-peer voice 2 voip
 destination-pattern .T
 voice-class codec 1
 session target ras
!
dial-peer voice 1 pots
 application debit
 incoming called-number T
 direct-inward-dial
 port 0:D
 forward-digits 0
 prefix 96
!
gateway
!
!
line con 0
line aux 0
line vty 0 4
!
ntp clock-period 17180401
ntp server 192.168.254.1 prefer
end
что ещё показать?

Аватара пользователя
ProFTP
подполковник
Сообщения: 3388
Зарегистрирован: 2008-04-13 1:50:04
Откуда: %&й
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение ProFTP » 2009-11-19 1:34:37

lissyara писал(а): ему лень =)
а у меня теперь новая игра - отличи мессаги парадокса от мессаг Гвеста =)
с учётом что оба отвечают грамотно, удаётся тока по стилю, и то не всегда =)))
а парадокс что гостем ходит?? :-D

он мне редлагал perl OS написать и бразуер написать :)
сразу видно что-то тут не то
Pеrl FAQ
perl -e 'print join"",map $$_[rand@$_],([0..9,'a'..'z','A'..'Z'])x30'
ИзображениеИзображение

Гость
проходил мимо

Re: AS5300 и gnuGK

Непрочитанное сообщение Гость » 2009-11-19 4:59:32

Nov 18 22:24:23.521: %AAA-3-BADSERVERTYPEERROR: Cannot process accounting server type radius (UNKNOWN)
циска незнает айпишник радиус сервера
куда отправлять радиус пакеты

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-19 11:51:55

Угу, спасибо, уже врубился в это. На свежую голову.
Теперь Карточки автоматом добавляются (активируются), но вот говорится что пинкод неверный. В логах пишет, что не могёт найти логин в бд
Через админку, я вижу что пользователь карточный есть,

Код: Выделить всё

?Debug : Nov 19 10:04:18 RADIUS DBA: NAS found. Data size <0>
?Debug : Nov 19 10:04:18 AcctServer: Acct packet with session ID: 00000021
?Debug : Nov 19 10:04:18 RADIUS DBA: NAS found. Data size <0>
?Debug : Nov 19 10:04:18 AcctServer: Acct-Start packet
?Debug : Nov 19 10:04:18 AcctServer: Acct-Start: User <74012>
?Debug : Nov 19 10:04:18 AcctServer: Acct-Session-Time (46) not present in accounting packet. 
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find login <74012>
?Debug : Nov 19 10:04:18 RADIUS DBA: Searching card login <000074012>
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find card login <000074012>
?Debug : Nov 19 10:04:18 RADIUS DBA: Calling-Station-ID <74012> is used in place of User-Name <74012>
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find login <74012>
?Debug : Nov 19 10:04:18 RADIUS DBA: Searching card login <000074012>
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find card login <000074012>
?Debug : Nov 19 10:04:18 RADIUS DBA: Called-Station-ID <570235> is used in place of User-Name <74012>
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find login <570235>
?Debug : Nov 19 10:04:18 RADIUS DBA: Searching card login <000570235>
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find card login <000570235>
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find login <74012>
?Debug : Nov 19 10:04:18 RADIUS DBA: Searching card login <000074012>
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find card login <000074012>
?Debug : Nov 19 10:04:18 RADIUS DBA: Calling-Station-ID <74012> is used in place of User-Name <74012>
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find login <74012>
?Debug : Nov 19 10:04:18 RADIUS DBA: Searching card login <000074012>
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find card login <000074012>
?Debug : Nov 19 10:04:18 RADIUS DBA: Called-Station-ID <570235> is used in place of User-Name <74012>
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find login <570235>
?Debug : Nov 19 10:04:18 RADIUS DBA: Searching card login <000570235>
 ERROR : Nov 19 10:04:18 RADIUS DBA: Can't find card login <000570235>
 ERROR : Nov 19 10:04:18 RADIUS DBA: No data for login: 74012
 ERROR : Nov 19 10:04:18 AcctServer: Error! (2)
?Debug : Nov 19 10:04:18 RadiusSocket: Waiting for RADIUS raw data
?Debug : Nov 19 10:04:20 RadiusSocket: RADIUS packet successfully received
?Debug : Nov 19 10:04:20 RadiusSocket: RADIUS raw data obtained
?Debug : Nov 19 10:04:20 RADIUS Packet: Size <186>; HDR.Size <186>
?Debug : Nov 19 10:04:20 AuthServer: Recv...
?Debug : Nov 19 10:04:20 AuthServer: Packet from NAS <192.168.254.2>
?Debug : Nov 19 10:04:20 RADIUS DBA: NAS found. Data size <0>
?Debug : Nov 19 10:04:20 AuthServer: Packet from <192.168.254.2> packet dump: RPacket:
Code: 1; ID: 8
<Vendor: 0; Attr: 1>[4]: 30303032
<Vendor: 0; Attr: 2>[16]: 859e8f251913c9ae5af3484d50563c5b
<Vendor: 0; Attr: 4>[4]: c0a8fe02
<Vendor: 0; Attr: 5>[4]: 00000000
<Vendor: 0; Attr: 6>[4]: 00000001
<Vendor: 0; Attr: 31>[5]: 3734303132
<Vendor: 0; Attr: 61>[4]: 00000000
<Vendor: 9; Attr: 1>[28]: 683332332d6976722d6f75743d7472616e73616374696f6e49443a38
<Vendor: 9; Attr: 2>[11]: 4953444e20303a443a3138
<Vendor: 9; Attr: 24>[48]: 683332332d636f6e662d69643d4632443343314243204434313831314445203830314441453232203431384534414330
 
?Debug : Nov 19 10:04:20 AuthServer: User <0002> connecting
?Debug : Nov 19 10:04:20 AuthServer: Session for sessionid <0002> not found in <192.168.254.2> cache
 ERROR : Nov 19 10:04:20 RADIUS DBA: Can't find login <0002>
?Debug : Nov 19 10:04:20 RADIUS DBA: Searching card login <000000002>
 ERROR : Nov 19 10:04:20 RADIUS DBA: Can't find card login <000000002>
?Debug : Nov 19 10:04:20 AuthServer: Attempt to add new Card user: <0002>
?Debug : Nov 19 10:04:20 AuthServer: Skiping non-digit symbols
?Debug : Nov 19 10:04:20 RADIUS DBA: Sending Auto-Add Request for Card-ID: 0002
?Debug : Nov 19 10:04:20 RADIUS Stream[plugin]: Account <4> with balance <100.000>
?Debug : Nov 19 10:04:20 RADIUS Stream[plugin]: Got User-Autoadd id <4>
?Debug : Nov 19 10:04:20 AuthServer: Got AutoAdd 4 UID from core.
 Info  : Nov 19 10:04:21 AuthServer: Retry:0 to find user <0002>
 ERROR : Nov 19 10:04:21 RADIUS DBA: Can't find login <0002>
?Debug : Nov 19 10:04:21 RADIUS DBA: Searching card login <000000002>
 ERROR : Nov 19 10:04:21 RADIUS DBA: Can't find card login <000000002>
 Info  : Nov 19 10:04:22 AuthServer: Retry:1 to find user <0002>
 ERROR : Nov 19 10:04:22 RADIUS DBA: Can't find login <0002>
?Debug : Nov 19 10:04:22 RADIUS DBA: Searching card login <000000002>
 ERROR : Nov 19 10:04:22 RADIUS DBA: Can't find card login <000000002>
 Info  : Nov 19 10:04:23 AuthServer: Retry:2 to find user <0002>
 ERROR : Nov 19 10:04:23 RADIUS DBA: Can't find login <0002>
?Debug : Nov 19 10:04:23 RADIUS DBA: Searching card login <000000002>
 ERROR : Nov 19 10:04:23 RADIUS DBA: Can't find card login <000000002>
 Warn  : Nov 19 10:04:23 AuthServer: Errors adding card <0002>. Rehash failed
 ERROR : Nov 19 10:04:23 AuthServer: No data for User <0002> found.
?Debug : Nov 19 10:04:23 AuthServer: Auth reply: RPacket:
Code: 3; ID: 8
<Vendor: 0; Attr: 18>[21]: 417574686f72697a6174696f6e206661696c65642e
<Vendor: 9; Attr: 103>[19]: 683332332d72657475726e2d636f64653d2d31

?Debug : Nov 19 10:04:23 RADIUS Packet: raw data constructed! size <70>
?Debug : Nov 19 10:04:23 RadiusSocket: Moving RADIUS packet into send queue
?Debug : Nov 19 10:04:23 RadiusSocket: RADIUS raw data sent
?Debug : Nov 19 10:04:23 AuthServer: Next...
?Trace : Nov 19 10:04:23 AuthServer: Process loop step
?Debug : Nov 19 10:04:23 RadiusSocket: Waiting for RADIUS raw data
?Debug : Nov 19 10:04:23 RadiusSocket: RADIUS packet successfully received
?Debug : Nov 19 10:04:23 RadiusSocket: RADIUS raw data obtained
?Debug : Nov 19 10:04:23 RADIUS Packet: Size <545>; HDR.Size <545>
?Debug : Nov 19 10:04:23 AcctServer: Recv...
?Debug : Nov 19 10:04:23 AcctServer: Packet from <192.168.254.2> packet dump: RPacket:
Code: 4; ID: 50
<Vendor: 0; Attr: 1>[5]: 3734303132
<Vendor: 0; Attr: 4>[4]: c0a8fe02
<Vendor: 0; Attr: 5>[4]: 00000000
<Vendor: 0; Attr: 6>[4]: 00000001
<Vendor: 0; Attr: 30>[6]: 353730323335
<Vendor: 0; Attr: 31>[5]: 3734303132
<Vendor: 0; Attr: 40>[4]: 00000001
<Vendor: 0; Attr: 41>[4]: 0000000f
<Vendor: 0; Attr: 44>[8]: 3030303030303231
<Vendor: 0; Attr: 45>[4]: 00000000
<Vendor: 0; Attr: 61>[4]: 00000000
<Vendor: 9; Attr: 1>[57]: 683332332d696e636f6d696e672d636f6e662d69643d4632443343314243204434313831314445203830314441453232203431384534414330
<Vendor: 9(0); Attr: 1>[22]: 737562736372696265723d526567756c61724c696e65
<Vendor: 9(1); Attr: 1>[31]: 67772d7278642d63646e3d746f6e3a302c6e70693a302c233a353730323335
<Vendor: 9(2); Attr: 1>[24]: 63616c6c696e672d70617274792d63617465676f72793d39
<Vendor: 9(3); Attr: 1>[25]: 7472616e736d697373696f6e2d6d656469756d2d7265713d30
<Vendor: 9(4); Attr: 1>[24]: 636f6e6e6563742d70726f67726573733d43616c6c205570
<Vendor: 9; Attr: 2>[11]: 4953444e20303a443a3138
<Vendor: 9; Attr: 24>[48]: 683332332d636f6e662d69643d4632443343314243204434313831314445203830314441453232203431384534414330
<Vendor: 9; Attr: 25>[48]: 683332332d73657475702d74696d653d31303a30343a30382e3630342045455420546875204e6f762031392032303039
<Vendor: 9; Attr: 26>[23]: 683332332d63616c6c2d6f726967696e3d616e73776572
<Vendor: 9; Attr: 27>[24]: 683332332d63616c6c2d747970653d54656c6570686f6e79
<Vendor: 9; Attr: 33>[18]: 683332332d67772d69643d526f757465722e
74012 - это id циски
570235 - это номер на который звонится

В общем пока писал, ещё и разбирался потихоньку. Какой то косяк у меня в настройках Биллинга. Кто может подсказать, кто с NetUp имел дело?
Сейчас карточка автоматом добавляется, ей присваивается услуга. Но карточка остаётся "красной" - в её свойствах есть пункт "интернет", который стоит "выключен". Хотя это и телефония, но всё же при активации этого параметра карточка становится "зеленой". Но при вводе её пинкода всё равно в ответ сылшно "неправильно введен пин код", а в логах так же пишет что не может найти логин карты.
Последний раз редактировалось Mobilesfinks 2009-11-19 12:32:15, всего редактировалось 1 раз.

Гость
проходил мимо

Re: AS5300 и gnuGK

Непрочитанное сообщение Гость » 2009-11-19 11:56:32

это уже вопрос к биллингу
скорее всего к документации по UTM

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-19 13:39:33

Ты её читал? :st: да там половины нет того, что нужно делать.
Даже например с адресом радиус сервера - там вообще не сказано, что его нужно указывать.
"Заведите пользователя" - какого, зачем, пароли какие ставить, какие ему нужно услуги правильно подключать. Там отписка, а не документация.
Нигде не сказано, что для регистрации на гейткипере нужно заводить пользователя в биллинге. Нигде не сказано, что нужно заводить пользователя для самого шлюза. Про то какие на него услуги вешать тоже не сказано. Типа сами разбирайтесь.
Может там конечно на супер продвинутых пользователей ориентированно, но всё же столько мелочей упущено...

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-19 14:07:18

Вытащил лог биллинга - помогите разобрать
Копирую свой пост с другого форума.


Дальше возникла следующая заморочка:
Дозвонился, ввожу пинкод карты, мне отвечает, что пинкод неправильный. Лезу в админку, смотрю что карта добавилась. Смотрю в её свойствах - нет услуги.

Создал фиктивную услугу, скопировал в неё цены с основной. Поставил галочку "добавлять по умолчанию". В базовой услуге эта галочка не активна.

При вводе пинкода уже другой карты, она добавилась, услуга завелась, но в ответ всё же пишет, что "неправильно введен пинкод.
Да ещё карты при автодобавлени (автоактивации) в списке красными нарисованы, если изменить в них параметр "Интернет" на "включен", то карточные пользователи становятся зелеными. Тем не менее на результат ввода пинкода это не влияет.
Вот что нашёл Debug.log

Код: Выделить всё

?Debug : Nov 19 12:03:36 Radius: init_session_log id <2>
?Debug : Nov 19 12:03:36 DBCtx: <679506944> SQL query: INSERT INTO tel_sessions_log(account_id,slink_id,recv_date,last_update_date,             NAS_Port,Acct_Delay_Time,               Acct_Session_Id,NAS_Port_Type,User_Name,Service_Type,Framed_Protocol,NAS_IP_Address,NAS_Id,Acct_Status_Type,            Acct_Input_Packets,Acct_Input_Octets,Acct_Input_Gigawords,Acct_Output_Packets,Acct_Output_Octets,Acct_Output_Gigawords,         Acct_Session_Time,Acct_Terminate_Cause,Called_Station_Id,Calling_Station_Id,h323_remote_address,h323_conf_id,           h323_setup_time,h323_call_origin,               h323_call_type,h323_connect_time,h323_disconnect_time,h323_disconnect_cause,            h323_gw_id,zone_id,did,session_start_date) VALUES('3','3','1258625016','1258625016','0','0','00000042','0','74012','1','0','50243776','192.168.254.2','1','0','0','0','0','0','0','0','0','570235','74012','','h323-conf-id=A348F4B4 D42911DE 803BAE22 418E4AC0','h323-setup-time=12\:03\:36.592 EET Thu Nov 19 2009','h323-call-origin=answer','h323-call-type=Telephony','','','','h323-gw-id=Router.','0','0','1258625016')
?Debug : Nov 19 12:03:36 Radius: Dynamic IP binding not called because ip or slink is null ! ip <0> slink <3>
?Debug : Nov 19 12:03:50 UTM5 DBA: DBAccess instance created
?Debug : Nov 19 12:03:50 DBA:Ctx: Looking for free context
?Debug : Nov 19 12:03:50 DBCtx: <679515136> SQL query: BEGIN
?Debug : Nov 19 12:03:50 DBCtx: DB transaction begin
?Debug : Nov 19 12:03:50 DBCtx: <679515136> SQL SELECT query: SELECT id,pool_id,secret,balance,currency,expiration,days,is_used,service_id,is_blocked FROM card_info WHERE secret='000397717964'
?Debug : Nov 19 12:03:50 DBCtx: <679515136> SQL SELECT query: SELECT value FROM utm5_settings WHERE variable='card_user_prefix'
?Debug : Nov 19 12:03:50 DBCtx: <679515136> SQL SELECT query: SELECT id,pool_id,secret,balance,currency,expiration,days,is_used,service_id,is_blocked FROM card_info WHERE id='3'
?Debug : Nov 19 12:03:50 DBCtx: <679515136> SQL SELECT query: SELECT pool_id,cards,cards_used,first_update,last_update FROM card_pool_info WHERE  pool_id='1'
?Debug : Nov 19 12:03:50 DBCtx: <679515136> SQL SELECT query: SELECT user_id FROM card_pool_owners WHERE pool_id ='1' AND is_deleted = 0
?Debug : Nov 19 12:03:50 DBCtx: <679515136> SQL SELECT query: SELECT id,pool_id,secret,balance,currency,expiration,days,is_used,service_id,is_blocked FROM card_info WHERE id='3'
 Warn  : Nov 19 12:03:50 UTM5 DBA: add_user_card_priv: card <3> is already used
?Debug : Nov 19 12:03:50 DBCtx: <679515136> SQL query: COMMIT
?Debug : Nov 19 12:03:50 DBCtx: DB transaction commit
?Debug : Nov 19 12:03:50 DBA:Ctx: Pushing back free context
-Stats : Nov 19 12:03:50 UTM5 DBA:      Stats: Uptime: 00:00:00. Events: 0; Errors: 0
?Debug : Nov 19 12:03:56 DBCtx: <679506944> SQL query: INSERT INTO tel_sessions_detail(dhs_sess_id,disc_per_id,slink_id,recv_date,account_id,trange_id,duration,base_cost,sum_cost) VALUES('10','3','3','1258625036','3','0','20','0','0')
?Debug : Nov 19 12:03:56 UTM5 DBA: DBAccess instance created
?Debug : Nov 19 12:03:56 DBA:Ctx: Looking for free context
?Debug : Nov 19 12:03:56 DBCtx: <679511040> SQL query: BEGIN
?Debug : Nov 19 12:03:56 DBCtx: DB transaction begin
?Debug : Nov 19 12:03:56 UTM5 DBA: discount_from_account tel zoneid <0> h.base_cost <0.000000>
?Debug : Nov 19 12:03:56 DBCtx: <679506944> SQL query: UPDATE dtagg_telephony SET discounted='0.000000',discounted_without_tax='0.000000', duration='68' WHERE id='1'
?Debug : Nov 19 12:03:56 UTM5 DBA: Charge:0.000000 p.u. for link:3 account 3
?Debug : Nov 19 12:03:56 DBCtx: <679511040> SQL query: UPDATE accounts SET balance='1' WHERE id = '3'
?Debug : Nov 19 12:03:56 DBCtx: <679511040> SQL query: INSERT INTO discount_transactions_all(account_id,incoming_rest,outgoing_rest,discount,discount_with_tax,service_id,service_type,slink_id,discount_date,charge_type,discount_period_id) VALUES('3','1','1','0','0','1','6','3','1258625036','6','3')
?Debug : Nov 19 12:03:56 UTM5 DBA: Checking for rehash: flags 3, balance 1.000 (old 1.000), credit 0.000
?Debug : Nov 19 12:03:56 DBAGiga: Rehash: Target: 10; Action: 1; Ptr: bc7e8a0c
?Debug : Nov 19 12:03:56 Radius: Account '3': 1.000/0.000 send...
?Debug : Nov 19 12:03:56 HSPlugin: Rehash: Target: 10; Action: 1; Ptr: bc7e8a0c
?Debug : Nov 19 12:03:56 BusLogic: BLM(37) pushed (comment: ruh block)
?Debug : Nov 19 12:03:56 DBCtx: <679511040> SQL query: COMMIT
?Debug : Nov 19 12:03:56 BusLogic: try to execute 37
?Debug : Nov 19 12:03:56 BusLogic: hw_block_handler with code 37
?Debug : Nov 19 12:03:56 BusLogic: finished unknown
?Debug : Nov 19 12:03:56 DBCtx: DB transaction commit
?Debug : Nov 19 12:03:56 DBA:Ctx: Pushing back free context
-Stats : Nov 19 12:03:56 UTM5 DBA:      Stats: Uptime: 00:00:00. Events: 0; Errors: 0
?Debug : Nov 19 12:03:56 Radius: edit_session_log id <2> input octets <0> output octet <60480>
?Debug : Nov 19 12:03:56 Radius: session log with id <2> found in the cache
?Debug : Nov 19 12:03:56 DBCtx: <679506944> SQL query: UPDATE tel_sessions_log SET  account_id='3', slink_id='3', last_update_date='1258625036', Acct_Status_Type='2', Acct_Input_Packets ='0', Acct_Input_Octets ='0', Acct_Input_Gigawords ='0', Acct_Output_Packets ='252', Acct_Output_Octets ='60480', Acct_Output_Gigawords ='0', h323_connect_time='', Acct_Terminate_Cause='0', h323_disconnect_cause='h323-disconnect-cause=11', Acct_Session_Time ='20' WHERE id='10'
?Debug : Nov 19 12:03:56 Radius: id2core removing key <2>
А вот что сыпется в radius.log

Код: Выделить всё

 
?Debug : Nov 19 12:03:36 RADIUS DBA: NAS found. Data size <0>
?Debug : Nov 19 12:03:36 AcctServer: Acct packet with session ID: 00000042
?Debug : Nov 19 12:03:36 RADIUS DBA: NAS found. Data size <0>
?Debug : Nov 19 12:03:36 AcctServer: Acct-Start packet
?Debug : Nov 19 12:03:36 AcctServer: Acct-Start: User <74012>
?Debug : Nov 19 12:03:36 AcctServer: Acct-Session-Time (46) not present in accounting packet. 
?Debug : Nov 19 12:03:36 RADIUS DBA: Info for login <74012> found. type <3>
?Debug : Nov 19 12:03:36 RADIUS DBA: Password found for tel login:74012
?Debug : Nov 19 12:03:36 RADIUS DBA: info for user found. type <3> info addr <677436416>
?Debug : Nov 19 12:03:36 RADIUS DBA: search_user_info return info <677436416>
?Debug : Nov 19 12:03:36 RADIUS DBA: search_user_info return valid info
?Debug : Nov 19 12:03:36 RADIUS DBA: Setting interim interval <0> for session id <00000042>
?Debug : Nov 19 12:03:36 RADIUS DBA: TELTARIFF: called number <570235> calling number <74012> direction id <0> zone id <0>
?Debug : Nov 19 12:03:36 RADIUS DBA: tel.session_count incremented. value <1>
?Debug : Nov 19 12:03:36 RADIUS DBA: Calling send_session_log_init_sync ...
?Debug : Nov 19 12:03:36 RADIUS Stream[plugin]: send_session_log_init_sync
?Debug : Nov 19 12:03:36 RADIUS Stream[plugin]: init log id <2>
?Debug : Nov 19 12:03:36 AcctServer: Reply packet dump: RPacket:
Code: 5; ID: 99

?Debug : Nov 19 12:03:36 RadiusSocket: Moving RADIUS packet into send queue
?Debug : Nov 19 12:03:36 RadiusSocket: RADIUS raw data sent
?Debug : Nov 19 12:03:36 AcctServer: Next...
?Debug : Nov 19 12:03:36 RadiusSocket: Waiting for RADIUS raw data
?Debug : Nov 19 12:03:49 RADIUS DBA: No interim update enabled session <2> found. Setting to default (if enabled). 
?Debug : Nov 19 12:03:50 RadiusSocket: RADIUS packet successfully received
?Debug : Nov 19 12:03:50 RadiusSocket: RADIUS raw data obtained
?Debug : Nov 19 12:03:50 RADIUS Packet: Size <187>; HDR.Size <187>
?Debug : Nov 19 12:03:50 AuthServer: Recv...
?Debug : Nov 19 12:03:50 AuthServer: Packet from NAS <192.168.254.2>
?Debug : Nov 19 12:03:50 RADIUS DBA: NAS found. Data size <0>
?Debug : Nov 19 12:03:50 AuthServer: Packet from <192.168.254.2> packet dump: RPacket:
Code: 1; ID: 17
<Vendor: 0; Attr: 1>[4]: 30303033
<Vendor: 0; Attr: 2>[16]: 8c7317d63c44eb690655a9bd4819dc43
<Vendor: 0; Attr: 4>[4]: c0a8fe02
<Vendor: 0; Attr: 5>[4]: 00000000
<Vendor: 0; Attr: 6>[4]: 00000001
<Vendor: 0; Attr: 31>[5]: 3734303132
<Vendor: 0; Attr: 61>[4]: 00000000
<Vendor: 9; Attr: 1>[29]: 683332332d6976722d6f75743d7472616e73616374696f6e49443a3137
<Vendor: 9; Attr: 2>[11]: 4953444e20303a443a3238
<Vendor: 9; Attr: 24>[48]: 683332332d636f6e662d69643d4133343846344234204434323931314445203830334241453232203431384534414330
 
?Debug : Nov 19 12:03:50 AuthServer: User <0003> connecting
?Debug : Nov 19 12:03:50 AuthServer: Session for sessionid <0003> not found in <192.168.254.2> cache
 ERROR : Nov 19 12:03:50 RADIUS DBA: Can't find login <0003>
?Debug : Nov 19 12:03:50 RADIUS DBA: Searching card login <000000003>
 ERROR : Nov 19 12:03:50 RADIUS DBA: Can't find card login <000000003>
?Debug : Nov 19 12:03:50 AuthServer: Attempt to add new Card user: <0003>
?Debug : Nov 19 12:03:50 AuthServer: Skiping non-digit symbols
?Debug : Nov 19 12:03:50 RADIUS DBA: Sending Auto-Add Request for Card-ID: 0003
?Debug : Nov 19 12:03:50 RADIUS Stream[plugin]: Ping reply received
?Debug : Nov 19 12:03:50 RADIUS Stream[plugin]: Got User-Autoadd id <0>
?Debug : Nov 19 12:03:50 AuthServer: Got AutoAdd 0 UID from core.
 Info  : Nov 19 12:03:51 AuthServer: Retry:0 to find user <0003>
 ERROR : Nov 19 12:03:51 RADIUS DBA: Can't find login <0003>
?Debug : Nov 19 12:03:51 RADIUS DBA: Searching card login <000000003>
 ERROR : Nov 19 12:03:51 RADIUS DBA: Can't find card login <000000003>
 Info  : Nov 19 12:03:52 AuthServer: Retry:1 to find user <0003>
 ERROR : Nov 19 12:03:52 RADIUS DBA: Can't find login <0003>
?Debug : Nov 19 12:03:52 RADIUS DBA: Searching card login <000000003>
 ERROR : Nov 19 12:03:52 RADIUS DBA: Can't find card login <000000003>
 Info  : Nov 19 12:03:53 AuthServer: Retry:2 to find user <0003>
 ERROR : Nov 19 12:03:53 RADIUS DBA: Can't find login <0003>
?Debug : Nov 19 12:03:53 RADIUS DBA: Searching card login <000000003>
 ERROR : Nov 19 12:03:53 RADIUS DBA: Can't find card login <000000003>
 Warn  : Nov 19 12:03:53 AuthServer: Errors adding card <0003>. Rehash failed
 ERROR : Nov 19 12:03:53 AuthServer: No data for User <0003> found.
?Debug : Nov 19 12:03:53 AuthServer: Auth reply: RPacket:
Code: 3; ID: 17
<Vendor: 0; Attr: 18>[21]: 417574686f72697a6174696f6e206661696c65642e
<Vendor: 9; Attr: 103>[19]: 683332332d72657475726e2d636f64653d2d31

?Debug : Nov 19 12:03:53 RADIUS Packet: raw data constructed! size <70>
?Debug : Nov 19 12:03:53 RadiusSocket: Moving RADIUS packet into send queue
?Debug : Nov 19 12:03:53 RadiusSocket: RADIUS raw data sent
?Debug : Nov 19 12:03:53 AuthServer: Next...
?Trace : Nov 19 12:03:53 AuthServer: Process loop step
?Debug : Nov 19 12:03:53 RadiusSocket: Waiting for RADIUS raw data
?Debug : Nov 19 12:03:56 RadiusSocket: RADIUS packet successfully received
?Debug : Nov 19 12:03:56 RadiusSocket: RADIUS raw data obtained
?Debug : Nov 19 12:03:56 RADIUS Packet: Size <1142>; HDR.Size <1142>
?Debug : Nov 19 12:03:56 AcctServer: Recv...
?Debug : Nov 19 12:03:56 AcctServer: Packet from <192.168.254.2> packet dump: RPacket:
Code: 4; ID: 100
<Vendor: 0; Attr: 1>[4]: 30303033
<Vendor: 0; Attr: 4>[4]: c0a8fe02
<Vendor: 0; Attr: 5>[4]: 00000000
<Vendor: 0; Attr: 6>[4]: 00000001
<Vendor: 0; Attr: 30>[6]: 353730323335
<Vendor: 0; Attr: 31>[5]: 3734303132
<Vendor: 0; Attr: 40>[4]: 00000002
<Vendor: 0; Attr: 41>[4]: 00000000
<Vendor: 0; Attr: 42>[4]: 00000000
<Vendor: 0; Attr: 43>[4]: 0000ec40
<Vendor: 0; Attr: 44>[8]: 3030303030303432
<Vendor: 0; Attr: 45>[4]: 00000001
<Vendor: 0; Attr: 46>[4]: 00000014
<Vendor: 0; Attr: 47>[4]: 00000000
<Vendor: 0; Attr: 48>[4]: 000000fc
<Vendor: 0; Attr: 61>[4]: 00000000
<Vendor: 9; Attr: 1>[57]: 683332332d696e636f6d696e672d636f6e662d69643d4133343846344234204434323931314445203830334241453232203431384534414330
<Vendor: 9(0); Attr: 1>[22]: 737562736372696265723d526567756c61724c696e65
<Vendor: 9(1); Attr: 1>[31]: 67772d7278642d63646e3d746f6e3a302c6e70693a302c233a353730323335
<Vendor: 9(2); Attr: 1>[24]: 63616c6c696e672d70617274792d63617465676f72793d39
<Vendor: 9(3); Attr: 1>[25]: 7472616e736d697373696f6e2d6d656469756d2d7265713d30
<Vendor: 9(4); Attr: 1>[27]: 683332332d6976722d6f75743d5461726966663a556e6b6e6f776e
<Vendor: 9(5); Attr: 1>[16]: 72656c656173652d736f757263653d31
<Vendor: 9(6); Attr: 1>[30]: 67772d7278642d63676e3d746f6e3a302c6e70693a302c233a3734303132
<Vendor: 9(7); Attr: 1>[15]: 636861726765642d756e6974733d30
<Vendor: 9(8); Attr: 1>[30]: 646973636f6e6e6563742d746578743d7573657220627573792028313729
<Vendor: 9(9); Attr: 1>[18]: 706565722d616464726573733d3734303132
<Vendor: 9(10); Attr: 1>[16]: 696e666f2d747970653d737065656368
<Vendor: 9(11); Attr: 1>[9]: 706565722d69643d31
<Vendor: 9(12); Attr: 1>[16]: 706565722d69662d696e6465783d3736
<Vendor: 9(13); Attr: 1>[19]: 6c6f676963616c2d69662d696e6465783d3430
<Vendor: 9(14); Attr: 1>[13]: 61636f6d2d6c6576656c3d3231
<Vendor: 9(15); Attr: 1>[24]: 636f6465722d747970652d726174653d67373131756c6177
<Vendor: 9(16); Attr: 1>[22]: 6e6f6973652d6c6576656c3d34323934393637323132
<Vendor: 9(17); Attr: 1>[26]: 766f6963652d74782d6475726174696f6e3d3131363730206d73
<Vendor: 9(18); Attr: 1>[20]: 74782d6475726174696f6e3d3131363730206d73
<Vendor: 9; Attr: 2>[11]: 4953444e20303a443a3238
<Vendor: 9; Attr: 24>[48]: 683332332d636f6e662d69643d4133343846344234204434323931314445203830334241453232203431384534414330
<Vendor: 9; Attr: 25>[48]: 683332332d73657475702d74696d653d31323a30333a33362e3539322045455420546875204e6f762031392032303039
<Vendor: 9; Attr: 26>[23]: 683332332d63616c6c2d6f726967696e3d616e73776572
<Vendor: 9; Attr: 27>[24]: 683332332d63616c6c2d747970653d54656c6570686f6e79
<Vendor: 9; Attr: 28>[50]: 683332332d636f6e6e6563742d74696d653d31323a30333a33362e3630362045455420546875204e6f762031392032303039
<Vendor: 9; Attr: 29>[53]: 683332332d646973636f6e6e6563742d74696d653d31323a30333a35362e3133372045455420546875204e6f762031392032303039
<Vendor: 9; Attr: 30>[24]: 683332332d646973636f6e6e6563742d63617573653d3131
<Vendor: 9; Attr: 31>[20]: 683332332d766f6963652d7175616c6974793d30
<Vendor: 9; Attr: 33>[18]: 683332332d67772d69643d526f757465722e
 
?Debug : Nov 19 12:03:56 RADIUS DBA: NAS found. Data size <0>
?Debug : Nov 19 12:03:56 AcctServer: Acct packet with session ID: 00000042
?Debug : Nov 19 12:03:56 RADIUS DBA: NAS found. Data size <0>
?Debug : Nov 19 12:03:56 AcctServer: Acct-Stop packet
?Debug : Nov 19 12:03:56 RADIUS DBA: Session erase ... login type <3>
?Debug : Nov 19 12:03:56 RADIUS DBA: login type login_tel
?Debug : Nov 19 12:03:56 RADIUS DBA: Calling tel_calculate cost. session_time_not_present <0> NOW <1258625036>
?Debug : Nov 19 12:03:56 RADIUS Tarif: UT for telephony called. tkey:0 start:1258625016 stop:1258625036
?Debug : Nov 19 12:03:56 RADIUS Tarif: Telephony service <1> free time <5>
?Debug : Nov 19 12:03:56 RADIUS Tarif: UT cost_info sum:0.0000 setup_time <1258625016>
?Debug : Nov 19 12:03:56 RADIUS DBA: VoIP Discount: TR ID 0: 0.000 for 20 sec setup_time <1258625016>
?Debug : Nov 19 12:03:56 RADIUS Tarif: UT tkey <0> downloaded <46>
?Debug : Nov 19 12:03:56 RADIUS DBA: VoIP calculated cost: 0.000
?Debug : Nov 19 12:03:56 RADIUS Stream[plugin]: finish log id <2>
?Debug : Nov 19 12:03:56 AcctServer: Reply packet dump: RPacket:
Code: 5; ID: 100
т.е. в логе радиуса видно, что карточку № 0003 не видит в БД

про других пользователей:
для регистрации шлюза заведены 2 пользователя
1 - cisco - для регистрации его на ГейтКипере
2 - 74012 - для регистрации при звонке - иначе сыпятся ошибки, мол неизвестный логин/пароль в логах
Им обоим добавлена услуга телефонии.
Возможно у меня где то в этом косяк, но понять пока не могу. Может кто сможет подсказать более точно?

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-19 16:03:45

Нашёл полный мануал по UTM5, буду читать, там как раз всё то чего не хватало.

неее, слишком понадеялся. Там пусто..., не ну есть кое что, но абсолютно не то, что требуется

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-21 1:56:03

Что, никто не знает?

Гость
проходил мимо

Re: AS5300 и gnuGK

Непрочитанное сообщение Гость » 2009-11-21 2:02:21

как отладить utm биллинг лучше спросить на форуме UTM
или попробуй другой биллинг lanbilling у них тоже есть для VoIP - может с ним повезет больше

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-11-21 14:10:34

В том то и дело, что на форуме UTM партизаны собрались.

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-12-01 15:43:55

И так. После переписки с представителем нетапа разобрался.

выдержки пояснений из письма:
1.Судя по дебагу ядра, не создается сервисная связка для услуги телефонии. Пусть проверят, входит ли в состав тарифного плана с идентификатором 1 услуга телефонии и если входит, то установлена ли в её свойствах опция "Подключать поумолчанию".

2. Наиболее актуальная конфигурация - конфигурация по умолчанию, когда весь пин-код карты используется как логин. Такая конфигурация позволяет использовать максимальное количество карт и исключает вариант коллизии, если при генерации карт проверять уникальность пин-кодов и не создавать руками сервисных связок, имеющих логин такой же длины как пин-код и состоящий из тех же символов, которые могут использоваться в пин-коде.
Если же по каким-то причинам имеется необходимость разделить пин-код на несколько частей (без веской причины этого делать не рекомендуется), то в данном случае следует установить переменную ядра UTM5 card_tel_uid_len в нужное значение. Переменная описана в документации на страницах 120-121. Конфигурация циски в любом случае должна соответствовать конфигурации UTM5. Номер карты при авторегистрации пользователей в случае телефонии не используется.

Опцию "Экспорт в PIN-формате" устанавливать не нужно. Данная опция признана устаревшей и в новом интерфейсе администратора не используется.
Под пин-кодом подразумевается соответствующее свойство карты. В приведенном примере пин-кодом является 19655912. При этом номер карты (в примере - 5) при авторизации использовать не следует.
Приведенная конфигурация циски в данном случае не соответствует конфигурации UTM5. Указанная конфигурация будет работать, если в пин-коде карты 12 символов
(4 плюс 8), а переменная card_tel_uid_len установлена в значение, равное 4, однако использование подобной конфигурации сомнительно.
Насчёт 1-го ответа - я просто настраивал с нуля и забыл картам при создании тариф указать. А так же не поставил галочку "подключать услугу по умолчанию" в нужной услуге.

Насчёт второго ответа:
Вот это как раз тот косяк который допущен в манах по настройке. Там нигде не указано, что является пинкодом, что при выгрузке карт опция "Экспорт в PIN-формате" является устаревшей. и т.д. и т.п.

в общем выставил на циске в настройках IVR

Код: Выделить всё

call application voice debit uid-len 4
в настройках УТМ выставил параметр

Код: Выделить всё

card_tel_uid_len=4
Всё. Теперь по логам проходит авторизация карты, но циска сразу же кидает трубку - приходит Аккаунт-стоп пакет - в чём теперь косяк?
Вложения
utm_radius.log.txt
лог радиуса
(11.73 КБ) 25 скачиваний
Radius_monitor_CISCO.txt
на циске:
debug radius
term mon
(12.62 КБ) 29 скачиваний

Mobilesfinks
мл. сержант
Сообщения: 128
Зарегистрирован: 2008-04-14 14:49:48
Контактная информация:

Re: AS5300 и gnuGK

Непрочитанное сообщение Mobilesfinks » 2009-12-01 17:11:12

Во спасибо доброму человеку, подсказал глянуть debug voice ivr на циске
Обнаружил что какой то косяк в TCL скрипте - бум разбираться