Catalyst 4908G-L3 маршрутизация VLAN dot1q

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2008-10-14 0:01:17

купил сибе 2 шт. Catalyst 4908G-L3. Может кто подскажет, где нарыть документацию по настройке маршрутизации между VLAN (VLAN организованы на 2948G и 2980G).
топология будет простая - чистая звезда. есть 4 коммутатора (2980G) - они будут GBIC подключены к 4908G-L3. На каждом свиче висит около 11 VLAN. Нужно пропускать трафик между VLAN фильтруя NetBIOS. IP адресация в каждом VLAN своя.
Также в 4908G-L3 будет входить кабель от сервера который даёт пользователям инет.

PS Пока девайсы ещё не привезли, поэтому посмотреть и поклацать немогу. Ищу где почитать.
PSS cisco.com смотрел, но не получилось найти нужную инфу.

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2008-10-14 0:39:14

уже подсказали http://www.cisco.com/en/US/products/hw/ ... l#insertID
Тему продолжу - когда привезут оборудование. Пока учу матчасть :)


Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2009-09-28 23:21:33

Задача. Настроить 4908g-L3 так, что бы он гонял трафик между VLAN но пользователи спокойно выходили в инет.
IP адресация разная в каждом VLAN.
4908g-L3_pic2.png
Насколько я понял, нужно поднимать sub-интерфейсы для каждого VLAN.
по идее должно получится нечто следующее:

Код: Выделить всё

!
interface GigabitEthernet1
 ip address 192.168.0.80 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no cdp enable
!
interface GigabitEthernet1.1
 encapsulation dot1Q 1 native
 ip address 192.168.0.80 255.255.255.0
 no ip directed-broadcast
!
interface GigabitEthernet1.2
 encapsulation dot1Q 82
 ip address 10.8.2.2 255.255.255.0
 no ip directed-broadcast
ещё возник вопрос, нужно ли собирать интерфейсы на 4908G-L3 в bridge ?
на странице http://www.cisco.com/en/US/docs/switche ... #wp1024839
написано:
802.1Q VLAN bridging is a protocol for interconnecting multiple switches and maintaining VLAN information as traffic travels between switches. You can configure VLAN bridging on both the Catalyst 2948G-L3 and the Catalyst 4908G-L3 switch routers.

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение zingel » 2009-09-28 23:25:10

Z301171463546 - можно пожертвовать мне денег

Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2009-09-28 23:35:14

из этого букваря выплывает, что пользователь должен указать у себя в системе адрес шлюза такой, какой я укажу на подинтерфейсе в роутере? тогда как пользователь получит доступ к инету, ведь у него в настройках основной шлюз это IP сервера. Роутер должен только рулить трафик между VLAN.

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение zingel » 2009-09-28 23:36:35

я бы поставил гейт и на него бы зароутил все вланы и уже на гейте уже сам доступ бы организовывал
Z301171463546 - можно пожертвовать мне денег

Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2009-09-28 23:41:08

имеется ввиду на сервере рулить VLAN или спец роутер который будет и VLAN рулить и в инет выпускать и трафик для биллинга передавать?

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение zingel » 2009-09-28 23:42:51

нет роутить между вланами и вланы будет кошка а выход к вланам через гейт

Изображение

с поправкой на Вашу кошку


http://www.cisco.com/en/US/tech/tk389/t ... e74e.shtml
Z301171463546 - можно пожертвовать мне денег

Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2009-09-29 22:05:24

вообщем это приблизительно предыдущий пример. они предлагают использовать на конечном оборудовании IP адрес основного шлюза - адрес интерфейса маршрутизирующего свича. если пакет не предназначается кому-то из таблицы маршрутизации он отправляется дальше на основной роутер.
Configure your end devices to use the respective Catalyst 3550 VLAN interface as their default gateway. For example, devices in VLAN 2 should use the interface VLAN 2 IP address as its default gateway. Refer to the appropriate client configuration guide for more information on how to designate the default gateway.
почти подходит но смена сетевых реквизитов, это не есть гуд.

это я про этот вариант http://www.cisco.com/en/US/tech/tk389/t ... f17a.shtml

gurgen
проходил мимо

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение gurgen » 2009-10-07 12:07:04

zingel писал(а):нет роутить между вланами и вланы будет кошка а выход к вланам через гейт

Изображение

с поправкой на Вашу кошку


http://www.cisco.com/en/US/tech/tk389/t ... e74e.shtml
Не совсем ясно в этой схеме зачем на 3550 заводить интерфейс виланы с ип адресацией, да еще прописывать дефолтный маршрут? Или это от избытка ума? :ROFL:

Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2009-10-27 1:39:08

WhatsUp10002.PNG
WhatsUp10002.PNG (5.89 КБ) 3001 просмотр
не совсем понимаю как настраивать порты на 4908G
по ходу порты ни в групы ни в мосты объединять не нужно. просто пишешь порт в транк и всё. он по умолчанию будет работать как обычный свич? тоесть если пакет пришёл на первый порт и дальге ему нужно на 4 порт, то свич его и отправит так, или это нужно прописывать маршрутизацию на портах + IP адреса и всё остально?

сами VLAN пока будет маршрутизировать сервак, просто на сервак сейчас нужно загнать все VLAN.

Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2009-10-27 19:51:18

чтение документации помогло. вроди всё бегает.

Аватара пользователя
zingel
beastie
Сообщения: 6204
Зарегистрирован: 2007-10-30 3:56:49
Откуда: Moscow
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение zingel » 2009-10-27 22:02:56

а выложи конфиг что ли
Z301171463546 - можно пожертвовать мне денег

Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2010-04-23 14:01:39

Код: Выделить всё

!
version 12.0
service config
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 
!
enable secret 
enable password 
!
sdm size ipx-node 32 
sdm size ip-adjacency 4096 
sdm size ip-prefix 16384 
sdm size ipx-network 32 
sdm size ip-mcast 32 
sdm size l2-switching 128 
ip subnet-zero
ip multicast-routing
ip dvmrp route-limit 20000
ipx routing 0007.85ed.0200
bridge irb
!
!
!
interface Port-channel1
 no ip address
 no ip directed-broadcast
 hold-queue 300 in
!
interface GigabitEthernet1
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no negotiation auto
 no cdp enable
!
interface GigabitEthernet1.1
 encapsulation dot1Q 1 native
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 1
!
interface GigabitEthernet1.2
 encapsulation dot1Q 52
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 2
!
interface GigabitEthernet1.3
 encapsulation dot1Q 53
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 3
!
interface GigabitEthernet1.4
 encapsulation dot1Q 54
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 4
!
interface GigabitEthernet1.5
 encapsulation dot1Q 55
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 5
!
interface GigabitEthernet1.6
 encapsulation dot1Q 56
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 6
!
interface GigabitEthernet1.7
 encapsulation dot1Q 57
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 7
!
interface GigabitEthernet1.8
 encapsulation dot1Q 58
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 8
!
interface GigabitEthernet1.9
 encapsulation dot1Q 59
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 9
!
interface GigabitEthernet1.10
 encapsulation dot1Q 510
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 10
!
interface GigabitEthernet1.11
 encapsulation dot1Q 511
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 11
!
interface GigabitEthernet1.12
 encapsulation dot1Q 512
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 12
!
interface GigabitEthernet1.13
 encapsulation dot1Q 62
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 13
!
interface GigabitEthernet1.14
 encapsulation dot1Q 63
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 14
!
interface GigabitEthernet1.15
 encapsulation dot1Q 64
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 15
!
interface GigabitEthernet1.16
 encapsulation dot1Q 65
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 16
!
interface GigabitEthernet1.17
 encapsulation dot1Q 66
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 17
!
interface GigabitEthernet1.18
 encapsulation dot1Q 67
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 18
!
interface GigabitEthernet1.19
 encapsulation dot1Q 68
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 19
!
interface GigabitEthernet1.20
 encapsulation dot1Q 69
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 20
!
interface GigabitEthernet1.21
 encapsulation dot1Q 610
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 21
!
interface GigabitEthernet1.22
 encapsulation dot1Q 611
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 22
!
interface GigabitEthernet1.23
 encapsulation dot1Q 612
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 23
!
interface GigabitEthernet1.24
 encapsulation dot1Q 72
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 24
!
interface GigabitEthernet1.25
 encapsulation dot1Q 73
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 25
!
interface GigabitEthernet1.26
 encapsulation dot1Q 74
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 26
!
interface GigabitEthernet1.27
 encapsulation dot1Q 75
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 27
!
interface GigabitEthernet1.28
 encapsulation dot1Q 76
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 28
!
interface GigabitEthernet1.29
 encapsulation dot1Q 77
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 29
!
interface GigabitEthernet1.30
 encapsulation dot1Q 78
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 30
!
interface GigabitEthernet1.31
 encapsulation dot1Q 79
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 31
!
interface GigabitEthernet1.32
 encapsulation dot1Q 710
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 32
!
interface GigabitEthernet1.33
 encapsulation dot1Q 711
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 33
!
interface GigabitEthernet1.34
 encapsulation dot1Q 712
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 34
!
interface GigabitEthernet1.35
 encapsulation dot1Q 82
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 35
!
interface GigabitEthernet1.36
 encapsulation dot1Q 83
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 36
!
interface GigabitEthernet1.37
 encapsulation dot1Q 84
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 37
!
interface GigabitEthernet1.38
 encapsulation dot1Q 85
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 38
!
interface GigabitEthernet1.39
 encapsulation dot1Q 86
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 39
!
interface GigabitEthernet1.40
 encapsulation dot1Q 87
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 40
!
interface GigabitEthernet1.41
 encapsulation dot1Q 88
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 41
!
interface GigabitEthernet1.42
 encapsulation dot1Q 89
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 42
!
interface GigabitEthernet1.43
 encapsulation dot1Q 810
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 43
!
interface GigabitEthernet1.44
 encapsulation dot1Q 811
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 44
!
interface GigabitEthernet1.45
 encapsulation dot1Q 812
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 45
!
interface GigabitEthernet1.46
 encapsulation dot1Q 10
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 46
!
interface GigabitEthernet1.47
 encapsulation dot1Q 11
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 47
!
interface GigabitEthernet2
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no negotiation auto
 no cdp enable
!
interface GigabitEthernet2.1
 encapsulation dot1Q 1 native
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 46
!
interface GigabitEthernet2.2
 encapsulation dot1Q 10
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 46
!
interface GigabitEthernet2.3
 encapsulation dot1Q 11
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 47
!
interface GigabitEthernet3
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no negotiation auto
 no cdp enable
!
interface GigabitEthernet3.1
 encapsulation dot1Q 1 native
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 46
!
interface GigabitEthernet3.2
 encapsulation dot1Q 11
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 47
!
interface GigabitEthernet4
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no cdp enable
!
interface GigabitEthernet5
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no negotiation auto
 no cdp enable
!
interface GigabitEthernet5.1
 encapsulation dot1Q 1 native
 no ip directed-broadcast
 bridge-group 1
!
interface GigabitEthernet5.2
 encapsulation dot1Q 52
 no ip directed-broadcast
 bridge-group 2
!
interface GigabitEthernet5.3
 encapsulation dot1Q 53
 no ip directed-broadcast
 bridge-group 3
!
interface GigabitEthernet5.4
 encapsulation dot1Q 54
 no ip directed-broadcast
 bridge-group 4
!
interface GigabitEthernet5.5
 encapsulation dot1Q 55
 no ip directed-broadcast
 bridge-group 5
!
interface GigabitEthernet5.6
 encapsulation dot1Q 56
 no ip directed-broadcast
 bridge-group 6
!
interface GigabitEthernet5.7
 encapsulation dot1Q 57
 no ip directed-broadcast
 bridge-group 7
!
interface GigabitEthernet5.8
 encapsulation dot1Q 58
 no ip directed-broadcast
 bridge-group 8
!
interface GigabitEthernet5.9
 encapsulation dot1Q 59
 no ip directed-broadcast
 bridge-group 9
!
interface GigabitEthernet5.10
 encapsulation dot1Q 510
 no ip directed-broadcast
 bridge-group 10
!
interface GigabitEthernet5.11
 encapsulation dot1Q 511
 no ip directed-broadcast
 bridge-group 11
!
interface GigabitEthernet5.12
 encapsulation dot1Q 512
 no ip directed-broadcast
 bridge-group 12
!
interface GigabitEthernet5.13
 encapsulation dot1Q 82
 no ip directed-broadcast
 bridge-group 35
!
interface GigabitEthernet5.14
 encapsulation dot1Q 83
 no ip directed-broadcast
 bridge-group 36
!
interface GigabitEthernet5.15
 encapsulation dot1Q 84
 no ip directed-broadcast
 bridge-group 37
!
interface GigabitEthernet5.16
 encapsulation dot1Q 85
 no ip directed-broadcast
 bridge-group 38
!
interface GigabitEthernet5.17
 encapsulation dot1Q 86
 no ip directed-broadcast
 bridge-group 39
!
interface GigabitEthernet5.18
 encapsulation dot1Q 87
 no ip directed-broadcast
 bridge-group 40
!
interface GigabitEthernet5.19
 encapsulation dot1Q 88
 no ip directed-broadcast
 bridge-group 41
!
interface GigabitEthernet5.20
 encapsulation dot1Q 89
 no ip directed-broadcast
 bridge-group 42
!
interface GigabitEthernet5.21
 encapsulation dot1Q 810
 no ip directed-broadcast
 bridge-group 43
!
interface GigabitEthernet5.22
 encapsulation dot1Q 811
 no ip directed-broadcast
 bridge-group 44
!
interface GigabitEthernet5.23
 encapsulation dot1Q 812
 no ip directed-broadcast
 bridge-group 45
!
interface GigabitEthernet5.24
 encapsulation dot1Q 10
 no ip directed-broadcast
 bridge-group 46
!
interface GigabitEthernet5.25
 encapsulation dot1Q 11
 no ip directed-broadcast
 bridge-group 47
!
interface GigabitEthernet6
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no negotiation auto
 no cdp enable
!
interface GigabitEthernet6.1
 encapsulation dot1Q 1 native
 no ip directed-broadcast
 bridge-group 1
!
interface GigabitEthernet6.2
 encapsulation dot1Q 62
 no ip directed-broadcast
 bridge-group 13
!
interface GigabitEthernet6.3
 encapsulation dot1Q 63
 no ip directed-broadcast
 bridge-group 14
!
interface GigabitEthernet6.4
 encapsulation dot1Q 64
 no ip directed-broadcast
 bridge-group 15
!
interface GigabitEthernet6.5
 encapsulation dot1Q 65
 no ip directed-broadcast
 bridge-group 16
!
interface GigabitEthernet6.6
 encapsulation dot1Q 66
 no ip directed-broadcast
 bridge-group 17
!
interface GigabitEthernet6.7
 encapsulation dot1Q 67
 no ip directed-broadcast
 bridge-group 18
!
interface GigabitEthernet6.8
 encapsulation dot1Q 68
 no ip directed-broadcast
 bridge-group 19
!
interface GigabitEthernet6.9
 encapsulation dot1Q 69
 no ip directed-broadcast
 bridge-group 20
!
interface GigabitEthernet6.10
 encapsulation dot1Q 610
 no ip directed-broadcast
 bridge-group 21
!
interface GigabitEthernet6.11
 encapsulation dot1Q 611
 no ip directed-broadcast
 bridge-group 22
!
interface GigabitEthernet6.12
 encapsulation dot1Q 612
 no ip directed-broadcast
 bridge-group 23
!
interface GigabitEthernet6.13
 encapsulation dot1Q 11
 no ip directed-broadcast
 bridge-group 47
!
interface GigabitEthernet7
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no negotiation auto
 no cdp enable
!
interface GigabitEthernet7.1
 encapsulation dot1Q 1 native
 no ip directed-broadcast
 bridge-group 1
!
interface GigabitEthernet7.2
 encapsulation dot1Q 72
 no ip directed-broadcast
 bridge-group 24
!
interface GigabitEthernet7.3
 encapsulation dot1Q 73
 no ip directed-broadcast
 bridge-group 25
!
interface GigabitEthernet7.4
 encapsulation dot1Q 74
 no ip directed-broadcast
 bridge-group 26
!
interface GigabitEthernet7.5
 encapsulation dot1Q 75
 no ip directed-broadcast
 bridge-group 27
!
interface GigabitEthernet7.6
 encapsulation dot1Q 76
 no ip directed-broadcast
 bridge-group 28
!
interface GigabitEthernet7.7
 encapsulation dot1Q 77
 no ip directed-broadcast
 bridge-group 29
!
interface GigabitEthernet7.8
 encapsulation dot1Q 78
 no ip directed-broadcast
 bridge-group 30
!
interface GigabitEthernet7.9
 encapsulation dot1Q 79
 no ip directed-broadcast
 bridge-group 31
!
interface GigabitEthernet7.10
 encapsulation dot1Q 710
 no ip directed-broadcast
 bridge-group 32
!
interface GigabitEthernet7.11
 encapsulation dot1Q 711
 no ip directed-broadcast
 bridge-group 33
!
interface GigabitEthernet7.12
 encapsulation dot1Q 712
 no ip directed-broadcast
 bridge-group 34
!
interface GigabitEthernet7.13
 encapsulation dot1Q 11
 no ip directed-broadcast
 bridge-group 47
!
interface GigabitEthernet8
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no negotiation auto
 no cdp enable
!
interface GigabitEthernet8.1
 encapsulation dot1Q 1 native
 no ip directed-broadcast
 bridge-group 1
!
interface GigabitEthernet8.2
 encapsulation dot1Q 82
 no ip directed-broadcast
 bridge-group 35
!
interface GigabitEthernet8.3
 encapsulation dot1Q 83
 no ip directed-broadcast
 bridge-group 36
!
interface GigabitEthernet8.4
 encapsulation dot1Q 84
 no ip directed-broadcast
 bridge-group 37
!
interface GigabitEthernet8.5
 encapsulation dot1Q 85
 no ip directed-broadcast
 bridge-group 38
!
interface GigabitEthernet8.6
 encapsulation dot1Q 86
 no ip directed-broadcast
 bridge-group 39
!
interface GigabitEthernet8.7
 encapsulation dot1Q 87
 no ip directed-broadcast
 bridge-group 40
!
interface GigabitEthernet8.8
 encapsulation dot1Q 88
 no ip directed-broadcast
 bridge-group 41
!
interface GigabitEthernet8.9
 encapsulation dot1Q 89
 no ip directed-broadcast
 bridge-group 42
!
interface GigabitEthernet8.10
 encapsulation dot1Q 810
 no ip directed-broadcast
 bridge-group 43
!
interface GigabitEthernet8.11
 encapsulation dot1Q 811
 no ip directed-broadcast
 bridge-group 44
!
interface GigabitEthernet8.12
 encapsulation dot1Q 812
 no ip directed-broadcast
 bridge-group 45
!
interface GigabitEthernet8.13
 encapsulation dot1Q 10
 no ip directed-broadcast
 no ip mroute-cache
 bridge-group 46
!
interface GigabitEthernet8.14
 encapsulation dot1Q 11
 no ip directed-broadcast
 bridge-group 47
!
interface BVI1
 ip address 192.168.0.100 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
 ipx network 1000
!
interface BVI2
 ip address 10.5.2.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI3
 ip address 10.5.3.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI4
 ip address 10.5.4.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI5
 ip address 10.5.5.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI6
 ip address 10.5.6.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI7
 ip address 10.5.7.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI8
 ip address 10.5.8.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI9
 ip address 10.5.9.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI10
 ip address 10.5.10.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI11
 ip address 10.5.11.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI12
 ip address 10.5.12.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI13
 ip address 10.6.2.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI14
 ip address 10.6.3.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI15
 ip address 10.6.4.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI16
 ip address 10.6.5.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI17
 ip address 10.6.6.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI18
 ip address 10.6.7.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI19
 ip address 10.6.8.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI20
 ip address 10.6.9.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI21
 ip address 10.6.10.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI22
 ip address 10.6.11.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI23
 ip address 10.6.12.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI24
 ip address 10.7.2.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI25
 ip address 10.7.3.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI26
 ip address 10.7.4.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI27
 ip address 10.7.5.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI28
 ip address 10.7.6.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI29
 ip address 10.7.7.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI30
 ip address 10.7.8.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI31
 ip address 10.7.9.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI32
 ip address 10.7.10.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI33
 ip address 10.7.11.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI34
 ip address 10.7.12.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI35
 ip address 10.8.2.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI36
 ip address 10.8.3.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI37
 ip address 10.8.4.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI38
 ip address 10.8.5.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI39
 ip address 10.8.6.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI40
 ip address 10.8.7.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI41
 ip address 10.8.8.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI42
 ip address 10.8.9.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI43
 ip address 10.8.10.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI44
 ip address 10.8.11.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI45
 ip address 10.8.12.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI46
 ip address 10.10.10.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
interface BVI47
 ip address 195.xxxxxxx.2 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-mode
 no ip route-cache cef
!
ip classless
ip route 0.0.0.0 0.0.0.0 BVI1 192.168.0.1
ip route 0.0.0.0 0.0.0.0 BVI2 10.5.2.1
ip route 0.0.0.0 0.0.0.0 BVI3 10.5.3.1
ip route 0.0.0.0 0.0.0.0 BVI4 10.5.4.1
ip route 0.0.0.0 0.0.0.0 BVI5 10.5.5.1
ip route 0.0.0.0 0.0.0.0 BVI6 10.5.6.1
ip route 0.0.0.0 0.0.0.0 BVI7 10.5.7.1
ip route 0.0.0.0 0.0.0.0 BVI8 10.5.8.1
ip route 0.0.0.0 0.0.0.0 BVI9 10.5.9.1
ip route 0.0.0.0 0.0.0.0 BVI10 10.5.10.1
ip route 0.0.0.0 0.0.0.0 BVI11 10.5.11.1
ip route 0.0.0.0 0.0.0.0 BVI12 10.5.12.1
ip route 0.0.0.0 0.0.0.0 BVI13 10.6.2.1
ip route 0.0.0.0 0.0.0.0 BVI14 10.6.3.1
ip route 0.0.0.0 0.0.0.0 BVI15 10.6.4.1
ip route 0.0.0.0 0.0.0.0 BVI16 10.6.5.1
ip route 0.0.0.0 0.0.0.0 BVI17 10.6.6.1
ip route 0.0.0.0 0.0.0.0 BVI18 10.6.7.1
ip route 0.0.0.0 0.0.0.0 BVI19 10.6.8.1
ip route 0.0.0.0 0.0.0.0 BVI20 10.6.9.1
ip route 0.0.0.0 0.0.0.0 BVI21 10.6.10.1
ip route 0.0.0.0 0.0.0.0 BVI22 10.6.11.1
ip route 0.0.0.0 0.0.0.0 BVI23 10.6.12.1
ip route 0.0.0.0 0.0.0.0 BVI24 10.7.2.1
ip route 0.0.0.0 0.0.0.0 BVI25 10.7.3.1
ip route 0.0.0.0 0.0.0.0 BVI26 10.7.4.1
ip route 0.0.0.0 0.0.0.0 BVI27 10.7.5.1
ip route 0.0.0.0 0.0.0.0 BVI28 10.7.6.1
ip route 0.0.0.0 0.0.0.0 BVI29 10.7.7.1
ip route 0.0.0.0 0.0.0.0 BVI30 10.7.8.1
ip route 0.0.0.0 0.0.0.0 BVI31 10.7.9.1
ip route 0.0.0.0 0.0.0.0 BVI32 10.7.10.1
ip route 0.0.0.0 0.0.0.0 BVI33 10.7.11.1
ip route 0.0.0.0 0.0.0.0 BVI34 10.7.12.1
ip route 0.0.0.0 0.0.0.0 BVI35 10.8.2.1
ip route 0.0.0.0 0.0.0.0 BVI36 10.8.3.1
ip route 0.0.0.0 0.0.0.0 BVI37 10.8.4.1
ip route 0.0.0.0 0.0.0.0 BVI38 10.8.5.1
ip route 0.0.0.0 0.0.0.0 BVI39 10.8.6.1
ip route 0.0.0.0 0.0.0.0 BVI40 10.8.7.1
ip route 0.0.0.0 0.0.0.0 BVI41 10.8.8.1
ip route 0.0.0.0 0.0.0.0 BVI42 10.8.9.1
ip route 0.0.0.0 0.0.0.0 BVI43 10.8.10.1
ip route 0.0.0.0 0.0.0.0 BVI44 10.8.11.1
ip route 0.0.0.0 0.0.0.0 BVI45 10.8.12.1
ip route 0.0.0.0 0.0.0.0 BVI46 10.10.10.1
ip route 0.0.0.0 0.0.0.0 BVI47 195.xxxxxxx.1
ip http port 8080
ip http access-class 1
!
access-list 1 permit 192.168.0.1
access-list 1 permit 109.xxxxxxxxxxx
access-list 1 permit 195.xxxxxxxxxxx
snmp-server community xxx
snmp-server community xxx
snmp-server community xxx
!
!
!
bridge 1 protocol ieee
 bridge 1 route ip
 bridge 1 route ipx
bridge 2 protocol ieee
 bridge 2 route ip
 bridge 2 route ipx
bridge 3 protocol ieee
 bridge 3 route ip
 bridge 3 route ipx
bridge 4 protocol ieee
 bridge 4 route ip
 bridge 4 route ipx
bridge 5 protocol ieee
 bridge 5 route ip
 bridge 5 route ipx
bridge 6 protocol ieee
 bridge 6 route ip
 bridge 6 route ipx
bridge 7 protocol ieee
 bridge 7 route ip
 bridge 7 route ipx
bridge 8 protocol ieee
 bridge 8 route ip
 bridge 8 route ipx
bridge 9 protocol ieee
 bridge 9 route ip
 bridge 9 route ipx
bridge 10 protocol ieee
 bridge 10 route ip
 bridge 10 route ipx
bridge 11 protocol ieee
 bridge 11 route ip
 bridge 11 route ipx
bridge 12 protocol ieee
 bridge 12 route ip
 bridge 12 route ipx
bridge 13 protocol ieee
 bridge 13 route ip
 bridge 13 route ipx
bridge 14 protocol ieee
 bridge 14 route ip
 bridge 14 route ipx
bridge 15 protocol ieee
 bridge 15 route ip
 bridge 15 route ipx
bridge 16 protocol ieee
 bridge 16 route ip
 bridge 16 route ipx
bridge 17 protocol ieee
 bridge 17 route ip
 bridge 17 route ipx
bridge 18 protocol ieee
 bridge 18 route ip
 bridge 18 route ipx
bridge 19 protocol ieee
 bridge 19 route ip
 bridge 19 route ipx
bridge 20 protocol ieee
 bridge 20 route ip
 bridge 20 route ipx
bridge 21 protocol ieee
 bridge 21 route ip
 bridge 21 route ipx
bridge 22 protocol ieee
 bridge 22 route ip
 bridge 22 route ipx
bridge 23 protocol ieee
 bridge 23 route ip
 bridge 23 route ipx
bridge 24 protocol ieee
 bridge 24 route ip
 bridge 24 route ipx
bridge 25 protocol ieee
 bridge 25 route ip
 bridge 25 route ipx
bridge 26 protocol ieee
 bridge 26 route ip
 bridge 26 route ipx
bridge 27 protocol ieee
 bridge 27 route ip
 bridge 27 route ipx
bridge 28 protocol ieee
 bridge 28 route ip
 bridge 28 route ipx
bridge 29 protocol ieee
 bridge 29 route ip
 bridge 29 route ipx
bridge 30 protocol ieee
 bridge 30 route ip
 bridge 30 route ipx
bridge 31 protocol ieee
 bridge 31 route ip
 bridge 31 route ipx
bridge 32 protocol ieee
 bridge 32 route ip
 bridge 32 route ipx
bridge 33 protocol ieee
 bridge 33 route ip
 bridge 33 route ipx
bridge 34 protocol ieee
 bridge 34 route ip
 bridge 34 route ipx
bridge 35 protocol ieee
 bridge 35 route ip
 bridge 35 route ipx
bridge 36 protocol ieee
 bridge 36 route ip
 bridge 36 route ipx
bridge 37 protocol ieee
 bridge 37 route ip
 bridge 37 route ipx
bridge 38 protocol ieee
 bridge 38 route ip
 bridge 38 route ipx
bridge 39 protocol ieee
 bridge 39 route ip
 bridge 39 route ipx
bridge 40 protocol ieee
 bridge 40 route ip
 bridge 40 route ipx
bridge 41 protocol ieee
 bridge 41 route ip
 bridge 41 route ipx
bridge 42 protocol ieee
 bridge 42 route ip
 bridge 42 route ipx
bridge 43 protocol ieee
 bridge 43 route ip
 bridge 43 route ipx
bridge 44 protocol ieee
 bridge 44 route ip
 bridge 44 route ipx
bridge 45 protocol ieee
 bridge 45 route ip
 bridge 45 route ipx
bridge 46 protocol ieee
 bridge 46 route ip
 bridge 46 route ipx
bridge 47 protocol ieee
 bridge 47 route ip
 bridge 47 route ipx
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password snapshots
 login
!
end

Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2010-04-23 14:11:52

блин, в предыдущее сообщение хотел добавить, а мне написало, что, мол, уже низзя...

Только есть несколько нюансов.
1. Почему-то

Код: Выделить всё

router-01#sh ip route static
S*   0.0.0.0/0 [1/0] via 10.10.10.1, BVI46
               [1/0] via 195.xxxxxx.1, BVI47
               [1/0] via 10.5.2.1, BVI2
               [1/0] via 10.5.3.1, BVI3
               [1/0] via 10.5.4.1, BVI4
               [1/0] via 10.5.5.1, BVI5
выводит только 6 статических маршрутов, хотя в конфиге прописаны все. На практике не пробовал наличие маршрутизации из "не выведеных маршрутов" -- может работает.

2. Так как планирую запустить мультикаст то возникла проблема, что CGMP (а мой девайс не поддерживает напрямую IGMP) не работает через BVI. Пока не знаю как выкрутится из этой ситуации. Возможно нужно будет поднимать PIM не на BVI а на GigabitEthernet X.X (подинтерфейс)

Al
ст. прапорщик
Сообщения: 501
Зарегистрирован: 2007-10-18 13:42:48
Откуда: Тверь
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Al » 2010-04-26 12:17:33

zingel писал(а):а выложи конфиг что ли
Аккуратнее с такими предложениями, когда речь идет о дохренапортовых коммутаторах)
ЗЫ. особо не вчитывался, но нахрен столько роутов в конфиге и их смысл?

Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2010-04-30 20:22:27

для маршрутизации VLAN.
статические роуты для доступа клиента в инет, так как шлюз в инет это другая железка.

Al
ст. прапорщик
Сообщения: 501
Зарегистрирован: 2007-10-18 13:42:48
Откуда: Тверь
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Al » 2010-05-01 8:55:38

А чем просто маршрут по умолчанию не нравится?
Ладно, разбираться откровенно лень... Просто первый раз такую картину увидел. Тем более, авторитетные пацаны уже отписались)
ЗЫ, классическая схема маршрутизации вланов - все физические порты в транки, на каждый влан свой вирт. интерфейс с адресм (он шлюз у всех компов этого влана) и один стат. маршрут по умолчанию (на другую железку) в интернет и на другие сети.
Маршрутизацию между вланами коммутатор делает сам, так как сети директли коннектед.

Inzevision
мл. сержант
Сообщения: 102
Зарегистрирован: 2008-07-30 13:43:00
Откуда: Киев
Контактная информация:

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение Inzevision » 2010-05-30 16:36:42

это так на старших версиях. но на 4908G-L3 и 2948-L3 нужно создавать виртуальный интерефейс BVI и уже этим интерфейсом оперировать. Я пробовал прописать один маршрут - не получилось. Только так, как есть :(
Вообще-то 4908 мощная железка из своей ценовой категории.

camelot@col.ru
проходил мимо

Re: Catalyst 4908G-L3 маршрутизация VLAN dot1q

Непрочитанное сообщение camelot@col.ru » 2010-08-09 20:11:10

а там разве нельзя на порту сказать

Код: Выделить всё

Interface <>
 switchport trunk encapsulation dot1q
 switchport mode trunk
после этого создать содать необходимые int vlan Х с соответствующими адресами на них.

просто с bvi может получиться что производительность свича упадет ниже плинтуса, несмотря на продвинутость свича.

ЗЫ: Маршрутизируются не vlan-ы а сети.