Cisco 1811 после падения не поднимается резервный канал

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Vlad@
рядовой
Сообщения: 29
Зарегистрирован: 2009-10-23 17:48:58

Cisco 1811 после падения не поднимается резервный канал

Непрочитанное сообщение Vlad@ » 2011-11-27 16:14:36

Привет!
После падения, резервный канал не поднимается!
Дано Cisco 1811 catalist, ISP-1 основной канал, ISP-2 резервный (ADSL-динамический IP)

Код: Выделить всё

track timer interface 5
!
track 1 rtr 1 reachability
 delay down 15 up 15
!
track 2 rtr 2 reachability
 delay down 15 up 15
!
ip route 0.0.0.0 0.0.0.0 FastEthernet1 track 1
ip route 0.0.0.0 0.0.0.0 Dialer0 track 2
!
ip nat inside source route-map ISP-1 interface FastEthernet1 overload
ip nat inside source route-map ISP-2 interface Dialer0 overload
!
ip sla 1
 icmp-echo 192.168.0.1 source-interface FastEthernet1
 timeout 1000
 threshold 40
 frequency 3
ip sla schedule 1 life forever start-time now
!
ip sla 2
 icmp-echo 8.8.8.8 source-interface Dialer0
 timeout 1000
 threshold 40
 frequency 3
ip sla schedule 2 life forever start-time now
!
access-list 11 remark -= NAT =-
access-list 11 permit 192.168.40.0 0.0.0.7
!
!
route-map ISP-1 permit 10
 match ip address 11
 match interface FastEthernet1
!
route-map ISP-2 permit 10
 match ip address 11
 match interface Dialer0
Включениие Cisco (reload) если канал ISP-1 отклычен то

Код: Выделить всё

R1#sh track
Track 1
  Response Time Reporter 1 reachability
  Reachability is Down
    2 changes, last change 00:27:50
  Delay up 15 secs, down 15 secs
  Latest operation return code: Timeout
  Tracked by:
    STATIC-IP-ROUTING 0
Track 2
  Response Time Reporter 2 reachability
  Reachability is Up
    1 change, last change 00:28:33
  Delay up 15 secs, down 15 secs
  Latest operation return code: Over threshold
  Latest RTT (millisecs) 52
  Tracked by:
    STATIC-IP-ROUTING 0
Но если выдернуть телефонный кабель из модема или отключить его, то после включения - Track 2 не поднимается!

Код: Выделить всё

R1#sh int dialer 0
Dialer0 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Description: -= ISP2 : track 2 =-
  Internet address is 95.13x.xxx.xx/32
  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 4/255, rxload 4/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Vi2
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:26:42
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 42 kilobits/sec
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     3220 packets input, 1344777 bytes
     3018 packets output, 382589 bytes
Bound to:
Virtual-Access2 is up, line protocol is up
  Hardware is Virtual Access interface
  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Listen: CDPCP
  Open: IPCP
  PPPoE vaccess, cloned from Dialer0
  Vaccess status 0x44, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Interface is bound to Di0 (Encapsulation PPP)
  Last input 00:00:02, output never, output hang never
  Last clearing of "show interface" counters 00:26:50
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     3239 packets input, 1345284 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     3040 packets output, 383405 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

Как его заставить работать!

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
vintovkin
ВДВ
Сообщения: 1284
Зарегистрирован: 2007-05-11 9:39:11
Откуда: CSKA

Re: Cisco 1811 после падения не поднимается резервный канал

Непрочитанное сообщение vintovkin » 2011-12-05 16:34:19

попробуй позвонить провайдеру и сдать ему эту проблему, может на его оборудовании порт залип.
Junos OS kernel based on FreeBSD UNIX.

Vlad@
рядовой
Сообщения: 29
Зарегистрирован: 2009-10-23 17:48:58

Re: Cisco 1811 после падения не поднимается резервный канал

Непрочитанное сообщение Vlad@ » 2012-01-05 12:10:05

Скорее всего не залипания порта, т.к. если не использовать sla cisco работает идеально и при обрыве связи (а такое периодически бывает по вине ISP) соединение восстанавливается! На форуме Cisco
я натолкнулся на такую же проблему. По всей видимости резервный канал будет работать только с статическим IP для ADSL !!!