Cisco 3845 + 4-E1

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
TiRider
рядовой
Сообщения: 11
Зарегистрирован: 2010-08-20 9:50:35

Cisco 3845 + 4-E1

Непрочитанное сообщение TiRider » 2010-10-23 12:00:40

Доброго времени суток всем!

В общем понять не могу, т.к. не сильно знаком с телефонией. Суть проблемы опишу.

Имеется маршрутизатор Cisco 3845 + 2 платы E1 потока (HWIC-2CE1T1-PRI) итого 4 RJ-48.

Состоит задача на 1 порт E1 получать со спутника (через спутниковый модем) телефонию. Остальных 3 порта Е1 передают информацию на станцию АТС (звонки чтобы шли через маршрутизатор, можно было совершать звонки как внутри фирмы, так и за пределы, через 1 порт на спутник). Станция цифровая. Понять не могу, как настроить это все дело... Причина? Не сильно силен в телефонии. Это факт. Помогите друзья, хотя бы какую-нибудь подсказку. Статей по настройке именно такой конфиги, не нашел :(

На маршрутизаторе изначально стоял IOS - c3845-ipbase-mz.150-1.M3.bin. Установил вместо, вот такой c3845-adventerprisek9-mz.151-2.T1.bin.

Заранее благодарен!

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение skeletor » 2010-10-25 9:14:22

АТС-ки у вас могут принимать потоки E1?

TiRider
рядовой
Сообщения: 11
Зарегистрирован: 2010-08-20 9:50:35

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение TiRider » 2010-10-25 10:15:51

конечно.

TiRider
рядовой
Сообщения: 11
Зарегистрирован: 2010-08-20 9:50:35

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение TiRider » 2010-10-25 10:21:44

Примерный конфиг накидал. Могу сюда выложить. Хз, правильно или нет...

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение skeletor » 2010-10-25 10:41:53

Выкладывай.

TiRider
рядовой
Сообщения: 11
Зарегистрирован: 2010-08-20 9:50:35

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение TiRider » 2010-10-25 11:16:33

Код: Выделить всё

!
version 15.1
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname c3845-adm-mcs
!
boot-start-marker
boot system flash:/c3845-adventerprisek9-mz.151-2.T1.bin
boot-end-marker
!
!
card type e1 0 0
card type e1 0 1
logging buffered 51200 warnings
!
no aaa new-model
!
clock timezone KRAST 7 0
clock summer-time KRAST recurring last Sun Mar 2:00 last Sun Oct 2:00
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 E1 0/0/0
network-clock-select 2 E1 0/0/1
network-clock-select 3 E1 0/1/0
network-clock-select 4 E1 0/1/1
!
dot11 syslog
ip source-route
!
ip cef
!
!
!
!
ip domain name mcs.local
ip name-server 2.3.4.2
ip name-server 2.3.4.3
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
isdn voice-call-failure 0
isdn logging
carrier-id source
!
voice-card 0
!
!
voice call send-alert
voice call carrier capacity active
voice rtp send-recv
!
voice service pots
 supported-language RU
!
voice class codec 1
 codec preference 1 g729br8
 codec preference 2 g729r8
 codec preference 3 g726r16
 codec preference 4 g726r24
 codec preference 5 g726r32
 codec preference 6 g723r53
 codec preference 7 g723ar53
 codec preference 8 g723r63
 codec preference 9 g723ar63
 codec preference 10 g711alaw
 codec preference 11 g711ulaw
!
!
!
!
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO3845-MB sn FOC14270HPJ
archive
 log config
  hidekeys
 path tftp://172.16.1.1/c3845-adm-mcs.cfg
 write-memory
username admin privilege 15 secret 5 1234567890
!
redundancy
!
!
controller E1 0/0/0
 framing NO-CRC4
 pri-group timeslots 1-31
 description --Link_Modem_CDM-600_DB-15--
!
controller E1 0/0/1
 framing NO-CRC4
 pri-group timeslots 1-31 service mgcp
 description --Link_134_ATC_DX-500_Port3--
!
controller E1 0/1/0
 framing NO-CRC4
 pri-group timeslots 1-31 service mgcp
 description --Link_135_ATC_DX-500_Port2--
!
controller E1 0/1/1
 framing NO-CRC4
 pri-group timeslots 1-31 service mgcp
 description --Link_136_ATC_DX-500_Port1--
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
 ip address 2.3.4.14 255.255.255.240
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/1
 no ip address
 ip flow ingress
 ip route-cache policy
 duplex full
 speed 1000
 media-type rj45
 snmp ifindex persist
!
interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 no cdp enable
!
interface Serial0/0/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn overlap-receiving
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete
 no cdp enable
!
interface Serial0/1/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
interface Serial0/1/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
router ospf 1
 redistribute connected subnets
 redistribute static subnets
 passive-interface default
!
router bgp 64567
 bgp router-id 1.2.3.4
 bgp log-neighbor-changes
 network 2.3.4.0 mask 255.255.255.0
 aggregate-address 2.3.4.0 255.255.255.0 summary-only
 redistribute connected
 redistribute static
 neighbor ROSTELECOM peer-group
 neighbor ROSTELECOM remote-as 64600
 neighbor ROSTELECOM next-hop-self
 neighbor ROSTELECOM send-community both
 neighbor ROSTELECOM prefix-list 1 out
 neighbor ROSTELECOM maximum-prefix 300 restart 10
 neighbor 1.2.3.4 peer-group ROSTELECOM
 no auto-summary
!
ip default-gateway 2.3.4.14
ip forward-protocol nd
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip bgp-community new-format
ip as-path access-list 1 deny ^$
ip as-path access-list 1 permit .*
ip flow-export version 5
!
ip route 0.0.0.0 0.0.0.0 1.2.3.4
ip route 2.3.4.0 255.255.255.0 Null0 254
!
!
ip prefix-list 1 seq 5 permit 2.3.4.0/24
logging esm config
access-list 14 permit 2.3.4.0 0.0.0.15
access-list 14 deny   any
!
!
!
!
snmp-server community public RO 14
snmp-server ifindex persist
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
 logging synchronous
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input ssh
line vty 5 15
 access-class 14 in
 privilege level 15
 login local
 transport input ssh
!
scheduler allocate 20000 1000
end

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение skeletor » 2010-10-25 11:43:39

Такой конфиг написали, а говорите, что не знаете с чего начать. Теперь осталось настроить маршрутизацию звонков. Знаю, что в настройке dial-peer voice voip за это отвечает параметр destination-pattern. Но у тебя e1-e1, видимо там должно быть что-то похожее.

TiRider
рядовой
Сообщения: 11
Зарегистрирован: 2010-08-20 9:50:35

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение TiRider » 2010-10-25 11:52:28

А поподробнее? Примерный конфиг этого.

Аватара пользователя
skeletor
майор
Сообщения: 2548
Зарегистрирован: 2007-11-16 18:22:04

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение skeletor » 2010-10-25 12:02:43

Но это для e1-sip

Код: Выделить всё

dial-peer voice 1000 voip
 application session
 destination-pattern 1...
 session protocol sipv2
 session target sip-server
 codec g711alaw
 no vad


TiRider
рядовой
Сообщения: 11
Зарегистрирован: 2010-08-20 9:50:35

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение TiRider » 2010-10-30 12:43:37

Установил PVDM2-32. Вроде ввожу нужные команды на циске.

При настройке интерфейса Serial0/0/0:15, по сути должен появляться подинтерфейс voice-port 0/0/0:15 а его нет! Пытаюсь создать, а команды такой нет :( Иосов испробовал штук 10, все равно не работает... Что делать я не знаю :(

Подскажите люди добрые!

TiRider
рядовой
Сообщения: 11
Зарегистрирован: 2010-08-20 9:50:35

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение TiRider » 2010-11-14 12:58:02

Собственно нужны были другие платы. Купили плату VWIC-2MFT-E1 и PVDM2-32.

Встает следующий вопрос, помогите кто может.
Вроде настраиваю Serial как нужно, делаю звонок с одного номера на другой, звонок не проходит... в трубке постоянно длинный сигнал. В дебаге: Interface Serial0/1/0:9 is now connected to 2916ххх N/A
%ISDN-6-CONNECT: Interface Serial0/1/0:9 is now connected to 2916ххх N/A затем через секунд 5 короткие...

Первое что хотелось бы, чтобы звонки проходили. Как сделать?

1. Так же есть задача, во внутренней сети используются 3х значные номера (120-420), как сделать так чтобы при наборе номера из вне, на номер 2909ххх (где ххх это 120-420) звонок проходил.
2. Следующий пункт, это выход на корпоративную сеть и межгород. Чтобы при наборе 7_префикс некий_телефонный номер, звонки уходили в корпоративную сеть, а при наборе 8_код_телефонный номер -> на межгород.

Как уже раньше сказал, внутри фирмы используются 3х значные номера как цифровые, так и аналоговые.

Буду очень благодарен, кто натолкнет и подскажет, как это правильно сделать!

инкогнито
проходил мимо

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение инкогнито » 2010-12-18 0:33:03

а вы уверены что у вас TDM hairpining вообще будет работать на 38хх? мне кажется, что это только AS53хх может делать, да и то не с любым IOS'ом. В общем, успехов вам...

TiRider
рядовой
Сообщения: 11
Зарегистрирован: 2010-08-20 9:50:35

Re: Cisco 3845 + 4-E1

Непрочитанное сообщение TiRider » 2010-12-19 21:47:51

Все сделал. Все работает :) будет время напишу что да как сделал :)