cisco 831 отваливается DNS

Juniper/Cisco/Allied Telesis/D-Link/Zyxel
Правила форума
Убедительная просьба юзать теги [code] при оформлении листингов.
Сообщения не оформленные должным образом имеют все шансы быть незамеченными.
Аватара пользователя
squid
лейтенант
Сообщения: 683
Зарегистрирован: 2007-05-25 11:32:23
Откуда: Украина, Киев
Контактная информация:

cisco 831 отваливается DNS

Непрочитанное сообщение squid » 2008-05-28 9:51:53

есть сеть из 4 компов и cisco 831
на wan циска получает динамически айпи адрес и адреса днс серверов
также настроен DNS Proxy

Код: Выделить всё

ip dns server
ip domain-lookup
и dhcp на локалку
но периодически в локалке инет перестает работать
пинги проходят только по айпишнику
nslookup <ya.ru> <ip cisco> - не пашет
nslookup <ya.ru> <ip прова> - работает

понимаю что проблема в днс, но почему он отваливается не пойму
еще заметил глюк
в таком состоянии команда show run на циске не выводит ничего

первый раз имею дело с цисками, подскажите куда копать
хех..

Хостинговая компания Host-Food.ru
Хостинг HostFood.ru
 

Услуги хостинговой компании Host-Food.ru

Хостинг HostFood.ru

Тарифы на хостинг в России, от 12 рублей: https://www.host-food.ru/tariffs/hosting/
Тарифы на виртуальные сервера (VPS/VDS/KVM) в РФ, от 189 руб.: https://www.host-food.ru/tariffs/virtualny-server-vps/
Выделенные сервера, Россия, Москва, от 2000 рублей (HP Proliant G5, Intel Xeon E5430 (2.66GHz, Quad-Core, 12Mb), 8Gb RAM, 2x300Gb SAS HDD, P400i, 512Mb, BBU):
https://www.host-food.ru/tariffs/vydelennyi-server-ds/
Недорогие домены в популярных зонах: https://www.host-food.ru/domains/

Аватара пользователя
skeletor
майор
Сообщения: 2507
Зарегистрирован: 2007-11-16 18:22:04
Откуда: Kiev
Контактная информация:

Re: cisco 831 отваливается DNS

Непрочитанное сообщение skeletor » 2008-05-28 10:13:16

Возможно циска глючная.
"Винда съела дрова и резет здесь не фурычит."
"Все говорят, что у меня /dev/hands криво и я всё делаю через /dev/ass. А у меня этих фалов вообще нет!"

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: cisco 831 отваливается DNS

Непрочитанное сообщение hizel » 2008-05-28 11:03:31

полное логирование включить и посмотреть логи
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

Аватара пользователя
squid
лейтенант
Сообщения: 683
Зарегистрирован: 2007-05-25 11:32:23
Откуда: Украина, Киев
Контактная информация:

Re: cisco 831 отваливается DNS

Непрочитанное сообщение squid » 2008-05-28 11:50:30

hizel писал(а):полное логирование включить и посмотреть логи
а можно примеры команд ?
squid писал(а):первый раз имею дело с цисками
хех..

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: cisco 831 отваливается DNS

Непрочитанное сообщение hizel » 2008-05-28 12:44:51

в консоли

Код: Выделить всё

conf t
logging console debug
end
это вариант чтобы выводил на консоль
а вобще посмотреть какие варианты на вашей IOS возможны
написать logging ?

буфер логов смотрится
show logging

а также листнуть офсайт, например тут
http://www.cisco.com/en/US/docs/routers ... e/swg.html
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

Аватара пользователя
squid
лейтенант
Сообщения: 683
Зарегистрирован: 2007-05-25 11:32:23
Откуда: Украина, Киев
Контактная информация:

Re: cisco 831 отваливается DNS

Непрочитанное сообщение squid » 2008-05-28 19:42:25

вот, думаю проблема в памяти, если да то что можно сделать, конфиг ниже, ночью собираюсь перегрузить когда не будет народу
что можно еще поправить в конфиге может там что то личшнее, конфиг сам сочинял ;) ?

Код: Выделить всё

cisco#show version
Cisco IOS Software, C831 Software (C831-K9O3SY6-M), Version 12.3(4)T,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2003 by Cisco Systems, Inc.
Compiled Sat 25-Oct-03 19:17 by ccai

ROM: System Bootstrap, Version 12.2(8r)YN, RELEASE SOFTWARE (fc1)

cisco uptime is 1 day, 22 hours, 46 minutes
System returned to ROM by power-on
System image file is "flash:c831-k9o3sy6-mz.123-4.T.bin"
часть лога

Код: Выделить всё

-Process= "Chunk Manager", ipl= 4, pid= 1
-Traceback= 80176AD4 80178610 80188924 80187B58 801878DC 8016B7AC 8016FF78
*Mar  2 03:11:37.845: %SYS-2-CHUNKEXPANDFAIL: Could not expand chunk pool for ipnat entry. No memory available
-Process= "Chunk Manager", ipl= 4, pid= 1
-Traceback= 80187924 8016B7AC 8016FF78
*Mar  2 22:26:29.704: %SYS-5-CONFIG_I: Configured from console by andrey on vty0 (192.168.0.7)
*Mar  2 22:26:32.532: %SYS-2-MALLOCFAIL: Memory allocation of 131072 bytes failed from 0x800815FC, alignment 0
Pool: Processor  Free: 421156  Cause: Memory fragmentation
Alternate Pool: None  Free: 0  Cause: No Alternate pool

Код: Выделить всё

cisco#sh startup-config
Using 1314 out of 131072 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cisco
!
boot-start-marker
boot-end-marker
!
no logging console
enable password ХХХХХХХХХХХХ
!
username andrey privilege 15 password ХХХХХХХХХХХХ
aaa new-model
!
!
aaa session-id common
ip subnet-zero
no ip domain lookup
ip domain name cisco.test
!
ip dhcp pool my_pool
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 10.100.100.1
!
!
ip ftp username andrey
ip ftp password ХХХХХХХХХХХХХХХХ
ip audit notify log
ip audit po max-events 100
ip ssh version 2
no ftp-server write-enable
!
!
!
no crypto isakmp enable
!
!
!
!
interface Ethernet0
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
!
interface Ethernet1
 ip address dhcp
 ip nat outside
 duplex auto
!
ip nat inside source list 100 interface Ethernet1 overload
ip classless
no ip http server
no ip http secure-server
!
!
access-list 100 permit ip any any
!
control-plane
!
!
line con 0
 no modem enable
 transport preferred all
 transport output all
 speed 115200
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 transport preferred all
 transport input all
 transport output all
!
scheduler max-task-time 5000
!
end

Код: Выделить всё

CPU utilization for five seconds: 7%/2%; one minute: 7%; five minutes: 7%

Код: Выделить всё

cisco#sh processes memory
Total: 14372124, Used: 12125264, Free: 2246860
хех..

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: cisco 831 отваливается DNS

Непрочитанное сообщение hizel » 2008-05-28 21:55:29

стрянно конечно, что памяти даже на нат не хватает
может прошивочку обновить?
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.

Аватара пользователя
squid
лейтенант
Сообщения: 683
Зарегистрирован: 2007-05-25 11:32:23
Откуда: Украина, Киев
Контактная информация:

Re: cisco 831 отваливается DNS

Непрочитанное сообщение squid » 2008-05-28 22:08:10

стоп, конфиг я уже подправил, поотключал что на мой взгяд ненужно
там днска работала, хттп, думаю вот ночью ребутнуть, если раньше спать не пойду, а то народ сидит качает сейчас скорость номарльная
по поводу обновить думал, но вроде говорят новая ИОС расчитана на 128, а здесь только 64
хех..

Аватара пользователя
squid
лейтенант
Сообщения: 683
Зарегистрирован: 2007-05-25 11:32:23
Откуда: Украина, Киев
Контактная информация:

Re: cisco 831 отваливается DNS

Непрочитанное сообщение squid » 2008-05-28 22:08:43

так дело все таки в памяти ?
хех..

Аватара пользователя
hizel
дядя поня
Сообщения: 9031
Зарегистрирован: 2007-06-29 10:05:02
Откуда: Выборг

Re: cisco 831 отваливается DNS

Непрочитанное сообщение hizel » 2008-05-28 22:24:14

ну ваши логи, довольно четко на это указывают :\
В дурацкие игры он не играет. Он просто жуткий, чу-чу, паровозик, и зовут его Блейн. Блейн --- это Боль.